summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2013-04-03 17:49:00 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 10:48:40 +0200
commitc7e3389b054fe70119f660b0a19871f24ddb4e6b (patch)
tree63528a6638116be05b66629b1069fd7788fb07d8
parentBump firewall-mv: rename eth* -> net* in defaults (diff)
downloadmv-c7e3389b054fe70119f660b0a19871f24ddb4e6b.tar.gz
mv-c7e3389b054fe70119f660b0a19871f24ddb4e6b.tar.bz2
mv-c7e3389b054fe70119f660b0a19871f24ddb4e6b.zip
Fix zsh with texinfo-5. Make all patches -p1
-rw-r--r--app-portage/getdelta/files/eapi2.patch4
-rw-r--r--app-shells/auto-fu-zsh/files/exit.patch4
-rw-r--r--app-shells/auto-fu-zsh/files/reset-color.patch4
-rw-r--r--app-shells/auto-fu-zsh/files/zsh-compatibility.patch4
-rw-r--r--app-shells/zsh/ChangeLog7
-rw-r--r--app-shells/zsh/files/zsh-texi.patch30
-rw-r--r--app-shells/zsh/zsh-5.0.2-r2.ebuild (renamed from app-shells/zsh/zsh-5.0.2-r1.ebuild)3
-rw-r--r--net-print/foo2zjs/files/foo2zjs-20081129-udevfwld.patch4
-rw-r--r--sys-apps/less/files/code2color-0.2.patch4
-rw-r--r--sys-fs/squashfs-tools/files/squashfs-tools-3.3-progress-stderr.patch4
-rw-r--r--sys-fs/squashfs-tools/files/squashfs-tools-3.4-progress-stderr.patch4
-rw-r--r--sys-fs/squashfs-tools/files/squashfs-tools-4.0-progress-stderr.patch4
-rw-r--r--sys-fs/squashfs-tools/files/squashfs-tools-4.2_p20121216-progress-stderr.patch4
13 files changed, 59 insertions, 21 deletions
diff --git a/app-portage/getdelta/files/eapi2.patch b/app-portage/getdelta/files/eapi2.patch
index 7279ad72..5a8ce304 100644
--- a/app-portage/getdelta/files/eapi2.patch
+++ b/app-portage/getdelta/files/eapi2.patch
@@ -1,5 +1,5 @@
---- getdelta.sh
-+++ getdelta.sh
+--- 1/getdelta.sh
++++ 1/getdelta.sh
@@ -25,6 +25,17 @@
VERSION="0.7"
diff --git a/app-shells/auto-fu-zsh/files/exit.patch b/app-shells/auto-fu-zsh/files/exit.patch
index a4dfd743..a916f37f 100644
--- a/app-shells/auto-fu-zsh/files/exit.patch
+++ b/app-shells/auto-fu-zsh/files/exit.patch
@@ -1,5 +1,5 @@
---- auto-fu.zsh
-+++ auto-fu.zsh
+--- 1/auto-fu.zsh
++++ 1/auto-fu.zsh
@@ -287,7 +287,7 @@
afu-eof-maybe () {
diff --git a/app-shells/auto-fu-zsh/files/reset-color.patch b/app-shells/auto-fu-zsh/files/reset-color.patch
index fade13c6..12b5265b 100644
--- a/app-shells/auto-fu-zsh/files/reset-color.patch
+++ b/app-shells/auto-fu-zsh/files/reset-color.patch
@@ -1,5 +1,5 @@
---- auto-fu.zsh
-+++ auto-fu.zsh
+--- 1/auto-fu.zsh
++++ 1/auto-fu.zsh
@@ -370,7 +370,7 @@
[[ -z ${hi} ]] || region_highlight=("0 ${#BUFFER} ${hi}")
}
diff --git a/app-shells/auto-fu-zsh/files/zsh-compatibility.patch b/app-shells/auto-fu-zsh/files/zsh-compatibility.patch
index e8cd8776..1c2d546c 100644
--- a/app-shells/auto-fu-zsh/files/zsh-compatibility.patch
+++ b/app-shells/auto-fu-zsh/files/zsh-compatibility.patch
@@ -1,5 +1,5 @@
---- auto-fu.zsh
-+++ auto-fu.zsh
+--- 1/auto-fu.zsh
++++ 1/auto-fu.zsh
@@ -305,7 +305,11 @@
afu+vi-ins-mode () { zle -K afu ; }; zle -N afu+vi-ins-mode
afu+vi-cmd-mode () { zle -K afu-vicmd; }; zle -N afu+vi-cmd-mode
diff --git a/app-shells/zsh/ChangeLog b/app-shells/zsh/ChangeLog
index edd2ac06..542e32dc 100644
--- a/app-shells/zsh/ChangeLog
+++ b/app-shells/zsh/ChangeLog
@@ -2,9 +2,14 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*zsh-5.0.2-r2 (03 Apr 2013)
+
+ 03 Apr 2013; Martin Väth <martin@mvath.de>
+ Fix compilation with texinfo-5
+
*zsh-5.0.2-r1 (13 Jan 2013)
- 13 Jan 2012; Martin Väth <martin@mvath.de>
+ 13 Jan 2013; Martin Väth <martin@mvath.de>
Fix run-help generation by forcing width 80. Install run-help completion.
*zsh-5.0.2 (25 Dec 2012)
diff --git a/app-shells/zsh/files/zsh-texi.patch b/app-shells/zsh/files/zsh-texi.patch
new file mode 100644
index 00000000..24a72c6d
--- /dev/null
+++ b/app-shells/zsh/files/zsh-texi.patch
@@ -0,0 +1,30 @@
+--- 1/Doc/zsh.texi
++++ 1/Doc/zsh.texi
+@@ -22643,8 +22643,7 @@
+ described above.
+
+ @findex _pick_variant
+-@item @t{_pick_variant} [ @t{-b} @var{builtin-label} ] [ @t{-c}
+-@var{command} ] [ @t{-r} @var{name} ]
++@item @t{_pick_variant} [ @t{-b} @var{builtin-label} ] [ @t{-c} @var{command} ] [ @t{-r} @var{name} ]
+ @itemx @var{label}@t{=}@var{pattern} ... @var{label} [ @var{args} ... ]
+ This function is used to resolve situations where a single command name
+ requires more than one type of handling, either because it
+@@ -24981,14 +24980,9 @@
+ @var{targetwin} into the array named @var{array}.
+ These are, in order:
+ @table @asis
+-@item
+-The y and x coordinates of the cursor relative to the top left
+-of @var{targetwin}
+-@item
+-The y and x coordinates of the top left of @var{targetwin} on the
+-screen
+-@item
+-The size of @var{targetwin} in y and x dimensions.
++@item The y and x coordinates of the cursor relative to the top left of @var{targetwin}
++@item The y and x coordinates of the top left of @var{targetwin} on the screen
++@item The size of @var{targetwin} in y and x dimensions.
+ @end table
+
+ @noindent
diff --git a/app-shells/zsh/zsh-5.0.2-r1.ebuild b/app-shells/zsh/zsh-5.0.2-r2.ebuild
index 594ffe0c..549452c7 100644
--- a/app-shells/zsh/zsh-5.0.2-r1.ebuild
+++ b/app-shells/zsh/zsh-5.0.2-r2.ebuild
@@ -72,6 +72,9 @@ PDEPEND="
src_prepare() {
local i
+ # fix compilation issues with texinfo-5
+ epatch "${FILESDIR}"/zsh-texi.patch
+ sed -i -e '/^@item$/d' Doc/zsh.texi || die
# fix zshall problem with soelim
ln -s Doc man1
mv Doc/zshall.1 Doc/zshall.1.soelim
diff --git a/net-print/foo2zjs/files/foo2zjs-20081129-udevfwld.patch b/net-print/foo2zjs/files/foo2zjs-20081129-udevfwld.patch
index 8820d24b..808b32f1 100644
--- a/net-print/foo2zjs/files/foo2zjs-20081129-udevfwld.patch
+++ b/net-print/foo2zjs/files/foo2zjs-20081129-udevfwld.patch
@@ -1,5 +1,5 @@
---- Makefile
-+++ Makefile
+--- 1/Makefile
++++ 1/Makefile
@@ -20,6 +20,10 @@
PREFIX=/usr
PREFIX=$(DESTDIR)/usr
diff --git a/sys-apps/less/files/code2color-0.2.patch b/sys-apps/less/files/code2color-0.2.patch
index f8a78250..ffce21cb 100644
--- a/sys-apps/less/files/code2color-0.2.patch
+++ b/sys-apps/less/files/code2color-0.2.patch
@@ -1,5 +1,5 @@
---- code2color
-+++ code2color
+--- 1/code2color
++++ 1/code2color
@@ -163,11 +163,11 @@
# building up the database
# newer entries overwrite old ones
diff --git a/sys-fs/squashfs-tools/files/squashfs-tools-3.3-progress-stderr.patch b/sys-fs/squashfs-tools/files/squashfs-tools-3.3-progress-stderr.patch
index 4f1d0bdf..0392ba24 100644
--- a/sys-fs/squashfs-tools/files/squashfs-tools-3.3-progress-stderr.patch
+++ b/sys-fs/squashfs-tools/files/squashfs-tools-3.3-progress-stderr.patch
@@ -1,5 +1,5 @@
---- squashfs-tools/mksquashfs.c
-+++ squashfs-tools/mksquashfs.c
+--- 1/squashfs-tools/mksquashfs.c
++++ 1/squashfs-tools/mksquashfs.c
@@ -1832,17 +1832,17 @@
if(!progress || columns - used < 0)
return;
diff --git a/sys-fs/squashfs-tools/files/squashfs-tools-3.4-progress-stderr.patch b/sys-fs/squashfs-tools/files/squashfs-tools-3.4-progress-stderr.patch
index d06f9789..422d7c2b 100644
--- a/sys-fs/squashfs-tools/files/squashfs-tools-3.4-progress-stderr.patch
+++ b/sys-fs/squashfs-tools/files/squashfs-tools-3.4-progress-stderr.patch
@@ -1,5 +1,5 @@
---- squashfs-tools/mksquashfs.c
-+++ squashfs-tools/mksquashfs.c
+--- 1/squashfs-tools/mksquashfs.c
++++ 1/squashfs-tools/mksquashfs.c
@@ -2254,26 +2254,26 @@
int spaces = columns - used - hashes;
diff --git a/sys-fs/squashfs-tools/files/squashfs-tools-4.0-progress-stderr.patch b/sys-fs/squashfs-tools/files/squashfs-tools-4.0-progress-stderr.patch
index d6669773..832a17e2 100644
--- a/sys-fs/squashfs-tools/files/squashfs-tools-4.0-progress-stderr.patch
+++ b/sys-fs/squashfs-tools/files/squashfs-tools-4.0-progress-stderr.patch
@@ -1,5 +1,5 @@
---- squashfs-tools/mksquashfs.c
-+++ squashfs-tools/mksquashfs.c
+--- 1/squashfs-tools/mksquashfs.c
++++ 1/squashfs-tools/mksquashfs.c
@@ -2570,19 +2570,19 @@
previous = current;
}
diff --git a/sys-fs/squashfs-tools/files/squashfs-tools-4.2_p20121216-progress-stderr.patch b/sys-fs/squashfs-tools/files/squashfs-tools-4.2_p20121216-progress-stderr.patch
index 09d53d68..dd0c2279 100644
--- a/sys-fs/squashfs-tools/files/squashfs-tools-4.2_p20121216-progress-stderr.patch
+++ b/sys-fs/squashfs-tools/files/squashfs-tools-4.2_p20121216-progress-stderr.patch
@@ -1,5 +1,5 @@
---- progressbar.bak/progressbar.c
-+++ progressbar.bak/progressbar.c
+--- 1/progressbar.c
++++ 1/progressbar.c
@@ -119,19 +119,19 @@
previous = current;
}