summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2018-05-01 19:31:30 +0200
committerMartin Väth <martin@mvath.de>2018-05-01 19:31:30 +0200
commitcb80e492076d14e1dd8db1346298122a9ecd976e (patch)
tree8c0448eca3e13b1a75f4331e62c15d12d6177a9b
parentRemove mask for noscript: >=firefox-59 is in the gentoo repository (diff)
downloadmv-cb80e492076d14e1dd8db1346298122a9ecd976e.tar.gz
mv-cb80e492076d14e1dd8db1346298122a9ecd976e.tar.bz2
mv-cb80e492076d14e1dd8db1346298122a9ecd976e.zip
Fix mame dirs, sdlmame compilation, python deps
-rw-r--r--dev-util/pyrep/pyrep-1.5-r1.ebuild (renamed from dev-util/pyrep/pyrep-1.5.ebuild)4
-rw-r--r--dev-util/replacer/replacer-3.1-r1.ebuild (renamed from dev-util/replacer/replacer-3.1.ebuild)4
-rw-r--r--games-emulation/sdlmame/Manifest2
-rw-r--r--games-emulation/sdlmame/files/sdlmame-0.174-sdlSetWindow.patch13
-rw-r--r--games-emulation/sdlmame/sdlmame-0.174-r2.ebuild (renamed from games-emulation/sdlmame/sdlmame-0.174-r1.ebuild)6
-rw-r--r--games-emulation/xmame/xmame-0.106-r4.ebuild (renamed from games-emulation/xmame/xmame-0.106-r3.ebuild)2
-rw-r--r--games-emulation/xmess/xmess-0.106-r3.ebuild (renamed from games-emulation/xmess/xmess-0.106-r2.ebuild)2
-rw-r--r--metadata/pkg_desc_index10
8 files changed, 26 insertions, 17 deletions
diff --git a/dev-util/pyrep/pyrep-1.5.ebuild b/dev-util/pyrep/pyrep-1.5-r1.ebuild
index f2ade1ab..413760ec 100644
--- a/dev-util/pyrep/pyrep-1.5.ebuild
+++ b/dev-util/pyrep/pyrep-1.5-r1.ebuild
@@ -3,8 +3,6 @@
EAPI=6
RESTRICT="mirror"
-PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6}} )
-inherit python-any-r1
DESCRIPTION="Search and/or replace regular expressions within many files interactively"
HOMEPAGE="https://github.com/vaeth/pyrep/"
@@ -15,7 +13,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND="${PYTHON_DEPS}"
+RDEPEND="dev-lang/python"
src_prepare() {
use prefix || sed -i \
diff --git a/dev-util/replacer/replacer-3.1.ebuild b/dev-util/replacer/replacer-3.1-r1.ebuild
index a35d15aa..27e9e958 100644
--- a/dev-util/replacer/replacer-3.1.ebuild
+++ b/dev-util/replacer/replacer-3.1-r1.ebuild
@@ -3,8 +3,6 @@
EAPI=6
RESTRICT="mirror"
-PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6}} )
-inherit python-any-r1
DESCRIPTION="Search and replace python regular expressions within many files interactively"
HOMEPAGE="https://github.com/vaeth/replacer/"
@@ -19,7 +17,7 @@ for i in ${PLOCALES}; do
IUSE+=" l10n_${i}"
done
-RDEPEND="${PYTHON_DEPS}
+RDEPEND="dev-lang/python
nls? ( virtual/libintl )"
DEPEND="nls? ( sys-devel/gettext )"
diff --git a/games-emulation/sdlmame/Manifest b/games-emulation/sdlmame/Manifest
index 8b368284..c58d10af 100644
--- a/games-emulation/sdlmame/Manifest
+++ b/games-emulation/sdlmame/Manifest
@@ -1 +1 @@
-DIST mame-0.174.zip 95944685 BLAKE2B e97027edf7be293e599499bd428c663c1fc13498e2fe10ee356aa56ef8ba85d6ea003ba65a8cbc41d1159246eed354585fc18bf9507b47dc1774b87f5737b48d SHA512 9db4d98fb5f5373529808f3bc41fddefa65ebbf7c26d946ebf886cab25e5abf7c4d539d96dfd6af5e62f4366b2bb0b0b59d40fe7a722698f3707eb8ea4c12a0b
+DIST mame-0.174.zip 95944685 SHA512 9db4d98fb5f5373529808f3bc41fddefa65ebbf7c26d946ebf886cab25e5abf7c4d539d96dfd6af5e62f4366b2bb0b0b59d40fe7a722698f3707eb8ea4c12a0b
diff --git a/games-emulation/sdlmame/files/sdlmame-0.174-sdlSetWindow.patch b/games-emulation/sdlmame/files/sdlmame-0.174-sdlSetWindow.patch
new file mode 100644
index 00000000..ee9a7ca0
--- /dev/null
+++ b/games-emulation/sdlmame/files/sdlmame-0.174-sdlSetWindow.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/634662
+Author of patch: Rick Harris
+--- a/3rdparty/bgfx/include/bgfx/bgfxplatform.h
++++ b/3rdparty/bgfx/include/bgfx/bgfxplatform.h
+@@ -253,7 +253,7 @@
+
+ #endif // BX_PLATFORM_
+
+-#if defined(_SDL_syswm_h)
++#if defined(_SDL_syswm_h) || defined(SDL_syswm_h_)
+ // If SDL_syswm.h is included before bgfxplatform.h we can enable SDL window
+ // interop convenience code.
+
diff --git a/games-emulation/sdlmame/sdlmame-0.174-r1.ebuild b/games-emulation/sdlmame/sdlmame-0.174-r2.ebuild
index 0a8aa8e0..d526d46f 100644
--- a/games-emulation/sdlmame/sdlmame-0.174-r1.ebuild
+++ b/games-emulation/sdlmame/sdlmame-0.174-r2.ebuild
@@ -44,8 +44,7 @@ RDEPEND="!games-emulation/sdlmametools
dev-qt/qtgui:5
dev-qt/qtwidgets:5 )
x11-libs/libX11
- x11-libs/libXinerama
- ${PYTHON_DEPS}"
+ x11-libs/libXinerama"
DEPEND="${RDEPEND}
${PYTHON_DEPS}
app-arch/unzip
@@ -77,7 +76,8 @@ src_unpack() {
src_prepare() {
eapply \
"${FILESDIR}"/${P}-qt.patch \
- "${FILESDIR}"/${P}-cxx14.patch
+ "${FILESDIR}"/${P}-cxx14.patch \
+ "${FILESDIR}"/${P}-sdlSetWindow.patch
# Disable using bundled libraries
enable_feature USE_SYSTEM_LIB_EXPAT
enable_feature USE_SYSTEM_LIB_FLAC
diff --git a/games-emulation/xmame/xmame-0.106-r3.ebuild b/games-emulation/xmame/xmame-0.106-r4.ebuild
index 3ddee75e..e7bb7c97 100644
--- a/games-emulation/xmame/xmame-0.106-r3.ebuild
+++ b/games-emulation/xmame/xmame-0.106-r4.ebuild
@@ -201,7 +201,7 @@ src_install() {
fi
done
- insinto "/usr/share/games/${PN}"
+ insinto "/usr/share/${PN}"
doins -r ctrlr
dodoc doc/{changes.*,*.txt,mame/*,${TARGET}rc.dist} README todo
docinto html
diff --git a/games-emulation/xmess/xmess-0.106-r2.ebuild b/games-emulation/xmess/xmess-0.106-r3.ebuild
index 831b0ff6..850f45ba 100644
--- a/games-emulation/xmess/xmess-0.106-r2.ebuild
+++ b/games-emulation/xmess/xmess-0.106-r3.ebuild
@@ -201,7 +201,7 @@ src_install() {
fi
done
- insinto "/usr/share/games/${PN}"
+ insinto "/usr/share/${PN}"
doins -r ctrlr
dodoc doc/{changes.*,*.txt,mame/*,${TARGET}rc.dist} README todo
docinto html
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index 89bd5333..99885b34 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -56,14 +56,14 @@ dev-tex/chklref 2.6.0: Finds useless references in latex files or unnecessarily
dev-util/comp 4.3: compare files or directories, including metadata
dev-util/diffhelp 1.11: A frontend, beautifier, and path-fixer for diff -u
dev-util/mv_perl 3.16: A collection of perl scripts (replacement in files, syncing dirs etc)
-dev-util/pyrep 1.5: Search and/or replace regular expressions within many files interactively
-dev-util/replacer 3.1: Search and replace python regular expressions within many files interactively
+dev-util/pyrep 1.5-r1: Search and/or replace regular expressions within many files interactively
+dev-util/replacer 3.1-r1: Search and replace python regular expressions within many files interactively
dev-vcs/git-wrappers-mv 1.17: Some personal wrappers for the most important git commands
games-action/trackballs 1.1.4-r1: simple game similar to the classical game Marble Madness
games-board/chessproblem 1.8 2.9: Find solutions of chess problems (mate, selfmate, and helpmate) with cooks
-games-emulation/sdlmame 0.174-r1: Multiple Arcade Machine Emulator + Multi Emulator Super System (MESS)
-games-emulation/xmame 0.106-r3: Multiple Arcade Machine Emulator for X11
-games-emulation/xmess 0.106-r2: Multiple Arcade Machine Emulator for X11
+games-emulation/sdlmame 0.174-r2: Multiple Arcade Machine Emulator + Multi Emulator Super System (MESS)
+games-emulation/xmame 0.106-r4: Multiple Arcade Machine Emulator for X11
+games-emulation/xmess 0.106-r3: Multiple Arcade Machine Emulator for X11
games-engines/freesci 0.6.4-r1: Sierra script interpreter for your old Sierra adventures
games-rpg/aklabeth 1.0-r1: A remake of Richard C. Garriott's Ultima prequel
games-rpg/dsa-stats 1.0: calculate stat probabalities for the role playing game DSA - Das schwarze Auge