summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2014-11-01 08:06:53 +0100
committerMartin Väth <martin@mvath.de>2015-10-11 10:49:19 +0200
commitf8266ead5fd6b885718eb94b240ad8bb3608412a (patch)
tree0a1ec87bfed0dbdb7ea37110196602d20ffd1dfb
parentBump squashmount (diff)
downloadmv-f8266ead5fd6b885718eb94b240ad8bb3608412a.tar.gz
mv-f8266ead5fd6b885718eb94b240ad8bb3608412a.tar.bz2
mv-f8266ead5fd6b885718eb94b240ad8bb3608412a.zip
systemd-cron[etc-crontab]
-rw-r--r--profiles/use.local.desc1
-rw-r--r--sys-process/systemd-cron/ChangeLog5
-rw-r--r--sys-process/systemd-cron/metadata.xml1
-rw-r--r--sys-process/systemd-cron/systemd-cron-1.3.3-r1.ebuild (renamed from sys-process/systemd-cron/systemd-cron-1.3.3.ebuild)16
4 files changed, 21 insertions, 2 deletions
diff --git a/profiles/use.local.desc b/profiles/use.local.desc
index 22c2e81b..9f571e27 100644
--- a/profiles/use.local.desc
+++ b/profiles/use.local.desc
@@ -115,4 +115,5 @@ sys-fs/squash_dir:unionfs-fuse - Prefer unionfs-fuse
sys-fs/squashfs-tools:lz4 - Enable support for LZ4 compression using app-arch/lz4
sys-fs/squashfs-tools:xz - Enable support for XZ ("LZMA2") compression using app-arch/xz-utils
sys-process/systemd-cron:cron-boot - Enable systemd boot cron target
+sys-process/systemd-cron:etc-crontab - Use /etc/crontab; disable this when you have the sys-process/dcron default file here
sys-process/systemd-cron:yearly - Enable systemd yearly cron target
diff --git a/sys-process/systemd-cron/ChangeLog b/sys-process/systemd-cron/ChangeLog
index 0dd741f1..858c0177 100644
--- a/sys-process/systemd-cron/ChangeLog
+++ b/sys-process/systemd-cron/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*systemd-cron-1.3.3-r1 (01 Nov 2014)
+
+ 01 Nov 2014; Martin Väth <martin@mvath.de>:
+ Add USE=etc-crontab. Bump to alert users
+
*systemd-cron-1.3.3 (23 Oct 2014)
23 Oct 2014; Martin Väth <martin@mvath.de>:
diff --git a/sys-process/systemd-cron/metadata.xml b/sys-process/systemd-cron/metadata.xml
index ef4e4c09..a22e7cd5 100644
--- a/sys-process/systemd-cron/metadata.xml
+++ b/sys-process/systemd-cron/metadata.xml
@@ -15,6 +15,7 @@
</upstream>
<use>
<flag name="cron-boot">Enable systemd boot cron target</flag>
+ <flag name="etc-crontab">Use /etc/crontab; disable this when you have the sys-process/dcron default file here</flag>
<flag name="yearly">Enable systemd yearly cron target</flag>
</use>
</pkgmetadata>
diff --git a/sys-process/systemd-cron/systemd-cron-1.3.3.ebuild b/sys-process/systemd-cron/systemd-cron-1.3.3-r1.ebuild
index f0a864de..e62b9254 100644
--- a/sys-process/systemd-cron/systemd-cron-1.3.3.ebuild
+++ b/sys-process/systemd-cron/systemd-cron-1.3.3-r1.ebuild
@@ -14,7 +14,7 @@ SRC_URI="https://github.com/dbent/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="cron-boot yearly"
+IUSE="cron-boot +etc-crontab yearly"
RDEPEND=">=sys-apps/systemd-212
sys-apps/debianutils"
@@ -25,7 +25,10 @@ src_prepare() {
python_fix_shebang --force "${S}/src/bin"
sed -i \
-e 's/^crontab/crontab-systemd/' \
- "${S}/src/man/crontab.1.in"
+ "${S}/src/man/crontab.1.in" || die
+ use etc-crontab || sed -i \
+ -e "s!\\[*'/etc/crontab'\\]*[ + ]*!!" \
+ "${S}/src/bin/systemd-crontab-generator" || die
epatch_user
}
@@ -54,3 +57,12 @@ src_install() {
mv "${ED}"/usr/share/man/man1/crontab{,-systemd}.1 || die
mv "${ED}"/usr/share/man/man5/crontab{,-systemd}.5 || die
}
+
+pkg_postinst() {
+ if use etc-crontab && {
+ has_version sys-process/dcron || ! has_version virtual/cron
+ }
+ then ewarn "sys-process/systemd-cron[etc-crontab] does not work with the /etc/crontab"
+ ewarn "installed by sys-process/dcron"
+ fi
+}