summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2024-01-15 21:15:46 +0100
committerMartin Väth <martin@mvath.de>2024-01-15 21:21:00 +0100
commitfa933c23f5fe55f19355ea9292eb7ca8b32f27d4 (patch)
treea46f5f5e2c64522d7ca2fba2869930eb500878c3
parentdev-util/meson* -> dev-build/meson*. Thanks to https://github.com/xfzv. (diff)
downloadmv-fa933c23f5fe55f19355ea9292eb7ca8b32f27d4.tar.gz
mv-fa933c23f5fe55f19355ea9292eb7ca8b32f27d4.tar.bz2
mv-fa933c23f5fe55f19355ea9292eb7ca8b32f27d4.zip
sci-geosciences/googleearth: bump. Thanks to aliaksei.urbanski at gmail.com
Signed-off-by: Martin Väth <martin@mvath.de>
-rw-r--r--metadata/pkg_desc_index2
-rw-r--r--sci-geosciences/googleearth/Manifest1
-rw-r--r--sci-geosciences/googleearth/googleearth-7.3.6.ebuild134
3 files changed, 136 insertions, 1 deletions
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index e82deac6..8695b22d 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -95,7 +95,7 @@ net-misc/netctl 1.11: Profile based network connection tool from Arch Linux
net-misc/openrdate 1.2: use TCP or UDP to retrieve the current time of another machine
net-misc/sshstart 4.10-r1: Start ssh-agent/ssh-add only if you really use ssh or friends
net-print/foo2zjs 20200221: Support for printing to ZjStream-based printers
-sci-geosciences/googleearth 7.1.8.3036-r4 7.3.0.3832-r4 7.3.4-r2: A 3D interface to the planet
+sci-geosciences/googleearth 7.1.8.3036-r4 7.3.0.3832-r4 7.3.4-r2 7.3.6: A 3D interface to the planet
sci-mathematics/reduce 20141130-r3 20190413: A general-purpose computer algebra system
sys-apps/cpi 3.2: A wrapper for cp -i -a, making use of diff
sys-apps/less 643-r1: Excellent text file viewer, optionally with additional selection feature
diff --git a/sci-geosciences/googleearth/Manifest b/sci-geosciences/googleearth/Manifest
index 1210333d..c0521f4f 100644
--- a/sci-geosciences/googleearth/Manifest
+++ b/sci-geosciences/googleearth/Manifest
@@ -3,3 +3,4 @@ DIST google-earth-pro-stable_7.1.8.3036-r0_i386.deb 44460270 BLAKE2B 833bccfddee
DIST google-earth-pro-stable_7.3.0.3832-r0_amd64.deb 57842874 BLAKE2B c82c37226b57e99e47ea85fc42d6c468d54b973b10d0a072f0b11813c7a97a0523af81fe7bc78a92e5e05526bdaed984d69004b44e917494fd4443687cb25c5c SHA512 af75d6dc223983aba7f84685c8f12bb06b4972fe0a50a883c5ee3321c37b16cd25ac7c60da3c80f4bf7cec41011827fab9f66ba2c9c3f404cd7270f610815251
DIST google-earth-pro-stable_7.3.0.3832-r0_i386.deb 56685312 BLAKE2B b795026c371e0e768abca9ea077760bce51c2e0d3709f2b7f012db5826458615cf1790afab228ef66b7d81cca100e74d568216bdd1564a297b35b4b1d172c9e5 SHA512 7bdf9cdf5d431b55ccc02e15e9f58bb9b3ed6590a6f53afe7202ba2d8fd38be333e9bfe273ea64502a78fb4263021da15b16cf474ea48a3742f0ce622eb8d151
DIST google-earth-pro-stable_7.3.4-r1_amd64.deb 55955782 BLAKE2B 5db867a47f4f8695da0fa2e960f8dcbd0371cb703928642ed7a99b67d58ad859a6ff8e0fe33a0b1c2bccc5a5e6baa9c91cdd464407fcb49bbb7fe65d0631f9ae SHA512 084cc8f3faecd0c700f3a6c75535c12d0d9ad5847a6f316b4828a11fef9c3282f2b9099bdfa80af4bc24ab713e614287d35ae680459a267ae615a2893ddb530f
+DIST google-earth-pro-stable_7.3.6_amd64.deb 57717580 BLAKE2B 38bb64b80bc494218bee8b561695606581690cd4818a734cc9946f61fbc9a0c97ed8722cdfde4375d76d908607ab92858eb4a9a5f48f6295cdc46a1072e44886 SHA512 675afdccf726b65d167b5c3b19c4662f20f15c4f95833a690bc06b8d7ebf72d76590261549818d1b543c4d844468f78d710cdf8b4179a0bb5c0e6e27172427c4
diff --git a/sci-geosciences/googleearth/googleearth-7.3.6.ebuild b/sci-geosciences/googleearth/googleearth-7.3.6.ebuild
new file mode 100644
index 00000000..566d9d60
--- /dev/null
+++ b/sci-geosciences/googleearth/googleearth-7.3.6.ebuild
@@ -0,0 +1,134 @@
+# Copyright 1999-2024 Martin V\"ath and others
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop pax-utils unpacker wrapper xdg-utils
+
+DESCRIPTION="A 3D interface to the planet"
+HOMEPAGE="https://www.google.com/earth/desktop/"
+SRC_URI="https://dl.google.com/dl/linux/direct/google-earth-pro-stable_${PV}_amd64.deb"
+LICENSE="googleearth GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="mirror splitdebug"
+IUSE=""
+
+QA_PREBUILT="*"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/nspr
+ media-libs/fontconfig
+ media-libs/freetype
+ media-libs/gstreamer:1.0=
+ media-libs/gst-plugins-base:1.0=
+ net-libs/libproxy
+ net-misc/curl
+ sys-devel/gcc[cxx]
+ sys-libs/zlib
+ virtual/glu
+ virtual/opengl
+ virtual/ttf-fonts
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXext
+ x11-libs/libXrender
+ x11-libs/libXau
+ x11-libs/libXdmcp"
+# sci-libs/gdal-1*
+BDEPEND="dev-util/patchelf"
+
+S=${WORKDIR}/opt/google/earth/pro
+
+src_unpack() {
+ # default src_unpack fails with deb2targz installed, also this unpacks the data.tar.lzma as well
+ unpack_deb ${A}
+}
+
+src_prepare() {
+
+ # we have no ld-lsb.so.3 symlink
+ # thanks to Nathan Phillip Brink <ohnobinki@ohnopublishing.net> for suggesting patchelf
+ einfo "running patchelf"
+ patchelf --set-interpreter /$(get_libdir)/ld-linux$(usex amd64 "-x86-64" "").so.2 ${PN}-bin || die "patchelf failed"
+
+ # Set RPATH for preserve-libs handling (bug #265372).
+ local x
+ for x in * ; do
+ # Use \x7fELF header to separate ELF executables and libraries
+ [[ -f ${x} && $(od -t x1 -N 4 "${x}") == *"7f 45 4c 46"* ]] || continue
+ chmod u+w "${x}" || die
+ [[ ${x} != libicudata.so.* ]] || continue
+ patchelf --set-rpath '$ORIGIN' "${x}" || \
+ die "patchelf failed on ${x}"
+ done
+ for x in plugins/*.so ; do
+ [[ -f ${x} ]] || continue
+ chmod u+w "${x}" || die
+ patchelf --set-rpath '$ORIGIN/..' "${x}" || \
+ die "patchelf failed on ${x}"
+ done
+ for x in plugins/imageformats/*.so ; do
+ [[ -f ${x} ]] || continue
+ chmod u+w "${x}" || die
+ patchelf --set-rpath '$ORIGIN/../..' "${x}" || \
+ die "patchelf failed on ${x}"
+ done
+
+ eapply -p0 "${FILESDIR}"/${PN}-${PV%%.*}-pro-desktopfile.patch
+ default
+}
+
+src_install() {
+ make_wrapper ${PN} ./${PN} /opt/${PN} .
+
+ insinto /usr/share/mime/packages
+ doins "${FILESDIR}/${PN}-mimetypes.xml" || die
+
+ domenu google-earth-pro.desktop
+
+ local size
+ for size in 16 22 24 32 48 64 128 256 ; do
+ newicon -s ${size} product_logo_${size}.png google-earth-pro.png
+ done
+
+ rm -rf xdg-mime xdg-settings google-earth-pro google-earth-pro.desktop product_logo_*
+
+ insinto /opt/${PN}
+ doins -r *
+
+ chmod +x "${ED}"/opt/${PN}/{${PN}{,-bin},repair_tool,gpsbabel} || die
+ find "${ED}" -type f '(' -name '*.so.*' -o -name '*.so' ')' -exec chmod +x '{}' + || die
+
+ pax-mark -m "${ED}"/opt/${PN}/${PN}-bin
+}
+
+pkg_postinst() {
+ elog "When you get a crash starting Google Earth, try adding a file ~./.config/Google/GoogleEarthPlus.conf"
+ elog "with the following options:"
+ elog "lastTip = 4"
+ elog "enableTips = false"
+ elog ""
+ elog "In addition, the use of free video drivers may cause problems associated with using the Mesa"
+ elog "library. In this case, Google Earth 6x likely only works with the Gallium3D variant."
+ elog "To select the 32bit graphic library use the command:"
+ elog " eselect mesa list"
+ elog "For example, for Radeon R300 (x86):"
+ elog " eselect mesa set r300 2"
+ elog "For Intel Q33 (amd64):"
+ elog " eselect mesa set 32bit i965 2"
+ elog "You may need to restart X afterwards"
+
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ xdg_icon_cache_update
+}