summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2021-01-16 12:04:31 +0100
committerMartin Väth <martin@mvath.de>2021-01-16 12:04:31 +0100
commit00ed8667bcbbcafa410c898f66d9e8a1701e9fa6 (patch)
tree95c6beb4108b9707b63ffbf80de27000fdf242f3 /net-libs/wvstreams
parentapp-portage/eix: Version bump (diff)
downloadmv-00ed8667bcbbcafa410c898f66d9e8a1701e9fa6.tar.gz
mv-00ed8667bcbbcafa410c898f66d9e8a1701e9fa6.tar.bz2
mv-00ed8667bcbbcafa410c898f66d9e8a1701e9fa6.zip
net-misc/openrdate: fix compilation without sys/sysctl.h. -net-libs/wvstreams
Signed-off-by: Martin Väth <martin@mvath.de>
Diffstat (limited to 'net-libs/wvstreams')
-rw-r--r--net-libs/wvstreams/Manifest1
-rw-r--r--net-libs/wvstreams/metadata.xml23
-rw-r--r--net-libs/wvstreams/wvstreams-4.6.2_alpha20181025.ebuild99
3 files changed, 0 insertions, 123 deletions
diff --git a/net-libs/wvstreams/Manifest b/net-libs/wvstreams/Manifest
deleted file mode 100644
index d03f8454..00000000
--- a/net-libs/wvstreams/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST wvstreams-4.6.2_alpha20181025.tar.gz 851502 SHA512 9dc3502566b12ad52c134aec2682ad5d5a1a426621ee90e7055e1ebb712f768bbf4270d1045eadf6b842ceabaf5abb67bdf5c7bfa12f983a9d3a27a1730a72cf
diff --git a/net-libs/wvstreams/metadata.xml b/net-libs/wvstreams/metadata.xml
deleted file mode 100644
index d2ce9f15..00000000
--- a/net-libs/wvstreams/metadata.xml
+++ /dev/null
@@ -1,23 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="person">
-<email>mvaeth@google.com</email>
-<name>Martin Väth</name>
-<description>maintainer of the updates in the mv overlay</description>
-</maintainer>
-<maintainer type='person'>
-<email>jer@gentoo.org</email>
-</maintainer>
- <upstream>
- <remote-id type="google-code">wvstreams</remote-id>
- </upstream>
- <use>
- <flag name="boost">
- Use <pkg>dev-libs/boost</pkg> to provide TR1-compatible
- functional interface. This USE flag is only needed with GCC
- earlier than version 4.1, or with other compilares not providing
- said interface.
- </flag>
- </use>
-</pkgmetadata>
diff --git a/net-libs/wvstreams/wvstreams-4.6.2_alpha20181025.ebuild b/net-libs/wvstreams/wvstreams-4.6.2_alpha20181025.ebuild
deleted file mode 100644
index 73d23424..00000000
--- a/net-libs/wvstreams/wvstreams-4.6.2_alpha20181025.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2018 Martin V\"ath and Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-AT_NOELIBTOOLIZE=yes
-inherit autotools flag-o-matic toolchain-funcs
-
-DESCRIPTION="A network programming library in C++"
-HOMEPAGE="http://alumnit.ca/wiki/?WvStreams"
-case ${PV} in
-*alpha*)
- EGIT_COMMIT="dac7d0f784845a8b43d45f64fdf43fd5f4833a34"
- SRC_URI="https://github.com/apenwarr/wvstreams/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- S=${WORKDIR}/${PN}-${EGIT_COMMIT};;
-*)
- SRC_URI="https://wvstreams.googlecode.com/files/${P}.tar.gz"
-esac
-
-
-LICENSE="GPL-2"
-SLOT="0/5pre"
-KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
-IUSE="pam +dbus debug doc +ssl static-libs zlib"
-
-#Tests fail if openssl is not compiled with -DPURIFY. Gentoo's isn't. FAIL!
-RESTRICT="test"
-
-#QA Fail: xplc is compiled as a part of wvstreams.
-#It'll take a larger patching effort to get it extracted, since upstream integrated it
-#more tightly this time. Probably for the better since upstream xplc seems dead.
-
-RDEPEND="
- ssl? ( >=dev-libs/openssl-1.1:0= )
- sys-libs/readline:0=
- zlib? ( sys-libs/zlib )
- dbus? ( >=sys-apps/dbus-1.4.20 )
- pam? ( virtual/pam )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
-"
-
-src_prepare() {
- mv config.ac configure.ac
- mkdir build
- default
- eautoreconf
-}
-
-src_configure() {
- append-flags -fno-strict-aliasing
- append-flags -fno-tree-dce -fno-optimize-sibling-calls #421375
-
- tc-export AR CC CXX
-
- cd build
- ECONF_SOURCE="$S" econf \
- $(use_enable debug) \
- $(use_with dbus) \
- $(use_with pam) \
- $(use_with ssl openssl) \
- $(use_with zlib) \
- --cache-file="${BUILD_DIR}"/config.cache \
- --disable-optimization \
- --localstatedir=/var \
- --without-qt \
- --without-valgrind
-}
-
-src_compile() {
- if use doc; then
- doxygen "${S}"/Doxyfile || die
- fi
- cd build
- emake
-}
-
-src_test() {
- emake check
-}
-
-src_install() {
- if use doc; then
- docinto html
- dodoc -r Docs/doxy-html/*
- fi
- cd build
- emake DESTDIR="${ED}" install || die
- insinto /usr/include
- doins include/wvautoconf.h
- insinto /usr/$(get_libdir)/pkgconfig
- local lib
- for lib in $(find "${BUILD_DIR}" -name '*.so' -type l | grep -v libwvstatic); do
- doins "${BUILD_DIR}"/pkgconfig/$(basename ${lib/.so}).pc
- done
- use static-libs || find "${ED}" -name '*.a' -delete || die
-}