summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2017-07-19 16:54:16 +0200
committerMartin Väth <martin@mvath.de>2017-07-19 16:54:16 +0200
commita55a854916664d897e57a634932fc48937edca5f (patch)
treedb1fa085cbb038f2434f4079fa4f7bb3da8f115a /sci-mathematics
parentsys-power/nut: Add to fix system-shutdown path (diff)
downloadmv-a55a854916664d897e57a634932fc48937edca5f.tar.gz
mv-a55a854916664d897e57a634932fc48937edca5f.tar.bz2
mv-a55a854916664d897e57a634932fc48937edca5f.zip
Make repoman happy
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/genius/metadata.xml46
-rw-r--r--sci-mathematics/reduce/reduce-20141130-r1.ebuild10
-rw-r--r--sci-mathematics/reduce/reduce-20141130-r2.ebuild106
3 files changed, 134 insertions, 28 deletions
diff --git a/sci-mathematics/genius/metadata.xml b/sci-mathematics/genius/metadata.xml
index dbeb2617..cc2f5351 100644
--- a/sci-mathematics/genius/metadata.xml
+++ b/sci-mathematics/genius/metadata.xml
@@ -1,27 +1,27 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>martin@mvath.de</email>
- <name>Martin Väth</name>
- <description>maintainer of the updates in the mv overlay</description>
- </maintainer>
- <maintainer type="person">
- <email>grozin@gentoo.org</email>
- <name>Andrey Grozin</name>
- </maintainer>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
- </maintainer>
- <longdescription>Genius is a calculator program which can work
- with arbitrary precision integers, multiple precision floats,
- rational numbers, complex numbers, linear algebra, number theory,
- numerical calculus, statistics, numerical equation solving,
- combinatorics, elementary functions, modular arithmetic.
- It has a programming language with automatic typing.
- It can do various 2D and 3D plots, with possibility
- to export to eps or png. Genius has a GUI IDE.
- It can output matrices in LaTeX, Troff (eqn) or MathML.
- </longdescription>
+<maintainer type="person">
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ <description>maintainer of the updates in the mv overlay</description>
+</maintainer>
+<maintainer type="person">
+ <email>grozin@gentoo.org</email>
+ <name>Andrey Grozin</name>
+</maintainer>
+<maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+</maintainer>
+<longdescription>Genius is a calculator program which can work
+ with arbitrary precision integers, multiple precision floats,
+ rational numbers, complex numbers, linear algebra, number theory,
+ numerical calculus, statistics, numerical equation solving,
+ combinatorics, elementary functions, modular arithmetic.
+ It has a programming language with automatic typing.
+ It can do various 2D and 3D plots, with possibility
+ to export to eps or png. Genius has a GUI IDE.
+ It can output matrices in LaTeX, Troff (eqn) or MathML.
+</longdescription>
</pkgmetadata>
diff --git a/sci-mathematics/reduce/reduce-20141130-r1.ebuild b/sci-mathematics/reduce/reduce-20141130-r1.ebuild
index cec32d89..40fb04d5 100644
--- a/sci-mathematics/reduce/reduce-20141130-r1.ebuild
+++ b/sci-mathematics/reduce/reduce-20141130-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2016 Gentoo Foundation
+# Copyright 2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -83,12 +83,12 @@ src_install() {
doins reduce.img csl.img
insinto /usr/share/${PN}
doins -r ${PN}.doc
- mv "${D}"usr/share/${PN}/${PN}.doc "${D}"usr/share/${PN}/doc
- dosym /usr/share/${PN}/doc /usr/${lib}/${PN}/${PN}.doc
+ mv -- "${ED}"usr/share/${PN}/${PN}.doc "${ED}"usr/share/${PN}/doc
+ dosym ../../share/${PN}/doc /usr/${lib}/${PN}/${PN}.doc
if use X; then
doins -r ${PN}.fonts
- mv "${D}"usr/share/${PN}/${PN}.fonts "${D}"usr/share/${PN}/fonts
- dosym /usr/share/${PN}/fonts /usr/${lib}/${PN}/${PN}.fonts
+ mv -- "${ED}"usr/share/${PN}/${PN}.fonts "${ED}"usr/share/${PN}/fonts
+ dosym ../../share/${PN}/fonts /usr/${lib}/${PN}/${PN}.fonts
fi
popd > /dev/null
diff --git a/sci-mathematics/reduce/reduce-20141130-r2.ebuild b/sci-mathematics/reduce/reduce-20141130-r2.ebuild
new file mode 100644
index 00000000..40fb04d5
--- /dev/null
+++ b/sci-mathematics/reduce/reduce-20141130-r2.ebuild
@@ -0,0 +1,106 @@
+# Copyright 2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+RESTRICT="mirror"
+inherit elisp-common
+
+DESCRIPTION="A general-purpose computer algebra system"
+HOMEPAGE="http://reduce-algebra.sourceforge.net/
+ http://reduce-algebra.com/"
+IUSE="doc emacs gnuplot X"
+PVyear=${PV%????}
+PVday=${PV#??????}
+PVmonth=${PV#????}
+PVmonth=${PVmonth%??}
+mPV="${PVyear}-${PVmonth}-${PVday}"
+TARBALL="${PN}-src-${mPV}"
+SRC_URI="mirror://sourceforge/${PN}-algebra/Snapshot_${mPV}/${TARBALL}.tar.bz2"
+LICENSE="BSD-2 X? ( LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+S="${WORKDIR}/${TARBALL}"
+
+RDEPEND="X? ( x11-libs/libXrandr
+ x11-libs/libXcursor
+ x11-libs/libXft )
+ gnuplot? ( sci-visualization/gnuplot )
+ emacs? ( virtual/emacs )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i -e '2iecho gentoo; exit' -- "${S}"/scripts/findos.sh
+ # sed -i -e 's/\${l}/"\${l}"/g' -- "${S}"/scripts/make.sh
+ sed -i -e 's/static char unmapTable/static unsigned char unmapTable/' \
+ -- "${S}"/csl/fox/src/FXShowMath.cpp
+ eapply_user
+}
+
+src_configure() {
+ # If you pass --prefix to this damn configure,
+ # make (not make install!) will try to install stuff
+ # into the live file system => sandbox violation
+ # Therefore, I cannot use econf here
+ # Also, make calls configure in maintainer mode in subdirs *by design*
+ # The trunk sucks less => WONTFIX until the next release
+ ./configure --with-csl $(use_with X gui)
+ # psl build requires Internet connection at build time
+ # we cannot support it
+}
+
+src_compile() {
+ emake -j1 STRIP=true
+
+ pushd cslbuild/*/csl/reduce.doc > /dev/null
+ rm -f *.txt *.tex
+ popd > /dev/null
+
+ if use emacs; then
+ einfo "Compiling emacs lisp files"
+ elisp-compile generic/emacs/*.el || die "elisp-compile failed"
+ fi
+}
+
+src_test() {
+ emake -j1 testall || die "emake testall failed"
+}
+
+src_install() {
+ local lib="$(get_libdir)"
+ dodoc README BUILDING DEPENDENCY_TRACKING
+ pushd bin > /dev/null
+ cp "${FILESDIR}"/redcsl "${FILESDIR}"/csl .
+ sed -e "s/lib/${lib}/" -i redcsl
+ sed -e "s/lib/${lib}/" -i csl
+ exeinto /usr/bin
+ doexe redcsl csl
+ popd > /dev/null
+
+ pushd cslbuild/*/csl > /dev/null
+ exeinto /usr/${lib}/${PN}
+ doexe reduce csl
+ insinto /usr/$(get_libdir)/${PN}
+ doins reduce.img csl.img
+ insinto /usr/share/${PN}
+ doins -r ${PN}.doc
+ mv -- "${ED}"usr/share/${PN}/${PN}.doc "${ED}"usr/share/${PN}/doc
+ dosym ../../share/${PN}/doc /usr/${lib}/${PN}/${PN}.doc
+ if use X; then
+ doins -r ${PN}.fonts
+ mv -- "${ED}"usr/share/${PN}/${PN}.fonts "${ED}"usr/share/${PN}/fonts
+ dosym ../../share/${PN}/fonts /usr/${lib}/${PN}/${PN}.fonts
+ fi
+ popd > /dev/null
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins doc/util/r38.pdf
+ fi
+
+ if use emacs; then
+ pushd generic/emacs > /dev/null
+ elisp-install ${PN} *.el *.elc || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/64${PN}-gentoo.el"
+ popd > /dev/null
+ fi
+}