summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPalmer Dabbelt <palmer@dabbelt.com>2015-01-17 16:32:13 -0800
committerPalmer Dabbelt <palmer@dabbelt.com>2015-01-17 16:32:13 -0800
commit2e9e139206bcaa6b3aae87607ff9aa035507fd7f (patch)
treed06ae66c46c5cb6d958718234c0a2723558d7cae /sys-auth/libpam-google-authenticator/libpam-google-authenticator-1.0.ebuild
parentAdd sci-visiualization/silo at 4.8 (diff)
downloadpalmer-2e9e139206bcaa6b3aae87607ff9aa035507fd7f.tar.gz
palmer-2e9e139206bcaa6b3aae87607ff9aa035507fd7f.tar.bz2
palmer-2e9e139206bcaa6b3aae87607ff9aa035507fd7f.zip
Add sys-auth/libpam-google-authentication at 1.0
This PAM module allows me to connect Google Authentication for Android to my SSH logins so I can safely login from untrusted machines.
Diffstat (limited to 'sys-auth/libpam-google-authenticator/libpam-google-authenticator-1.0.ebuild')
-rw-r--r--sys-auth/libpam-google-authenticator/libpam-google-authenticator-1.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-auth/libpam-google-authenticator/libpam-google-authenticator-1.0.ebuild b/sys-auth/libpam-google-authenticator/libpam-google-authenticator-1.0.ebuild
new file mode 100644
index 0000000..fb9b80f
--- /dev/null
+++ b/sys-auth/libpam-google-authenticator/libpam-google-authenticator-1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+inherit eutils pam toolchain-funcs
+
+DESCRIPTION="Example PAM module demonstrating two-factor authentication"
+HOMEPAGE="http://code.google.com/p/google-authenticator/"
+SRC_URI="http://google-authenticator.googlecode.com/files/libpam-google-authenticator-1.0-source.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RESTRICT="test"
+
+DEPEND="sys-libs/pam"
+RDEPEND="${DEPEND}
+ media-gfx/qrencode"
+
+src_install() {
+ dopammod pam_google_authenticator.so
+
+ dobin google-authenticator
+
+ dodoc README
+ dohtml totp.html
+}