summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/grpc/files/0002-grpc-1.3.0-Fix-unsecure-.pc-files.patch')
-rw-r--r--net-libs/grpc/files/0002-grpc-1.3.0-Fix-unsecure-.pc-files.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-libs/grpc/files/0002-grpc-1.3.0-Fix-unsecure-.pc-files.patch b/net-libs/grpc/files/0002-grpc-1.3.0-Fix-unsecure-.pc-files.patch
new file mode 100644
index 0000000..e6bde13
--- /dev/null
+++ b/net-libs/grpc/files/0002-grpc-1.3.0-Fix-unsecure-.pc-files.patch
@@ -0,0 +1,38 @@
+From bc139f5b7ce6a2a6d7c67480a04e029955aec0ab Mon Sep 17 00:00:00 2001
+From: Chirantan Ekbote <chirantan@google.com>
+Date: Mon, 10 Jul 2017 13:21:27 -0700
+Subject: [PATCH 3/5] grpc-1.3.0: Fix unsecure .pc files
+
+The *_unsecure.pc files were still linking against the secure versions
+of the grpc libraries. Fix them to link against the unsecure versions.
+
+Sent upstream as https://github.com/grpc/grpc/pull/11448.
+---
+ Makefile | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 4f0680e1d2..86bd66a5e0 100644
+--- a/Makefile
++++ b/Makefile
+@@ -778,7 +778,7 @@ PC_DESCRIPTION = high performance general RPC framework without SSL
+ PC_CFLAGS =
+ PC_REQUIRES_PRIVATE = $(PC_REQUIRES_GRPC)
+ PC_LIBS_PRIVATE = $(PC_LIBS_GRPC)
+-PC_LIB = -lgrpc
++PC_LIB = -lgrpc_unsecure
+ GRPC_UNSECURE_PC_FILE := $(CORE_PC_TEMPLATE)
+
+ PROTOBUF_PKG_CONFIG = false
+@@ -849,7 +849,7 @@ PC_DESCRIPTION = C++ wrapper for gRPC without SSL
+ PC_CFLAGS =
+ PC_REQUIRES_PRIVATE = grpc_unsecure $(PC_REQUIRES_GRPCXX)
+ PC_LIBS_PRIVATE = $(PC_LIBS_GRPCXX)
+-PC_LIB = -lgrpc++
++PC_LIB = -lgrpc++_unsecure
+ GRPCXX_UNSECURE_PC_FILE := $(CPP_PC_TEMPLATE)
+
+ ifeq ($(MAKECMDGOALS),clean)
+--
+2.14.0.rc0.284.gd933b75aa4-goog
+