summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/evrouter/evrouter-0.4.ebuild')
-rw-r--r--sys-apps/evrouter/evrouter-0.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-apps/evrouter/evrouter-0.4.ebuild b/sys-apps/evrouter/evrouter-0.4.ebuild
new file mode 100644
index 0000000..9ed56c6
--- /dev/null
+++ b/sys-apps/evrouter/evrouter-0.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit autotools
+
+DESCRIPTION="An input event router"
+HOMEPAGE="http://www.bedroomlan.org/~alexios/coding_evrouter.html"
+
+SRC_URI="http://debian.bedroomlan.org/debian/pool/main/e/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libxcb
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXtst"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc src/example || die "dodoc failed"
+}