summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Bressler <ruben.bressler@cerpamid.co.cu>2010-07-16 22:22:05 -0400
committerRuben Bressler <ruben.bressler@cerpamid.co.cu>2010-07-16 22:22:05 -0400
commit418cbab157947dba9230ad609b930936701e4b15 (patch)
tree7ccf1927127706cb73f8ab78b09bf4a75c9ee9fd
parent20100702 - Cambio automático (diff)
downloadrubenqba-418cbab157947dba9230ad609b930936701e4b15.tar.gz
rubenqba-418cbab157947dba9230ad609b930936701e4b15.tar.bz2
rubenqba-418cbab157947dba9230ad609b930936701e4b15.zip
20100716 - Cambio automático
-rw-r--r--dev-libs/gobject-introspection/Manifest2
-rw-r--r--dev-libs/gobject-introspection/gobject-introspection-0.9.3.ebuild48
-rw-r--r--gnome-extra/nautilus-dropbox/nautilus-dropbox-0.6.2-r2.ebuild55
3 files changed, 105 insertions, 0 deletions
diff --git a/dev-libs/gobject-introspection/Manifest b/dev-libs/gobject-introspection/Manifest
new file mode 100644
index 0000000..8caa79c
--- /dev/null
+++ b/dev-libs/gobject-introspection/Manifest
@@ -0,0 +1,2 @@
+DIST gobject-introspection-0.9.3.tar.bz2 558321 RMD160 0494a43c59bdf40f10af27d1512ad92339469486 SHA1 3b2e02a061deaefbe86b57cab741f3890ac221b0 SHA256 95a4bc72f912a56880ff521fa71f6cd14f5886941c9561415db08e96a20ba86a
+EBUILD gobject-introspection-0.9.3.ebuild 1104 RMD160 86c1fc8a63b3c68b70ee78835ee3efb2502cc4ae SHA1 145eaa247ef838fc791031ab0bc442e815663876 SHA256 48d73886a14f75caeadd496ae6a8e5be47f3d7f8bdbabb0945b389bf52c9c64a
diff --git a/dev-libs/gobject-introspection/gobject-introspection-0.9.3.ebuild b/dev-libs/gobject-introspection/gobject-introspection-0.9.3.ebuild
new file mode 100644
index 0000000..e228749
--- /dev/null
+++ b/dev-libs/gobject-introspection/gobject-introspection-0.9.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/gobject-introspection-0.9.0.ebuild,v 1.1 2010/07/11 14:06:56 nirbheek Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2:2.5"
+
+inherit python gnome2
+
+DESCRIPTION="Introspection infrastructure for gobject library bindings"
+HOMEPAGE="http://live.gnome.org/GObjectIntrospection/"
+
+LICENSE="LGPL-2 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-libs/glib-2.24.0
+ virtual/libffi"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-1.12 )
+ dev-util/pkgconfig
+ sys-devel/flex
+ test? ( x11-libs/cairo )"
+
+src_prepare() {
+ G2CONF="${G2CONF} --disable-static"
+
+ # FIXME: Parallel compilation failure with USE=doc
+ use doc && MAKEOPTS="-j1"
+
+ # Don't pre-compile .py
+ ln -sf $(type -P true) py-compile
+}
+
+src_configure() {
+ econf $(use_enable test tests) || die "econf failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/$(get_libdir)/${PN}/giscanner
+ python_need_rebuild
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/lib*/${PN}/giscanner
+}
diff --git a/gnome-extra/nautilus-dropbox/nautilus-dropbox-0.6.2-r2.ebuild b/gnome-extra/nautilus-dropbox/nautilus-dropbox-0.6.2-r2.ebuild
new file mode 100644
index 0000000..d9021e8
--- /dev/null
+++ b/gnome-extra/nautilus-dropbox/nautilus-dropbox-0.6.2-r2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit eutils gnome2
+
+DESCRIPTION="Dropbox client"
+HOMEPAGE="http://www.dropbox.com"
+SRC_URI="https://www.dropbox.com/download?dl=packages/${PN}-${PV}.tar.bz2
+ x86? ( http://dl-web.dropbox.com/u/17/dropbox-lnx.x86-0.7.110.tar.gz )
+ amd64? ( http://dl-web.dropbox.com/u/17/dropbox-lnx.x86_64-0.7.110.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/libnotify
+ gnome-base/nautilus
+ dev-libs/dbus-glib
+ x11-libs/libSM"
+
+DEPEND="${RDEPEND}
+ dev-python/docutils"
+
+src_compile() {
+ gnome2_src_prepare
+}
+
+pkg_setup() {
+ arch=${ARCH}
+ use amd64 && arch="x86_64"
+}
+
+src_unpack() {
+ unpack dropbox-lnx.${arch}-0.7.110.tar.gz
+ mv ${WORKDIR}/.dropbox-dist ${WORKDIR}/dropbox
+ unpack ${PN}-${PV}.tar.bz2
+}
+
+src_install() {
+ gnome2_src_install
+
+ rm ${D}/usr/bin/dropbox
+ insinto /opt
+ doins -r ../dropbox || die
+ chmod +x ${D}/opt/dropbox/dropboxd
+ chmod +x ${D}/opt/dropbox/dropbox
+ dosym /opt/dropbox/dropboxd /usr/bin
+ dosym /opt/dropbox/dropbox /usr/bin
+}
+