summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Bressler <ruben.bressler@cerpamid.co.cu>2010-07-16 23:42:41 -0400
committerRuben Bressler <ruben.bressler@cerpamid.co.cu>2010-07-16 23:42:41 -0400
commit4d230fba1b27128a995674da3d9a6e4e82fb0a5c (patch)
treeb1824514fa1cdb360159567c7e19c605fac933f8
parentadicionando vala-0.9.2 (diff)
downloadrubenqba-4d230fba1b27128a995674da3d9a6e4e82fb0a5c.tar.gz
rubenqba-4d230fba1b27128a995674da3d9a6e4e82fb0a5c.tar.bz2
rubenqba-4d230fba1b27128a995674da3d9a6e4e82fb0a5c.zip
adicionando glib-2.25.12
-rw-r--r--dev-libs/glib/Manifest8
-rw-r--r--dev-libs/glib/files/glib-2.10.3-ia64-atomic-ops.patch39
-rw-r--r--dev-libs/glib/files/glib-2.12.12-fbsd.patch21
-rw-r--r--dev-libs/glib/files/glib-2.18.1-workaround-gio-test-failure-without-userpriv.patch20
-rw-r--r--dev-libs/glib/files/glib-2.24-assert-test-failure.patch19
-rw-r--r--dev-libs/glib/files/glib-2.24-punt-python-check.patch20
-rw-r--r--dev-libs/glib/files/glib-2.6.3-testglib-ssp.patch11
-rw-r--r--dev-libs/glib/glib-2.25.12.ebuild132
8 files changed, 270 insertions, 0 deletions
diff --git a/dev-libs/glib/Manifest b/dev-libs/glib/Manifest
new file mode 100644
index 0000000..e0994a1
--- /dev/null
+++ b/dev-libs/glib/Manifest
@@ -0,0 +1,8 @@
+AUX glib-2.10.3-ia64-atomic-ops.patch 1058 RMD160 066e63a99739dc412fbed7f773118323f53ea774 SHA1 13c22e2f75a77e9e0546e495fd28015ddcb8bade SHA256 ad9cad6793626b4e36a59aa6cb839607847aa57ebc37592fd1e273ccd23a53c8
+AUX glib-2.12.12-fbsd.patch 668 RMD160 d8bf399b7e0b417c4622b278282086418c1d3363 SHA1 b7a0f4d67083f2c9b4bbecd84a6d597dd0f0f9ed SHA256 23b0dc406d3d45fe125268b731af67147e83f6e38a63c7892828bdbfe1c31e8d
+AUX glib-2.18.1-workaround-gio-test-failure-without-userpriv.patch 616 RMD160 dd06abe9298d6e3e4d3eda0d5d155f1545dfd1aa SHA1 92164aa1b29f49cf62fc366231f2046b8b3def52 SHA256 e64ad4fbd67f142f5a19b29eab323bf18856309ed064e7a9f838b6c1c38a8adb
+AUX glib-2.24-assert-test-failure.patch 724 RMD160 011da2b341281d14741e715eddd401968464608d SHA1 76149f52677a337569dbab1b5f664c8fc16d44ff SHA256 1e3d290455d6bbc3a4f69d7b8abdeb559a01c8cd30dc311641e1cb0b7f84c6af
+AUX glib-2.24-punt-python-check.patch 541 RMD160 8783f765b97814bc95a6143b75f317dbbdd8ba0c SHA1 dbaf420d3b8acd7691bc677f1fcc6e2fca04ed54 SHA256 0bdcc11d1434f695a5b5f6ec4c54ab7fa5a9f8a5c22d71b94f97378e92aaff84
+AUX glib-2.6.3-testglib-ssp.patch 344 RMD160 6709acf85c52e39553e2e5ee93637f7e9cc7eca6 SHA1 403b249a460a9700669e754a562fb6974f3d6898 SHA256 c2ece3d7b4533e3bfbe8100df5d0824176d9dfa0b18697a8919162956c8ebfa8
+DIST glib-2.25.12.tar.bz2 6040637 RMD160 511d71cef07ffd1974d93dced8d896a6f1ebc404 SHA1 358c1457a8a54515943160f888d8ad36d5cee46c SHA256 fc6f97a3dd3a7fe980abe73f27e7c3146b42d138ae712ab820b22eda95fccfca
+EBUILD glib-2.25.12.ebuild 4021 RMD160 c9721aebd5ef952c0e1bd2d95b5475a2869cde74 SHA1 c3de69945bed613ba903f72a96f6254c29140a27 SHA256 2da20e2580fcd01ab851706c891feb29143f601a1b9e3b032218598ffa5ad279
diff --git a/dev-libs/glib/files/glib-2.10.3-ia64-atomic-ops.patch b/dev-libs/glib/files/glib-2.10.3-ia64-atomic-ops.patch
new file mode 100644
index 0000000..0859e33
--- /dev/null
+++ b/dev-libs/glib/files/glib-2.10.3-ia64-atomic-ops.patch
@@ -0,0 +1,39 @@
+From Debian, this one is needed for gcc < 4.1...
+
+--- glib-2.10.0/glib/gatomic.c 2006-02-24 14:02:51.000000000 +0000
++++ glib-2.10.0/glib/gatomic.c 2006-03-06 18:12:06.000000000 +0000
+@@ -414,14 +414,14 @@
+ g_atomic_int_exchange_and_add (volatile gint *atomic,
+ gint val)
+ {
+- return __sync_fetch_and_add (atomic, val);
++ return __sync_fetch_and_add_si (atomic, val);
+ }
+
+ void
+ g_atomic_int_add (volatile gint *atomic,
+ gint val)
+ {
+- __sync_fetch_and_add (atomic, val);
++ __sync_fetch_and_add_si (atomic, val);
+ }
+
+ gboolean
+@@ -429,7 +429,7 @@
+ gint oldval,
+ gint newval)
+ {
+- return __sync_bool_compare_and_swap (atomic, oldval, newval);
++ return __sync_bool_compare_and_swap_si (atomic, oldval, newval);
+ }
+
+ gboolean
+@@ -437,7 +437,7 @@
+ gpointer oldval,
+ gpointer newval)
+ {
+- return __sync_bool_compare_and_swap ((long *)atomic,
++ return __sync_bool_compare_and_swap_di ((long *)atomic,
+ (long)oldval, (long)newval);
+ }
+
diff --git a/dev-libs/glib/files/glib-2.12.12-fbsd.patch b/dev-libs/glib/files/glib-2.12.12-fbsd.patch
new file mode 100644
index 0000000..bba6329
--- /dev/null
+++ b/dev-libs/glib/files/glib-2.12.12-fbsd.patch
@@ -0,0 +1,21 @@
+diff --exclude-from=/home/dang/.scripts/diffrc -up -ruN glib-2.12.12.orig/gmodule/gmodule-dl.c glib-2.12.12/gmodule/gmodule-dl.c
+--- glib-2.12.12.orig/gmodule/gmodule-dl.c 2007-05-01 19:12:40.000000000 -0400
++++ glib-2.12.12/gmodule/gmodule-dl.c 2007-07-05 20:10:51.000000000 -0400
+@@ -106,6 +106,7 @@ _g_module_open (const gchar *file_name,
+ static gpointer
+ _g_module_self (void)
+ {
++#ifndef __FreeBSD__
+ gpointer handle;
+
+ /* to query symbols from the program itself, special link options
+@@ -117,6 +118,9 @@ _g_module_self (void)
+ g_module_set_error (fetch_dlerror (TRUE));
+
+ return handle;
++#else
++ return RTLD_DEFAULT;
++#endif
+ }
+
+ static void
diff --git a/dev-libs/glib/files/glib-2.18.1-workaround-gio-test-failure-without-userpriv.patch b/dev-libs/glib/files/glib-2.18.1-workaround-gio-test-failure-without-userpriv.patch
new file mode 100644
index 0000000..cabe56f
--- /dev/null
+++ b/dev-libs/glib/files/glib-2.18.1-workaround-gio-test-failure-without-userpriv.patch
@@ -0,0 +1,20 @@
+Temporary workaround for gio tests failure when ran without FEATURES=userpriv
+until upstream bug #552912 is fixed
+
+--- gio/tests/live-g-file.c.orig 2008-09-25 05:44:12.848556034 +0300
++++ gio/tests/live-g-file.c 2008-09-25 06:12:34.248726237 +0300
+@@ -769,11 +769,14 @@
+ if (posix_compat)
+ {
+ /* target directory is not accessible (no execute flag) */
++#if 0
++/* Fails when ran as root */
+ do_copy_move (root, item, TEST_DIR_NO_ACCESS,
+ TEST_NO_ACCESS);
+ /* target directory is readonly */
+ do_copy_move (root, item, TEST_DIR_NO_WRITE,
+ TEST_NO_ACCESS);
++#endif
+ }
+ }
+ }
diff --git a/dev-libs/glib/files/glib-2.24-assert-test-failure.patch b/dev-libs/glib/files/glib-2.24-assert-test-failure.patch
new file mode 100644
index 0000000..6d8e74f
--- /dev/null
+++ b/dev-libs/glib/files/glib-2.24-assert-test-failure.patch
@@ -0,0 +1,19 @@
+Tests fail when upgrading glib from 2.22 to 2.24 if sys-devel/gdb is installed
+because gdb is run on .libs/assert-msg-test before LD_LIBRARY_PATH is set. This
+causes gdb to use the system-wide glib instead, and fail on the test.
+
+This patch exports LD_LIBRARY_PATH before running gdb
+
+https://bugzilla.gnome.org/621368
+
+---
+--- tests/run-assert-msg-test.sh
++++ tests/run-assert-msg-test.sh
+@@ -34,6 +34,7 @@ if [ -e ".libs/lt-$msg_test" ]; then
+ msg_test="lt-$msg_test"
+ fi
+ echo_v "Running gdb on assert-msg-test"
++export LD_LIBRARY_PATH="`dirname $PWD`/glib/.libs:$LD_LIBRARY_PATH"
+ OUT=$(gdb --batch --ex run --ex "print (char*) __glib_assert_msg" .libs/$msg_test 2> $error_out) || \
+ fail "failed to run gdb"
+
diff --git a/dev-libs/glib/files/glib-2.24-punt-python-check.patch b/dev-libs/glib/files/glib-2.24-punt-python-check.patch
new file mode 100644
index 0000000..3cbd6dc
--- /dev/null
+++ b/dev-libs/glib/files/glib-2.24-punt-python-check.patch
@@ -0,0 +1,20 @@
+Remove python detection from configure.in, we won't be installing the gdb python
+scripts anymore. They use a redhat-specific gdb module that has not been
+upstreamed yet.
+
+https://bugs.gentoo.org/291328
+https://bugzilla.gnome.org/623552
+---
+--- configure.in
++++ configure.in
+@@ -379,10 +379,6 @@ if test "x$PERL_PATH" = x ; then
+ fi
+ AC_SUBST(PERL_PATH)
+
+-# Need suitable python path for greport
+-AM_PATH_PYTHON(2.4,,PYTHON="/usr/bin/env python2.4")
+-
+-
+ dnl ***********************
+ dnl *** Tests for iconv ***
+ dnl ***********************
diff --git a/dev-libs/glib/files/glib-2.6.3-testglib-ssp.patch b/dev-libs/glib/files/glib-2.6.3-testglib-ssp.patch
new file mode 100644
index 0000000..9b104dd
--- /dev/null
+++ b/dev-libs/glib/files/glib-2.6.3-testglib-ssp.patch
@@ -0,0 +1,11 @@
+--- tests/Makefile.in.orig 2005-04-07 01:05:39.000000000 +0000
++++ tests/Makefile.in 2005-04-07 01:09:02.000000000 +0000
+@@ -50,7 +50,7 @@
+ CATOBJEXT = @CATOBJEXT@
+ CC = @CC@
+ CCDEPMODE = @CCDEPMODE@
+-CFLAGS = @CFLAGS@
++CFLAGS = @CFLAGS@ -fno-stack-protector
+ CPP = @CPP@
+ CPPFLAGS = @CPPFLAGS@
+ CROSS_COMPILING_FALSE = @CROSS_COMPILING_FALSE@
diff --git a/dev-libs/glib/glib-2.25.12.ebuild b/dev-libs/glib/glib-2.25.12.ebuild
new file mode 100644
index 0000000..aa1eab9
--- /dev/null
+++ b/dev-libs/glib/glib-2.25.12.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit autotools gnome.org libtool eutils flag-o-matic
+
+DESCRIPTION="The GLib library of C routines"
+HOMEPAGE="http://www.gtk.org/"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="debug doc fam hardened +introspection selinux static-libs test xattr"
+
+RDEPEND="virtual/libiconv
+ xattr? ( sys-apps/attr )
+ fam? ( virtual/fam )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.16
+ >=sys-devel/gettext-0.11
+ doc? (
+ >=dev-libs/libxslt-1.0
+ >=dev-util/gtk-doc-1.11
+ ~app-text/docbook-xml-dtd-4.1.2 )
+ test? ( >=sys-apps/dbus-1.2.14 )"
+PDEPEND="introspection? ( dev-libs/gobject-introspection )"
+# XXX: Consider adding test? ( sys-devel/gdb ); assert-msg-test tries to use it
+
+src_prepare() {
+ if use ppc64 && use hardened ; then
+ replace-flags -O[2-3] -O1
+ epatch "${FILESDIR}/glib-2.6.3-testglib-ssp.patch"
+ fi
+
+ if use ia64 ; then
+ # Only apply for < 4.1
+ local major=$(gcc-major-version)
+ local minor=$(gcc-minor-version)
+ if (( major < 4 || ( major == 4 && minor == 0 ) )); then
+ epatch "${FILESDIR}/glib-2.10.3-ia64-atomic-ops.patch"
+ fi
+ fi
+
+ # Don't fail gio tests when ran without userpriv, upstream bug 552912
+ # This is only a temporary workaround, remove as soon as possible
+ epatch "${FILESDIR}/${PN}-2.18.1-workaround-gio-test-failure-without-userpriv.patch"
+
+ # Fix gmodule issues on fbsd; bug #184301
+ epatch "${FILESDIR}"/${PN}-2.12.12-fbsd.patch
+
+ # Don't check for python, hence removing the build-time python dep.
+ # We remove the gdb python scripts in src_install due to bug 291328
+ #epatch "${FILESDIR}/${PN}-2.24-punt-python-check.patch"
+
+ # Fix test failure when upgrading from 2.22 to 2.24, upstream bug 621368
+ epatch "${FILESDIR}/${PN}-2.24-assert-test-failure.patch"
+
+ # Do not try to remove files on live filesystem, bug #XXX ?
+ sed 's:^\(.*"/desktop-app-info/delete".*\):/*\1*/:' \
+ -i "${S}"/gio/tests/desktop-app-info.c || die "sed failed"
+
+ # Needed for the punt-python-check patch.
+ eautoreconf
+
+ [[ ${CHOST} == *-freebsd* ]] && elibtoolize
+
+ epunt_cxx
+}
+
+src_configure() {
+ local myconf
+
+ # Building with --disable-debug highly unrecommended. It will build glib in
+ # an unusable form as it disables some commonly used API. Please do not
+ # convert this to the use_enable form, as it results in a broken build.
+ # -- compnerd (3/27/06)
+ use debug && myconf="--enable-debug"
+
+ # Always use internal libpcre, bug #254659
+ econf ${myconf} \
+ $(use_enable xattr) \
+ $(use_enable doc man) \
+ $(use_enable doc gtk-doc) \
+ $(use_enable fam) \
+ $(use_enable selinux) \
+ $(use_enable static-libs static) \
+ --enable-regex \
+ --with-pcre=internal \
+ --with-threads=posix
+}
+
+src_install() {
+ local f
+ emake DESTDIR="${D}" install || die "Installation failed"
+
+ # Do not install charset.alias even if generated, leave it to libiconv
+ rm -f "${D}/usr/lib/charset.alias"
+
+ # Don't install gdb python macros, bug 291328
+ rm -rf "${D}/usr/share/gdb/" "${D}/usr/share/glib-2.0/gdb/"
+
+ dodoc AUTHORS ChangeLog* NEWS* README || die "dodoc failed"
+
+ insinto /usr/share/bash-completion
+ for f in gdbus gsettings; do
+ newins "${D}/etc/bash_completion.d/${f}-bash-completion.sh" ${f} || die
+ done
+ rm -rf "${D}/etc"
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ export XDG_CONFIG_DIRS=/etc/xdg
+ export XDG_DATA_DIRS=/usr/local/share:/usr/share
+ export XDG_DATA_HOME="${T}"
+ emake check || die "tests failed"
+}
+
+pkg_preinst() {
+ # Only give the introspection message if:
+ # * The user has it enabled
+ # * Has glib already installed
+ # * Previous version was different from new version
+ if use introspection && has_version "${CATEGORY}/${PN}"; then
+ if ! has_version "=${CATEGORY}/${PF}"; then
+ ewarn "You must rebuild gobject-introspection so that the installed"
+ ewarn "typelibs and girs are regenerated for the new APIs in glib"
+ fi
+ fi
+}