summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Bressler <ruben.bressler@cerpamid.co.cu>2010-07-02 17:45:49 -0400
committerRuben Bressler <ruben.bressler@cerpamid.co.cu>2010-07-02 17:45:49 -0400
commite9b1cf5dfe59b8cb73a6aebc34ad38a55449c634 (patch)
tree81a1755ba53c2b93a48f167f56dd8c5665efe0a1
parent20100702 - Cambio automático (diff)
downloadrubenqba-e9b1cf5dfe59b8cb73a6aebc34ad38a55449c634.tar.gz
rubenqba-e9b1cf5dfe59b8cb73a6aebc34ad38a55449c634.tar.bz2
rubenqba-e9b1cf5dfe59b8cb73a6aebc34ad38a55449c634.zip
creando paquete de xsexceptions
-rw-r--r--dev-libs/xsexceptions/xsexceptions-1.5.0.3536.ebuild90
1 files changed, 90 insertions, 0 deletions
diff --git a/dev-libs/xsexceptions/xsexceptions-1.5.0.3536.ebuild b/dev-libs/xsexceptions/xsexceptions-1.5.0.3536.ebuild
new file mode 100644
index 0000000..da80372
--- /dev/null
+++ b/dev-libs/xsexceptions/xsexceptions-1.5.0.3536.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# NOTE: The comments in this file are for instruction and documentation.
+# They're not meant to appear with your final, production ebuild. Please
+# remember to remove them before submitting or committing your ebuild. That
+# doesn't mean you can't add your own comments though.
+
+# The 'Header' on the third line should just be left alone. When your ebuild
+# will be committed to cvs, the details on that line will be automatically
+# generated to contain the correct data.
+
+# The EAPI variable tells the ebuild format in use.
+# Defaults to 0 if not specified. The current PMS draft contains details on
+# a proposed EAPI=0 definition but is not finalized yet.
+# Eclasses will test for this variable if they need to use EAPI > 0 features.
+#EAPI=0
+
+# inherit lists eclasses to inherit functions from. Almost all ebuilds should
+# inherit eutils, as a large amount of important functionality has been
+# moved there. For example, the epatch call mentioned below wont work
+# without the following line:
+inherit eutils
+# A well-used example of an eclass function that needs eutils is epatch. If
+# your source needs patches applied, it's suggested to put your patch in the
+# 'files' directory and use:
+#
+# epatch "${FILESDIR}"/patch-name-here
+#
+# eclasses tend to list descriptions of how to use their functions properly.
+# take a look at /usr/portage/eclasses/ for more examples.
+
+# Short one-line description of this package.
+DESCRIPTION="This is a sample skeleton ebuild file"
+
+# Homepage, not used by Portage directly but handy for developer reference
+HOMEPAGE="http://foo.bar.com/"
+
+# Point to any required sources; these will be automatically downloaded by
+# Portage.
+SRC_URI="http://172.16.157.60/ruben/noti/xsexceptions-1.5.0.3536.tar.bz2"
+
+SLOT="4.0"
+
+KEYWORDS="amd64 x86"
+
+# Comprehensive list of any and all USE flags leveraged in the ebuild,
+# with the exception of any ARCH specific flags, i.e. "ppc", "sparc",
+# "x86" and "alpha". This is a required variable. If the ebuild doesn't
+# use any USE flags, set to "".
+IUSE=""
+
+# A space delimited list of portage features to restrict. man 5 ebuild
+# for details. Usually not needed.
+#RESTRICT="strip"
+
+# Build-time dependencies, such as
+# ssl? ( >=dev-libs/openssl-0.9.6b )
+# >=dev-lang/perl-5.6.1-r1
+# It is advisable to use the >= syntax show above, to reflect what you
+# had installed on your system when you tested the package. Then
+# other users hopefully won't be caught without the right version of
+# a dependency.
+DEPEND="dev-libs/xsdefinitions:4.0"
+
+# Run-time dependencies. Must be defined to whatever this depends on to run.
+# The below is valid if the same run-time depends are required to compile.
+RDEPEND="${DEPEND}"
+
+# Source directory; the dir where the sources can be found (automatically
+# unpacked) inside ${WORKDIR}. The default value for S is ${WORKDIR}/${P}
+# If you don't need to change it, leave the S= line out of the ebuild
+# to keep it tidy.
+#S="${WORKDIR}/${P}"
+
+#src_prepare() {
+ # Esto es principalmente para aplicar parches
+#}
+
+src_compile() {
+ econf --prefix=/opt/datys || die "econf failed"
+ emake || die "Error de compilación"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
+
+