aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSardem FF7 <sardemff7.pub@gmail.com>2011-03-12 14:36:35 +0100
committerSardem FF7 <sardemff7.pub@gmail.com>2011-03-12 14:37:52 +0100
commit268934f71da5f7899758930db3024c73fc19e972 (patch)
treef2b0111f6897e8033bb79fb88249e37aa50a3db4
parentFixes (diff)
downloadsardemff7-268934f71da5f7899758930db3024c73fc19e972.tar.gz
sardemff7-268934f71da5f7899758930db3024c73fc19e972.tar.bz2
sardemff7-268934f71da5f7899758930db3024c73fc19e972.zip
Provide spidermonkey-9999
-rw-r--r--dev-lang/spidermonkey/Manifest1
-rw-r--r--dev-lang/spidermonkey/spidermonkey-9999.ebuild35
-rw-r--r--eclass/mozilla-config.eclass2
-rw-r--r--eclass/mozilla-scm.eclass23
-rw-r--r--profiles/package.mask1
5 files changed, 53 insertions, 9 deletions
diff --git a/dev-lang/spidermonkey/Manifest b/dev-lang/spidermonkey/Manifest
new file mode 100644
index 0000000..4d19264
--- /dev/null
+++ b/dev-lang/spidermonkey/Manifest
@@ -0,0 +1 @@
+EBUILD spidermonkey-9999.ebuild 610 RMD160 04cb8b692f40ed65800652d7772f4bb23e645c2c SHA1 2a137a287a06054add9ed68209b9aa563ff73884 SHA256 f24bd2eeb422223e1cc8b76b53df234f318d34a13ef0860b79d52de54340c320
diff --git a/dev-lang/spidermonkey/spidermonkey-9999.ebuild b/dev-lang/spidermonkey/spidermonkey-9999.ebuild
new file mode 100644
index 0000000..707ed4d
--- /dev/null
+++ b/dev-lang/spidermonkey/spidermonkey-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+
+
+inherit mozilla-scm
+
+DESCRIPTION="Stand-alone JavaScript C library"
+HOMEPAGE="http://www.mozilla.org/js/spidermonkey/"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="NPL-1.1"
+
+S+="/js/src"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ # Disable no-print-directory
+ MAKEOPTS=${MAKEOPTS/--no-print-directory/}
+
+ mozilla-scm_src_configure \
+ --with-system-nspr \
+ --enable-threadsafe
+}
+
+src_install() {
+ mozilla-scm_src_install
+
+ dodoc ../jsd/README
+ dohtml README.html
+}
diff --git a/eclass/mozilla-config.eclass b/eclass/mozilla-config.eclass
index 76dd9aa..90c6650 100644
--- a/eclass/mozilla-config.eclass
+++ b/eclass/mozilla-config.eclass
@@ -178,8 +178,6 @@ function mozconfig_configure {
--disable-profilesharing \
--disable-profilelocking
- mozconfig_annotate 'Provide and use libmozjs' --enable-shared-js
-
sed -i \
-e '/--enable-application=/d' \
-e '/--enable-extensions=/d'\
diff --git a/eclass/mozilla-scm.eclass b/eclass/mozilla-scm.eclass
index 2908530..f708017 100644
--- a/eclass/mozilla-scm.eclass
+++ b/eclass/mozilla-scm.eclass
@@ -27,12 +27,17 @@ S="${WORKDIR}/${XULRUNNER_HG_MODULE}"
#
# Some per-application stuff
#
+IS_LIBMOZJS=false
IS_LIBXUL=false
MOZLIBDIR="/usr/$(get_libdir)/xulrunner-${MAJ_XUL_PV}"
MOZDEVELDIR="/usr/$(get_libdir)/xulrunner-devel-${MAJ_XUL_PV}"
SDKDIR="${MOZDEVELDIR}/sdk"
MOZILLA_FIVE_HOME="/usr/$(get_libdir)/${PN}"
case "${PN}" in
+ spidermonkey)
+ IS_LIBMOZJS=true
+ IS_LIBXUL=true
+ ;;
xulrunner)
IS_LIBXUL=true
MOZ_APPLICATION=xulrunner
@@ -164,7 +169,7 @@ function mozilla-scm_src_unpack {
local base_module=${1:-${XULRUNNER_HG_MODULE}}
local old_offline="${EHG_OFFLINE}"
# It is xul stuff, so xul only can update them
- ${IS_LIBXUL} || EHG_OFFLINE=yes
+ ${IS_LIBMOZJS} || EHG_OFFLINE=yes
moz_hg_fetch "${MOZ_HG_BASE_URI}/${XULRUNNER_HG_MODULE}/" "${base_module}"
moz_hg_fetch "${MOZ_HG_BASE_URI}/${MOZDOM_HG_MODULE}/" "${base_module}/extensions/inspector"
EHG_OFFLINE="${old_offline}"
@@ -205,11 +210,13 @@ function mozilla-scm_src_configure {
function mozilla-scm_src_install {
emake DESTDIR="${ED}" install || die "emake install failed"
- local prefdir="${ED}/${MOZILLA_FIVE_HOME}/defaults/pref"
- [[ -d "${prefdir}erences" ]] && prefdir+="erences"
- cp "${FILESDIR}"/default-prefs.js \
- "${prefdir}/all-gentoo.js" || \
- die "failed to cp default-prefs.js"
+ if ! ${IS_LIBMOZJS}; then
+ local prefdir="${ED}/${MOZILLA_FIVE_HOME}/defaults/pref"
+ [[ -d "${prefdir}erences" ]] && prefdir+="erences"
+ cp "${FILESDIR}"/default-prefs.js \
+ "${prefdir}/all-gentoo.js" || \
+ die "failed to cp default-prefs.js"
+ fi
}
##
@@ -221,7 +228,9 @@ function mozilla-scm_pkg_postinst {
ewarn "are willing to provide a patch. All bugs that are filled without a patch"
ewarn "will be closed INVALID!!"
- if ${IS_LIBXUL}; then
+ if ${IS_LIBMOZJS}; then
+ einfo "Don't forget to rebuild xulrunner to update it to the same changeset"
+ elif ${IS_LIBXUL}; then
einfo "Don't forget to rebuild firefox/thunderbird to update it to the same changeset"
else
ewarn "All the packages built against ${PN} won't compile,"
diff --git a/profiles/package.mask b/profiles/package.mask
index c2f9f7a..430d393 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -15,6 +15,7 @@ x11-misc/notify-osd
=dev-libs/klibc-9999
=x11-plugins/pidgin-libnotify+-9999
=games-emulation/sdlmess-9999
+=dev-lang/spidermonkey-9999
=net-libs/xulrunner-9999
=www-client/firefox-9999