summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Solano Gómez <daniel@solanogomez.org>2014-06-07 08:24:55 -0500
committerDaniel Solano Gómez <daniel@solanogomez.org>2014-06-07 08:24:55 -0500
commit40058c977f911214630ea925bbb55740ac60bbb5 (patch)
tree90996d0245cbea6f53e40949743bdb491349d826
parentUpdate cups dependencies (diff)
downloadsattvik-40058c977f911214630ea925bbb55740ac60bbb5.tar.gz
sattvik-40058c977f911214630ea925bbb55740ac60bbb5.tar.bz2
sattvik-40058c977f911214630ea925bbb55740ac60bbb5.zip
Get rid of profiles
-rw-r--r--profiles/package.use/00-system8
-rw-r--r--profiles/packages5
-rw-r--r--profiles/profiles.desc2
-rw-r--r--profiles/sattvik/base/eapi1
-rw-r--r--profiles/sattvik/base/make.defaults21
-rwxr-xr-xprofiles/sattvik/base/profile.bashrc51
-rw-r--r--profiles/sattvik/linux/amd64/13.0/eapi1
-rw-r--r--profiles/sattvik/linux/amd64/13.0/make.defaults3
-rw-r--r--profiles/sattvik/linux/amd64/13.0/parent2
-rw-r--r--profiles/sattvik/linux/amd64/13.0/sattvik_patches/app-shells/zsh-5.0.2-r1/zsh-5.0.2-texinfo-5.1-fix.patch31
-rw-r--r--profiles/sattvik/linux/amd64/13.0/sattvik_patches/media-libs/libsdl-1.2.15-r3/libsdl-1.2.15-libX11-1.5.99.901.patch16
-rw-r--r--profiles/sattvik/linux/amd64/13.0/sattvik_patches/net-print/cups/cups-1.5.0-group_fix.patch67
-rw-r--r--profiles/sattvik/linux/amd64/13.0/sattvik_patches/sys-apps/openrc-0.11.8/openrc-0.11.8-add-dhcpv6-support.patch249
-rw-r--r--profiles/sattvik/linux/amd64/13.0/workstation/eapi1
-rw-r--r--profiles/sattvik/linux/amd64/13.0/workstation/make.defaults3
-rw-r--r--profiles/sattvik/linux/amd64/13.0/workstation/parent1
16 files changed, 0 insertions, 462 deletions
diff --git a/profiles/package.use/00-system b/profiles/package.use/00-system
deleted file mode 100644
index 3494f79..0000000
--- a/profiles/package.use/00-system
+++ /dev/null
@@ -1,8 +0,0 @@
-# install motd/mail/lastlog pam modules
-sys-auth/pambase -cracklib -minimal mktemp passwdqc
-
-# install terminfo files
-sys-libs/ncurses -minimal
-
-# use openssh by default
-virtual/ssh -minimal
diff --git a/profiles/packages b/profiles/packages
deleted file mode 100644
index 29b55f6..0000000
--- a/profiles/packages
+++ /dev/null
@@ -1,5 +0,0 @@
-# I don't use nano
--*app-editors/nano
-
-# I use Vim instead
-*app-editors/vim
diff --git a/profiles/profiles.desc b/profiles/profiles.desc
deleted file mode 100644
index d0a9d46..0000000
--- a/profiles/profiles.desc
+++ /dev/null
@@ -1,2 +0,0 @@
-amd64 sattvik/linux/amd64/13.0 stable
-amd64 sattvik/linux/amd64/13.0/workstation stable
diff --git a/profiles/sattvik/base/eapi b/profiles/sattvik/base/eapi
deleted file mode 100644
index 7ed6ff8..0000000
--- a/profiles/sattvik/base/eapi
+++ /dev/null
@@ -1 +0,0 @@
-5
diff --git a/profiles/sattvik/base/make.defaults b/profiles/sattvik/base/make.defaults
deleted file mode 100644
index 47c2f61..0000000
--- a/profiles/sattvik/base/make.defaults
+++ /dev/null
@@ -1,21 +0,0 @@
-CFLAGS="-march=native -O2 -pipe -frecord-gcc-switches"
-CXXFLAGS="${CFLAGS}"
-FFLAGS="${CFLAGS}"
-FCFLAGS="${FFLAGS}"
-
-PORT_LOGDIR=/var/log/portage
-EMERGE_DEFAULT_OPTS="--verbose --keep-going --autounmask --autounmask-unrestricted-atoms --complete-graph --fail-clean --ask --backtrack=50"
-PORTAGE_IONICE_COMMAND="ionice -c 3 -p \${PID}"
-FEATURES="candy compress-build-logs ebuild-locks fail-clean news parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans unknown-features-warn userfetch userpriv usersandbox usersync xattr"
-
-PORTAGE_ELOG_CLASSES="*"
-PORTAGE_ELOG_SYSTEM="save mail:warn,error,log echo"
-PORTAGE_ELOG_MAILURI="root /usr/sbin/sendmail"
-PORTAGE_ELOG_MAILFROM="portage"
-PORTAGE_ELOG_MAILSUBJECT="[portage] \${HOST}: \${ACTION} \${PACKAGE}"
-
-
-USE="-berkdb caps -gdbm -gstreamer -introspection minimal -pcre -perl -python -tcpd -truetype vim-syntax xattr zsh-completion"
-
-
-# vim:set ft=gentoo-make-conf:
diff --git a/profiles/sattvik/base/profile.bashrc b/profiles/sattvik/base/profile.bashrc
deleted file mode 100755
index dc6b71a..0000000
--- a/profiles/sattvik/base/profile.bashrc
+++ /dev/null
@@ -1,51 +0,0 @@
-#!/bin/bash
-
-sattvik_profile_patches() {
- if [ "${FUNCNAME[1]}" != "post_src_prepare" ]; then
- eerror "You cannot call sattvik_profile_patches outside of post_src_prepare"
- return 2
- else
- local -a patches_dirs
- for profile_path in $PROFILE_PATHS; do
- local patches_dir="$profile_path/sattvik_patches"
- if [ -d "$patches_dir" ]; then
- patches_dirs+=("$patches_dir")
- fi
- done
-
- local idx
- local -a rev_patches_dirs
- for (( idx=${#patches_dirs[@]}-1 ; idx>=0 ; idx-- )); do
- rev_patches_dirs+=("${patches_dirs[idx]}")
- done
-
- local applied="${T}/sattvik_patch.log"
- [[ -e ${applied} ]] && return 2
-
- local patches_dir
- for patches_dir in "${rev_patches_dirs[@]}"; do
- local EPATCH_SOURCE check
- for check in ${CATEGORY}/{${P}-${PR},${P},${PN}}{,:${SLOT}}; do
- EPATCH_SOURCE=${patches_dir}/${CTARGET}/${check}
- [[ -r ${EPATCH_SOURCE} ]] || EPATCH_SOURCE=${patches_dir}/${CHOST}/${check}
- [[ -r ${EPATCH_SOURCE} ]] || EPATCH_SOURCE=${patches_dir}/${check}
- if [[ -d ${EPATCH_SOURCE} ]] ; then
- EPATCH_SOURCE=${EPATCH_SOURCE} \
- EPATCH_SUFFIX="patch" \
- EPATCH_FORCE="yes" \
- EPATCH_MULTI_MSG="Applying Sattvik profile patches from ${EPATCH_SOURCE} ..." \
- epatch
- echo "${EPATCH_SOURCE}" > "${applied}"
- return 0
- fi
- done
- done
-
- echo "none" > "${applied}"
- return 1
- fi
-}
-
-post_src_prepare() {
- sattvik_profile_patches
-}
diff --git a/profiles/sattvik/linux/amd64/13.0/eapi b/profiles/sattvik/linux/amd64/13.0/eapi
deleted file mode 100644
index 7ed6ff8..0000000
--- a/profiles/sattvik/linux/amd64/13.0/eapi
+++ /dev/null
@@ -1 +0,0 @@
-5
diff --git a/profiles/sattvik/linux/amd64/13.0/make.defaults b/profiles/sattvik/linux/amd64/13.0/make.defaults
deleted file mode 100644
index c625652..0000000
--- a/profiles/sattvik/linux/amd64/13.0/make.defaults
+++ /dev/null
@@ -1,3 +0,0 @@
-ACCEPT_KEYWORDS="~amd64"
-
-# vim:set ft=gentoo-make-conf:
diff --git a/profiles/sattvik/linux/amd64/13.0/parent b/profiles/sattvik/linux/amd64/13.0/parent
deleted file mode 100644
index 8b4aef0..0000000
--- a/profiles/sattvik/linux/amd64/13.0/parent
+++ /dev/null
@@ -1,2 +0,0 @@
-gentoo:default/linux/amd64/13.0
-:sattvik/base
diff --git a/profiles/sattvik/linux/amd64/13.0/sattvik_patches/app-shells/zsh-5.0.2-r1/zsh-5.0.2-texinfo-5.1-fix.patch b/profiles/sattvik/linux/amd64/13.0/sattvik_patches/app-shells/zsh-5.0.2-r1/zsh-5.0.2-texinfo-5.1-fix.patch
deleted file mode 100644
index 4ed7d5f..0000000
--- a/profiles/sattvik/linux/amd64/13.0/sattvik_patches/app-shells/zsh-5.0.2-r1/zsh-5.0.2-texinfo-5.1-fix.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-# https://bugs.gentoo.org/show_bug.cgi?id=464122
---- 1/Doc/zsh.texi
-+++ 1/Doc/zsh.texi
-@@ -22643,8 +22643,7 @@
- described above.
-
- @findex _pick_variant
--@item @t{_pick_variant} [ @t{-b} @var{builtin-label} ] [ @t{-c}
--@var{command} ] [ @t{-r} @var{name} ]
-+@item @t{_pick_variant} [ @t{-b} @var{builtin-label} ] [ @t{-c} @var{command} ] [ @t{-r} @var{name} ]
- @itemx @var{label}@t{=}@var{pattern} ... @var{label} [ @var{args} ... ]
- This function is used to resolve situations where a single command name
- requires more than one type of handling, either because it
-@@ -24981,14 +24980,9 @@
- @var{targetwin} into the array named @var{array}.
- These are, in order:
- @table @asis
--@item
--The y and x coordinates of the cursor relative to the top left
--of @var{targetwin}
--@item
--The y and x coordinates of the top left of @var{targetwin} on the
--screen
--@item
--The size of @var{targetwin} in y and x dimensions.
-+@item The y and x coordinates of the cursor relative to the top left of @var{targetwin}
-+@item The y and x coordinates of the top left of @var{targetwin} on the screen
-+@item The size of @var{targetwin} in y and x dimensions.
- @end table
-
- @noindent
diff --git a/profiles/sattvik/linux/amd64/13.0/sattvik_patches/media-libs/libsdl-1.2.15-r3/libsdl-1.2.15-libX11-1.5.99.901.patch b/profiles/sattvik/linux/amd64/13.0/sattvik_patches/media-libs/libsdl-1.2.15-r3/libsdl-1.2.15-libX11-1.5.99.901.patch
deleted file mode 100644
index 0f1c07c..0000000
--- a/profiles/sattvik/linux/amd64/13.0/sattvik_patches/media-libs/libsdl-1.2.15-r3/libsdl-1.2.15-libX11-1.5.99.901.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-libX11-1.5.99.901 has changed prototype of _XData32
-
-<http://bugzilla.libsdl.org/show_bug.cgi?id=1769>
-
-diff -r b6b2829cd7ef src/video/x11/SDL_x11sym.h
---- a/src/video/x11/SDL_x11sym.h Wed Feb 27 15:20:31 2013 -0800
-+++ b/src/video/x11/SDL_x11sym.h Wed Mar 27 16:07:23 2013 +0100
-@@ -165,7 +165,7 @@
- */
- #ifdef LONG64
- SDL_X11_MODULE(IO_32BIT)
--SDL_X11_SYM(int,_XData32,(Display *dpy,register long *data,unsigned len),(dpy,data,len),return)
-+SDL_X11_SYM(int,_XData32,(Display *dpy,register _Xconst long *data,unsigned len),(dpy,data,len),return)
- SDL_X11_SYM(void,_XRead32,(Display *dpy,register long *data,long len),(dpy,data,len),)
- #endif
-
diff --git a/profiles/sattvik/linux/amd64/13.0/sattvik_patches/net-print/cups/cups-1.5.0-group_fix.patch b/profiles/sattvik/linux/amd64/13.0/sattvik_patches/net-print/cups/cups-1.5.0-group_fix.patch
deleted file mode 100644
index 28d3fb5..0000000
--- a/profiles/sattvik/linux/amd64/13.0/sattvik_patches/net-print/cups/cups-1.5.0-group_fix.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-diff -Naur cups-1.5.0/scheduler/auth.c cups-1.5.0-group_fix/scheduler/auth.c
---- cups-1.5.0/scheduler/auth.c 2011-05-19 22:49:49.000000000 -0500
-+++ cups-1.5.0-group_fix/scheduler/auth.c 2011-08-23 18:13:32.000000000 -0500
-@@ -1431,6 +1431,7 @@
- const char *groupname) /* I - Group name */
- {
- int i; /* Looping var */
-+ int foundit; /* Whether or not the search returned a positive result. */
- struct group *group; /* System group info */
- char junk[33]; /* MD5 password (not used) */
- #ifdef HAVE_MBR_UID_TO_UUID
-@@ -1452,29 +1453,43 @@
- return (0);
-
- /*
-- * Check to see if the user is a member of the named group...
-+ * Iterate through all group entries until a match is found.
- */
--
-- group = getgrnam(groupname);
-- endgrent();
--
-- if (group != NULL)
-+ setgrent();
-+ foundit=0;
-+ while(!foundit && (group=getgrent())!=NULL)
- {
- /*
-- * Group exists, check it...
-+ * If the group name doesn't match, move on...
-+ */
-+ if(_cups_strcasecmp(groupname, group->gr_name))
-+ continue;
-+
-+ /*
-+ * First, check to see if group ID matches the user's group ID.
- */
-+ if(user && group->gr_gid == user->pw_gid)
-+ {
-+ foundit=1;
-+ break;
-+ }
-
-+ /*
-+ * Check to see if the user is listed as a member of the group...
-+ */
- for (i = 0; group->gr_mem[i]; i ++)
- if (!_cups_strcasecmp(username, group->gr_mem[i]))
-- return (1);
-+ {
-+ foundit=1;
-+ break;
-+ }
- }
-+ endgrent();
-
- /*
-- * Group doesn't exist or user not in group list, check the group ID
-- * against the user's group ID...
-+ * If the group membership was confirmed, return.
- */
--
-- if (user && group && group->gr_gid == user->pw_gid)
-+ if (foundit)
- return (1);
-
- #ifdef HAVE_MBR_UID_TO_UUID
diff --git a/profiles/sattvik/linux/amd64/13.0/sattvik_patches/sys-apps/openrc-0.11.8/openrc-0.11.8-add-dhcpv6-support.patch b/profiles/sattvik/linux/amd64/13.0/sattvik_patches/sys-apps/openrc-0.11.8/openrc-0.11.8-add-dhcpv6-support.patch
deleted file mode 100644
index 79df6af..0000000
--- a/profiles/sattvik/linux/amd64/13.0/sattvik_patches/sys-apps/openrc-0.11.8/openrc-0.11.8-add-dhcpv6-support.patch
+++ /dev/null
@@ -1,249 +0,0 @@
-diff --git a/doc/net.example.Linux.in b/doc/net.example.Linux.in
-index f050c2a..a0d9435 100644
---- a/doc/net.example.Linux.in
-+++ b/doc/net.example.Linux.in
-@@ -473,6 +473,41 @@
- # use any of them.
-
- #-----------------------------------------------------------------------------
-+# DHCPv6
-+# DHCPv6 can be provided by dhclient
-+#
-+# dhclient: emerge net-misc/dhcp
-+#
-+# If you have more than one DHCP client installed, you should probably
-+# explicitly use 'dhclient' to use dhclient for both DHCP and DHCPv6,
-+# otherwise the default DHCP client will be used. dhcpcd has some stateless
-+# IPv6 autoconfiguration support which may clash with DHCPv6.
-+#modules="dhclient" # to select dhclient over dhcpcd
-+
-+# Regardless of which DHCP client you prefer, you configure them the
-+# same way using one of following depending on which interface modules
-+# you're using.
-+#config_eth0="dhcpv6"
-+
-+# You can also use both DHCP and DHCPv6 on a dual-stack network:
-+#config_eth0="dhcp
-+#dhcpv6"
-+
-+# To pass runtime arguments to dhclient for DHCPv6, you do it similarly to
-+# setting runtime arguments for DHCP. Note that you can set options for
-+# DHCPv6 separately or in addition the dhclient arguments for DHCP.
-+#dhclientv6_eth0="..." # options for DHCPv6 only
-+#dhclient_eth0='..." # options for DHCP (also for DHCPv6 when no
-+# # dhclientv6_eth0 is defined)
-+
-+# GENERIC DHCPv6 OPTIONS
-+# Set generic DHCPv6 options just as with generic DHCP options.
-+#dhcpv6_eth0="release nodns nontp nonis nogateway nosendhost"
-+
-+# If no generic DHCPv6 options are set, the default is to fall back to the
-+# DHCP generic options.
-+
-+#-----------------------------------------------------------------------------
- # For APIPA support, emerge net-misc/iputils or net-analyzer/arping
-
- # APIPA is a module that tries to find a free address in the range
-diff --git a/init.d/net.lo.in b/init.d/net.lo.in
-index d42b5ae..2d6d4fb 100644
---- a/init.d/net.lo.in
-+++ b/init.d/net.lo.in
-@@ -211,6 +211,11 @@ _show_address()
- einfo "received address $(_get_inet_address "${IFACE}")"
- }
-
-+_show_address6()
-+{
-+ einfo "received address $(_get_inet6_address "${IFACE}")"
-+}
-+
- # Basically sorts our modules into order and saves the list
- _gen_module_list()
- {
-diff --git a/net/Makefile b/net/Makefile
-index cc24a80..7bde5e1 100644
---- a/net/Makefile
-+++ b/net/Makefile
-@@ -13,7 +13,7 @@ SRCS-Linux= iwconfig.sh.in
- INC-Linux= adsl.sh apipa.sh arping.sh bonding.sh br2684ctl.sh bridge.sh \
- ccwgroup.sh clip.sh ethtool.sh iproute2.sh ifplugd.sh ip6to4.sh \
- ipppd.sh iwconfig.sh netplugd.sh pppd.sh pump.sh tuntap.sh udhcpc.sh \
-- vlan.sh macvlan.sh ip6rd.sh firewalld.sh
-+ vlan.sh macvlan.sh ip6rd.sh firewalld.sh dhclientv6.sh
-
- SRCS-NetBSD=
- INC-NetBSD= ifwatchd.sh
-diff --git a/net/dhclientv6.sh b/net/dhclientv6.sh
-new file mode 100644
-index 0000000..f87ed4d
---- /dev/null
-+++ b/net/dhclientv6.sh
-@@ -0,0 +1,82 @@
-+# Copyright (c) 2007-2008 Roy Marples <roy@marples.name>
-+# Released under the 2-clause BSD license.
-+
-+dhclientv6_depend()
-+{
-+ after interface
-+ program start /sbin/dhclient
-+ provide dhcpv6
-+}
-+
-+_config_vars="$_config_vars dhcp dhclient dhcpv6 dhclientv6"
-+
-+dhclientv6_start()
-+{
-+ local args= opt= opts= pidfile="/var/run/dhclientv6-${IFACE}.pid"
-+ local sendhost=true dconf=
-+
-+ # Get our options
-+ # These options only work in Gentoo, and maybe RedHat
-+ eval args=\$dhclientv6_${IFVAR}
-+ [ -z "${args}" ] && eval args=\$dhclient_${IFVAR}
-+ eval opts=\$dhcpv6_${IFVAR}
-+ [ -z "${opts}" ] && opts=${dhcpv6}
-+ [ -z "${opts}" ] && eval opts=\$dhcp_${IFVAR}
-+ [ -z "${opts}" ] && opts=${dhcp}
-+
-+ for opt in ${opts}; do
-+ case "${opt}" in
-+ nodns) args="${args} -e PEER_DNS=no";;
-+ nontp) args="${args} -e PEER_NTP=no";;
-+ nogateway) args="${args} -e PEER_ROUTERS=no";;
-+ nosendhost) sendhost=false;;
-+ esac
-+ done
-+
-+ # Add our route metric
-+ [ "${metric:-0}" != "0" ] && args="${args} -e IF_METRIC=${metric}"
-+
-+ if ${sendhost}; then
-+ local hname="$(hostname)"
-+ if [ "${hname}" != "(none)" -a "${hname}" != "localhost" ]; then
-+ dhconf="${dhconf} interface \"${IFACE}\" {"
-+ dhconf="${dhconf} send fqdn.fqdn \"${hname}\";"
-+ dhconf="${dhconf} send fqdn.encoded on;"
-+ dhconf="${dhconf} send fqdn.server-update on;"
-+ dhconf="${dhconf} send fqdn.no-client-update on;"
-+ dhconf="${dhconf}}"
-+ fi
-+ fi
-+
-+ # Bring up DHCP for this interface
-+ ebegin "Running dhclient -6"
-+ echo "${dhconf}" | start-stop-daemon --start --exec /sbin/dhclient \
-+ --pidfile "${pidfile}" \
-+ -- -6 ${args} -q -1 -pf "${pidfile}" "${IFACE}"
-+ eend $? || return 1
-+
-+ _show_address6
-+ return 0
-+}
-+
-+dhclientv6_stop()
-+{
-+ local pidfile="/var/run/dhclientv6-${IFACE}.pid" opts=
-+ [ ! -f "${pidfile}" ] && return 0
-+
-+ # Get our options
-+ if [ -x /sbin/dhclient ]; then
-+ eval opts=\$dhcp_${IFVAR}
-+ [ -z "${opts}" ] && opts=${dhcp}
-+ fi
-+
-+ ebegin "Stopping dhclient -6 on ${IFACE}"
-+ case " ${opts} " in
-+ *" release "*) dhclient -6 -q -r -pf "${pidfile}" "${IFACE}";;
-+ *)
-+ start-stop-daemon --stop --quiet \
-+ --exec /sbin/dhclient --pidfile "${pidfile}"
-+ ;;
-+ esac
-+ eend $?
-+}
-diff --git a/net/ifconfig.sh.Linux.in b/net/ifconfig.sh.Linux.in
-index 19e5c35..739e63a 100644
---- a/net/ifconfig.sh.Linux.in
-+++ b/net/ifconfig.sh.Linux.in
-@@ -86,21 +86,41 @@ _get_inet_address()
- echo "/$(_netmask2cidr "$1")"
- }
-
--_get_inet_addresses()
-+_get_inet6_address()
-+{
-+ set -- $(LC_ALL=C ifconfig "${IFACE}" |
-+ sed -n -e 's/.*\(inet6 addr:\|inet6\) \([^ /]*\)\(\/\| *prefixlen \)\([^ ]*\).*/\2\/\4/p')
-+ [ -z "$1" ] && return 1
-+
-+ echo -n "$1"
-+}
-+
-+_get_addresses_fn()
- {
-+ local fn="$1"
- local iface=${IFACE} i=0
-- local addrs="$(_get_inet_address)"
-+ local addrs="$($fn)"
-
- while true; do
- local IFACE="${iface}:${i}"
- _exists || break
-- local addr="$(_get_inet_address)"
-+ local addr="$($fn)"
- [ -n "${addr}" ] && addrs="${addrs}${addrs:+ }${addr}"
- : $(( i += 1 ))
- done
- echo "${addrs}"
- }
-
-+_get_inet_addresses()
-+{
-+ _get_addresses_fn _get_inet_address
-+}
-+
-+_get_inet6_addresses()
-+{
-+ _get_addresses_fn _get_inet6_address
-+}
-+
- _cidr2netmask()
- {
- local cidr="$1" netmask="" done=0 i=0 sum=0 cur=128
-diff --git a/net/iproute2.sh b/net/iproute2.sh
-index 3bab7b7..81fefae 100644
---- a/net/iproute2.sh
-+++ b/net/iproute2.sh
-@@ -84,8 +84,16 @@ _set_mac_address()
-
- _get_inet_addresses()
- {
-- LC_ALL=C ip -family inet addr show "${IFACE}" | \
-- sed -n -e 's/.*inet \([^ ]*\).*/\1/p'
-+ local family="$1";
-+ if [ -z "$family" ]; then
-+ family="inet"
-+ fi
-+ LC_ALL=C ip -family $family addr show "${IFACE}" | \
-+ sed -n -e 's/.*inet6\? \([^ ]*\).*/\1/p'
-+}
-+
-+_get_inet6_addresses() {
-+ _get_inet_addresses "inet6"
- }
-
- _get_inet_address()
-@@ -95,6 +103,13 @@ _get_inet_address()
- echo "$1"
- }
-
-+_get_inet6_address()
-+{
-+ set -- $(_get_inet6_addresses)
-+ [ $# = "0" ] && return 1
-+ echo "$1"
-+}
-+
- _add_address()
- {
- if [ "$1" = "127.0.0.1/8" -a "${IFACE}" = "lo" ]; then
diff --git a/profiles/sattvik/linux/amd64/13.0/workstation/eapi b/profiles/sattvik/linux/amd64/13.0/workstation/eapi
deleted file mode 100644
index 7ed6ff8..0000000
--- a/profiles/sattvik/linux/amd64/13.0/workstation/eapi
+++ /dev/null
@@ -1 +0,0 @@
-5
diff --git a/profiles/sattvik/linux/amd64/13.0/workstation/make.defaults b/profiles/sattvik/linux/amd64/13.0/workstation/make.defaults
deleted file mode 100644
index 2efeffb..0000000
--- a/profiles/sattvik/linux/amd64/13.0/workstation/make.defaults
+++ /dev/null
@@ -1,3 +0,0 @@
-USE="X alsa cups jpeg opengl png"
-
-# vim:set ft=gentoo-make-conf:
diff --git a/profiles/sattvik/linux/amd64/13.0/workstation/parent b/profiles/sattvik/linux/amd64/13.0/workstation/parent
deleted file mode 100644
index f3229c5..0000000
--- a/profiles/sattvik/linux/amd64/13.0/workstation/parent
+++ /dev/null
@@ -1 +0,0 @@
-..