summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Solano Gómez <daniel@solanogomez.org>2017-10-24 19:51:04 -0500
committerDaniel Solano Gómez <daniel@solanogomez.org>2017-10-24 19:51:04 -0500
commite632e4a9e6473e162156ce69ae5a66e0a2c525ed (patch)
tree7359e6c8e1f832a1220e76d83bedaf8d881adef1
parentAdd dev-python/tabulate-0.8.1 (diff)
downloadsattvik-e632e4a9e6473e162156ce69ae5a66e0a2c525ed.tar.gz
sattvik-e632e4a9e6473e162156ce69ae5a66e0a2c525ed.tar.bz2
sattvik-e632e4a9e6473e162156ce69ae5a66e0a2c525ed.zip
add app-misc/todoman-3.4.2
-rw-r--r--app-misc/todoman/Manifest3
-rw-r--r--app-misc/todoman/metadata.xml12
-rw-r--r--app-misc/todoman/todoman-3.2.4.ebuild53
3 files changed, 68 insertions, 0 deletions
diff --git a/app-misc/todoman/Manifest b/app-misc/todoman/Manifest
new file mode 100644
index 0000000..b8bb384
--- /dev/null
+++ b/app-misc/todoman/Manifest
@@ -0,0 +1,3 @@
+DIST todoman-3.2.4.tar.gz 55333 SHA256 c9016b76f94313ffe7c8fbb096dd3fc86f53a8e6420153d8149e8d3119d963e7 SHA512 36f18a7a17da002118cbdd52b877ac1754a42928b2522e17325e6f861b9d1319a666b886beb19a8ad16f93c935df852f715125f474c505283ec7066363cf55c8 WHIRLPOOL de2a85d45d622388b86aed2f8db2fbd06ced7b9b41a904aaa1d4f8cd1520e1ff967d6221b175047a4b0105bfa6f3d84f57f539207d7a22cc7716ed2e0de147a2
+EBUILD todoman-3.2.4.ebuild 1543 SHA256 40915c8d3834e568a6a821c7302c4a7e765bc870eac6e3caf756dae6dee30d94 SHA512 b57335bbf0b30cc29f26a4f1a0928dfd96425eebf4230250d597eb65d789cb7033211e116a61237bc8ec12270cdf530b7a438777ae9fc5ebc753740cc9c42e6e WHIRLPOOL 62cbe8221e16cf233ef70e1c5d9b0904142368c7acf37ac3ca0a073676892f63a2dd81dd02be6e57c0fa91d6000fc9690aacaa9dd4dd476811c6c9a73fefcd29
+MISC metadata.xml 384 SHA256 81b6c7637c68db72c14bb62f3899249181eddda9375737ca6eacbd87b2f6ff77 SHA512 7941edd8b3d4c31465c3b035b1551b025c0c61f46d4a044e643a7fe0d5b80e7c9db91876d1f27f9045a1bd02e8b27d447c4e32f0673bc3a33ae18358e25c50e1 WHIRLPOOL 698c03bad34ecc545e5f2c99ee7f489082716eeb9f2d671ba2418e83e8eb12ece396e9918f9954073c96f27752d6e06d52cd6ac861d09a0df9cf98da191abb7d
diff --git a/app-misc/todoman/metadata.xml b/app-misc/todoman/metadata.xml
new file mode 100644
index 0000000..b9cfad7
--- /dev/null
+++ b/app-misc/todoman/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Daniel Solano Gómez</name>
+ <email>daniel@solanogomez.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">todoman</remote-id>
+ <remote-id type="github">pimutils/todoman</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-misc/todoman/todoman-3.2.4.ebuild b/app-misc/todoman/todoman-3.2.4.ebuild
new file mode 100644
index 0000000..9aef150
--- /dev/null
+++ b/app-misc/todoman/todoman-3.2.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="A simple CalDav-based todo manager"
+HOMEPAGE="https://github.com/pimutils/todoman"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="dev-python/atomicwrites[${PYTHON_USEDEP}]
+ >=dev-python/click-6.0[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ dev-python/icalendar[${PYTHON_USEDEP}]
+ dev-python/parsedatetime[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/tabulate[${PYTHON_USEDEP}]
+ dev-python/urwid[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ )"
+
+DOCS=( AUTHORS.rst CHANGELOG.rst README.rst todoman.conf.sample )
+
+python_test() {
+# # skip tests needing servers running
+# local -x DAV_SERVER=skip
+# local -x REMOTESTORAGE_SERVER=skip
+# # pytest dies hard if the envvars do not have any value...
+# local -x CI=false
+# local -x DETERMINISTIC_TESTS=false
+ pytest || die "Tests fail with ${EPYTHON}"
+}