summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorDaniel Solano Gómez <daniel@solanogomez.org>2010-01-21 21:10:21 -0600
committerDaniel Solano Gómez <daniel@solanogomez.org>2010-01-21 21:10:21 -0600
commit4533d13a70b2f002b01c4c3f80d8f82f4057949f (patch)
tree652c01aad6bfc8efeedb60f9a4fc1259ba227284 /sys-fs
parentUpdated manifest and QA fixes (diff)
downloadsattvik-4533d13a70b2f002b01c4c3f80d8f82f4057949f.tar.gz
sattvik-4533d13a70b2f002b01c4c3f80d8f82f4057949f.tar.bz2
sattvik-4533d13a70b2f002b01c4c3f80d8f82f4057949f.zip
Updated mtpfs ebuild.
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/mtpfs/Manifest2
-rw-r--r--sys-fs/mtpfs/mtpfs-0.9.ebuild55
2 files changed, 23 insertions, 34 deletions
diff --git a/sys-fs/mtpfs/Manifest b/sys-fs/mtpfs/Manifest
index 5f14e83..efaae87 100644
--- a/sys-fs/mtpfs/Manifest
+++ b/sys-fs/mtpfs/Manifest
@@ -1,2 +1,2 @@
DIST mtpfs-0.9.tar.gz 95038 RMD160 b2a5b67203da4579829bbce8a3d93b7a07ca3b01 SHA1 c2ccf17ac2b73f09d5ff84cacae810e3989016b4 SHA256 828e82955232155380b243348eb16cb5f6acfe02ddbf97222308b2fc2dcb1d09
-EBUILD mtpfs-0.9.ebuild 1328 RMD160 08d3ce236bbb2071cc90150172dcd9b461bfebe3 SHA1 c98245829ba024950a4d02738a1c166dceeeca69 SHA256 fe4975f189647e76726f4119f20c32c175bd4d26acb8c38e42e177397f2bcef9
+EBUILD mtpfs-0.9.ebuild 885 RMD160 20877ec7dbbce47e3a41af4d3ca6ba95d244da78 SHA1 68ea43d02ff37df648b5a0b2359398046c9cbf8a SHA256 ad41d5f101be37a991f081f63a44e52cd7cdd805f778026fb373aacb8d0abf7b
diff --git a/sys-fs/mtpfs/mtpfs-0.9.ebuild b/sys-fs/mtpfs/mtpfs-0.9.ebuild
index 4c89eff..efdfcfb 100644
--- a/sys-fs/mtpfs/mtpfs-0.9.ebuild
+++ b/sys-fs/mtpfs/mtpfs-0.9.ebuild
@@ -1,51 +1,40 @@
-# ==========================================================================
-# This ebuild come from akoya repository. Zugaina.org only host a copy.
-# For more info go to http://gentoo.zugaina.org/
-# ************************ General Portage Overlay ************************
-# ==========================================================================
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-inherit eutils
+EAPI="2"
-S="${WORKDIR}/mtpfs-${PV}"
-
-DESCRIPTION="A FUSE filesystem providing access to MTP devices."
-HOMEPAGE="http://www.adebenham.com/mtpfs/"
-SRC_URI="http://www.adebenham.com/mtpfs/${P}.tar.gz"
+DESCRIPTION="MTPFS is a Fuse filesystem based on libmtp"
+HOMEPAGE="http://adebenham.com/mtpfs"
+SRC_URI="http://adebenham.com/mtpfs/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~x86"
IUSE="debug"
-DEPEND=">=sys-fs/fuse-2.2
- >=dev-libs/glib-2.6
- >=media-libs/libmtp-0.0.9"
-
+DEPEND="sys-fs/fuse
+ >=dev-libs/glib-2.18.4-r1
+ media-libs/libmtp"
RDEPEND="${DEPEND}"
+src_configure() {
+ econf $(use_enable debug) || die 'econf failed'
+}
+
src_compile() {
- econf $(use_enable debug)
- emake
+ emake || die 'emake failed'
}
src_install() {
- einstall || die "einstall failed"
- dodoc AUTHORS INSTALL NEWS README ChangeLog
+ emake DESTDIR="${D}" install || die 'installation failed'
+ dodoc AUTHORS INSTALL NEWS README ChangeLog
}
pkg_postinst() {
- einfo "To mount your MTP device, issue:"
- einfo " /usr/bin/mtpfs <mountpoint>"
- einfo
- einfo "To unmount your MTP device, issue:"
- einfo " /usr/bin/fusermount -u <mountpoint>"
-
- if use debug; then
- einfo
- einfo "You have enabled debugging output."
- einfo "Please make sure you run mtpfs with the -d flag."
- fi
-}
+ einfo "To mount your MTP device, issue:"
+ einfo " /usr/bin/mtpfs <mountpoint>"
+ einfo
+ einfo "To unmount your MTP device, issue:"
+ einfo " /usr/bin/fusermount -u <mountpoint>"
+}