summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorDaniel Solano Gómez <daniel@solanogomez.org>2009-10-26 09:54:14 -0500
committerDaniel Solano Gómez <daniel@solanogomez.org>2009-10-26 09:54:14 -0500
commitaf61ac2ea38bd12f5f54649df86eac9184c0d46d (patch)
treee8fda175a7f558fa8f8e94bbbbad3e4619732ab2 /sys-fs
downloadsattvik-af61ac2ea38bd12f5f54649df86eac9184c0d46d.tar.gz
sattvik-af61ac2ea38bd12f5f54649df86eac9184c0d46d.tar.bz2
sattvik-af61ac2ea38bd12f5f54649df86eac9184c0d46d.zip
Initial commit from backup.
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/mtpfs/Manifest2
-rw-r--r--sys-fs/mtpfs/mtpfs-0.9.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/sys-fs/mtpfs/Manifest b/sys-fs/mtpfs/Manifest
new file mode 100644
index 0000000..5f14e83
--- /dev/null
+++ b/sys-fs/mtpfs/Manifest
@@ -0,0 +1,2 @@
+DIST mtpfs-0.9.tar.gz 95038 RMD160 b2a5b67203da4579829bbce8a3d93b7a07ca3b01 SHA1 c2ccf17ac2b73f09d5ff84cacae810e3989016b4 SHA256 828e82955232155380b243348eb16cb5f6acfe02ddbf97222308b2fc2dcb1d09
+EBUILD mtpfs-0.9.ebuild 1328 RMD160 08d3ce236bbb2071cc90150172dcd9b461bfebe3 SHA1 c98245829ba024950a4d02738a1c166dceeeca69 SHA256 fe4975f189647e76726f4119f20c32c175bd4d26acb8c38e42e177397f2bcef9
diff --git a/sys-fs/mtpfs/mtpfs-0.9.ebuild b/sys-fs/mtpfs/mtpfs-0.9.ebuild
new file mode 100644
index 0000000..4c89eff
--- /dev/null
+++ b/sys-fs/mtpfs/mtpfs-0.9.ebuild
@@ -0,0 +1,51 @@
+# ==========================================================================
+# This ebuild come from akoya repository. Zugaina.org only host a copy.
+# For more info go to http://gentoo.zugaina.org/
+# ************************ General Portage Overlay ************************
+# ==========================================================================
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+S="${WORKDIR}/mtpfs-${PV}"
+
+DESCRIPTION="A FUSE filesystem providing access to MTP devices."
+HOMEPAGE="http://www.adebenham.com/mtpfs/"
+SRC_URI="http://www.adebenham.com/mtpfs/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND=">=sys-fs/fuse-2.2
+ >=dev-libs/glib-2.6
+ >=media-libs/libmtp-0.0.9"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ econf $(use_enable debug)
+ emake
+}
+
+src_install() {
+ einstall || die "einstall failed"
+ dodoc AUTHORS INSTALL NEWS README ChangeLog
+}
+
+pkg_postinst() {
+ einfo "To mount your MTP device, issue:"
+ einfo " /usr/bin/mtpfs <mountpoint>"
+ einfo
+ einfo "To unmount your MTP device, issue:"
+ einfo " /usr/bin/fusermount -u <mountpoint>"
+
+ if use debug; then
+ einfo
+ einfo "You have enabled debugging output."
+ einfo "Please make sure you run mtpfs with the -d flag."
+ fi
+}