summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <sven.eden@gmx.de>2017-08-31 17:47:21 +0200
committerSven Eden <sven.eden@gmx.de>2017-08-31 17:47:21 +0200
commit531be1c201cf10c55729c4dd8dd84c81d59f1f15 (patch)
tree624f5e686a64620885745a2336c1eebfd94b216e
parentapp-backup/kup: Make USE="system-libgit2" the default. (diff)
downloadseden-531be1c201cf10c55729c4dd8dd84c81d59f1f15.tar.gz
seden-531be1c201cf10c55729c4dd8dd84c81d59f1f15.tar.bz2
seden-531be1c201cf10c55729c4dd8dd84c81d59f1f15.zip
sys-auth/elogind-9999 : New live ebuild to test new meson build in master.
-rw-r--r--profiles/package.mask/elogind1
-rw-r--r--sys-auth/elogind/elogind-9999.ebuild93
2 files changed, 94 insertions, 0 deletions
diff --git a/profiles/package.mask/elogind b/profiles/package.mask/elogind
index e4bfb01..9f65bc9 100644
--- a/profiles/package.mask/elogind
+++ b/profiles/package.mask/elogind
@@ -8,5 +8,6 @@
=sys-auth/elogind-232.9999
=sys-auth/elogind-233.9999
=sys-auth/elogind-234.9999
+=sys-auth/elogind-9999
=sys-process/procps-3.3.12-r2
=x11-apps/xinit-1.3.4-r3
diff --git a/sys-auth/elogind/elogind-9999.ebuild b/sys-auth/elogind/elogind-9999.ebuild
new file mode 100644
index 0000000..5066319
--- /dev/null
+++ b/sys-auth/elogind/elogind-9999.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit git-r3 linux-info meson pam udev
+
+DESCRIPTION="The systemd project's logind, extracted to a standalone package"
+HOMEPAGE="https://github.com/elogind/elogind"
+EGIT_REPO_URI="https://github.com/elogind/elogind.git"
+EGIT_BRANCH="master"
+
+LICENSE="CC0-1.0 LGPL-2.1+ public-domain"
+SLOT="0"
+KEYWORDS=""
+IUSE="+acl debug doc +pam +policykit selinux"
+
+RDEPEND="
+ sys-apps/util-linux
+ sys-libs/libcap
+ virtual/libudev:=
+ acl? ( sys-apps/acl )
+ pam? ( virtual/pam )
+ selinux? ( sys-libs/libselinux )
+ !sys-apps/systemd
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.2
+ app-text/docbook-xml-dtd:4.5
+ app-text/docbook-xsl-stylesheets
+ dev-util/gperf
+ dev-util/intltool
+ >=dev-util/meson-0.41.0
+ >=dev-util/ninja-1.7.2
+ virtual/pkgconfig
+"
+PDEPEND="
+ sys-apps/dbus
+ policykit? ( sys-auth/polkit )
+"
+
+pkg_setup() {
+ local CONFIG_CHECK="~CGROUPS ~EPOLL ~INOTIFY_USER ~SECURITY_SMACK
+ ~SIGNALFD ~TIMERFD"
+
+ if use kernel_linux; then
+ linux-info_pkg_setup
+ fi
+}
+
+src_configure() {
+ local emesonargs
+ emesonargs=(
+ -Ddocdir="${EPREFIX}/usr/share/doc/${P}" \
+ -Dhtmldir="${EPREFIX}/usr/share/doc/${P}/html" \
+ -Dpamlibdir=$(getpam_mod_dir) \
+ -Dudevrulesdir="$(get_udevdir)"/rules.d \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ -Drootlibdir="${EPREFIX}"/$(get_libdir) \
+ -Drootlibexecdir="${EPREFIX}"/$(get_libdir)/elogind \
+ -Drootprefix="/" \
+ -Dsmack=true \
+ -Dman=auto \
+ -Dhtml=$(usex doc auto false) \
+ -Dcgroup-controller=openrc \
+ -Ddefault-hierarchy=legacy \
+ -Ddebug=$(usex debug elogind false) \
+ --buildtype $(usex debug debug release) \
+ -Dacl=$(usex acl true false) \
+ -Dpam=$(usex pam true false) \
+ -Dselinux=$(usex selinux true false)
+ -Dbashcompletiondir="${EPREFIX}/usr/share/bash-completion/completions" \
+ -Dzsh-completion="${EPREFIX}/usr/share/zsh/site-functions" \
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ newinitd "${FILESDIR}"/${PN}.init ${PN}
+
+ sed -e "s/@libdir@/$(get_libdir)/" "${FILESDIR}"/${PN}.conf.in > ${PN}.conf || die
+ newconfd ${PN}.conf ${PN}
+}
+
+pkg_postinst() {
+ if [ "$(rc-config list boot | grep elogind)" = "" ]; then
+ ewarn "To enable the elogind daemon, elogind must be"
+ ewarn "added to the boot runlevel:"
+ ewarn "# rc-update add elogind boot"
+ fi
+}