summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <sven.eden@gmx.de>2017-03-13 14:44:50 +0100
committerSven Eden <sven.eden@gmx.de>2017-03-13 14:44:50 +0100
commita510c141214fb946717cb24b76ee44f3ae6af727 (patch)
tree1acbd5f787b1cbc46e58503d78b57925d570c0af
parentx11-wm/lumina-1.2.0.1-r1 : Test-Ebuild for Lumina 1.2.0 Patch 01 (diff)
downloadseden-a510c141214fb946717cb24b76ee44f3ae6af727.tar.gz
seden-a510c141214fb946717cb24b76ee44f3ae6af727.tar.bz2
seden-a510c141214fb946717cb24b76ee44f3ae6af727.zip
media-plugins/vocoder-ladspa-0.4 : Version bump - derived from proaudio overlay.
-rw-r--r--media-plugins/vocoder-ladspa/Manifest1
-rw-r--r--media-plugins/vocoder-ladspa/metadata.xml9
-rw-r--r--media-plugins/vocoder-ladspa/vocoder-ladspa-0.4.ebuild34
3 files changed, 44 insertions, 0 deletions
diff --git a/media-plugins/vocoder-ladspa/Manifest b/media-plugins/vocoder-ladspa/Manifest
new file mode 100644
index 0000000..e959266
--- /dev/null
+++ b/media-plugins/vocoder-ladspa/Manifest
@@ -0,0 +1 @@
+DIST vocoder-ladspa-0.4.tgz 5014 SHA256 4a8d72f1a471af026fce5b785d5236bcb9560c4e3cab7b3d03d8f1d86dd9dd14 SHA512 71ec50e7079f3181bdb76ae6d6a07596d2e9254cefa8a887c14c83e3ea3fb4ae9244794070c3a6015fe0af41db07b6bbed5687b25c2d2411651294a434457fe4 WHIRLPOOL 0084214279c8ef8aede3cbc1cd19867603d3a9e4233a4bb450119f4600a0bb31903baa433d7f2f5d9af640b6c0b2a5eedae675c2408372933e47409e7589063d
diff --git a/media-plugins/vocoder-ladspa/metadata.xml b/media-plugins/vocoder-ladspa/metadata.xml
new file mode 100644
index 0000000..7f7220f
--- /dev/null
+++ b/media-plugins/vocoder-ladspa/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>yamakuzure@gmx.net</email>
+ <name>Sven Eden</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/media-plugins/vocoder-ladspa/vocoder-ladspa-0.4.ebuild b/media-plugins/vocoder-ladspa/vocoder-ladspa-0.4.ebuild
new file mode 100644
index 0000000..3a26d6b
--- /dev/null
+++ b/media-plugins/vocoder-ladspa/vocoder-ladspa-0.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+RESTRICT=mirror
+DESCRIPTION="A vocoder is a sound effect that can make a human voice sound
+synthetic"
+HOMEPAGE="http://www.sirlab.de/linux/descr_vocoder.html"
+SRC_URI="http://www.sirlab.de/linux/download/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="media-libs/ladspa-sdk"
+MY_P="${P/-ladspa/}"
+S=${WORKDIR}/${MY_P}
+
+src_unpack(){
+ unpack "${A}"
+ cd "${S}"
+}
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ dodoc COPYRIGHT README
+ insinto /usr/$(get_libdir)/ladspa
+ insopts -m0755
+ doins vocoder.so
+}