summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/lhasa/lhasa-0.3.1.ebuild')
-rw-r--r--app-arch/lhasa/lhasa-0.3.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-arch/lhasa/lhasa-0.3.1.ebuild b/app-arch/lhasa/lhasa-0.3.1.ebuild
new file mode 100644
index 0000000..b72bcc0
--- /dev/null
+++ b/app-arch/lhasa/lhasa-0.3.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Lhasa aims to be compatible with as many types of lzh/lzs archives as possible."
+HOMEPAGE="https://fragglet.github.io/lhasa/"
+SRC_URI="https://soulsphere.org/projects/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="!app-arch/lha"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+}