summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/pwxlib')
-rw-r--r--dev-cpp/pwxlib/Manifest1
-rw-r--r--dev-cpp/pwxlib/metadata.xml34
-rw-r--r--dev-cpp/pwxlib/pwxlib-0.8.9.ebuild80
-rw-r--r--dev-cpp/pwxlib/pwxlib-9999.ebuild101
4 files changed, 0 insertions, 216 deletions
diff --git a/dev-cpp/pwxlib/Manifest b/dev-cpp/pwxlib/Manifest
deleted file mode 100644
index 1538664..0000000
--- a/dev-cpp/pwxlib/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST pwxlib-0.8.9.tar.gz 272119 SHA256 ab4b4a8baa09df7eed1cbfb1b04c9416387e86d5301767508b2d940539b38492 SHA512 a065326d63b254ceedbfbd57f1d28c388b66d64628b4ed4308004ca33f0937298b17cc44d6b6139e058120df2b96b859e27704d5706265894ec97baeaf40a4e8 WHIRLPOOL a7606316a7126228a01fbed1ad58fe799cfa491e14696525621a5638a28c962f45163c1fa1cc8145a43fa3456cfbe05bb3e28b1787b917920fb6465035c17e71
diff --git a/dev-cpp/pwxlib/metadata.xml b/dev-cpp/pwxlib/metadata.xml
deleted file mode 100644
index ebc381e..0000000
--- a/dev-cpp/pwxlib/metadata.xml
+++ /dev/null
@@ -1,34 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>yamakuzure@gmx.net</email>
- <name>Sven Eden</name>
- </maintainer>
- <use>
- <flag name="asan">Enable address sanitizer</flag>
- <flag name="annotations">
- Annotate inter thread synchronization for debugging with
- valgrind.
- </flag>
- <flag name="debug-thread">
- Produce massive debugging output. Do not enable lightly!
- </flag>
- <flag name="lsan">Enable leak sanitizer</flag>
- <flag name="spinlocks">
- Use spinlocks instead of mutexes. Improves performance.
- </flag>
- <flag name="test">Build and install test programs.</flag>
- <flag name="torture">
- Build and install torture, the multi-threaded container
- burner.</flag>
- <flag name="tsan">Enable thread sanitizer</flag>
- <flag name="yielding">
- Let spinlocks yield when they can not lock. Improves
- performance.
- </flag>
- </use>
- <upstream>
- <remote-id type="github">Yamakuzure/pwxlib</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-cpp/pwxlib/pwxlib-0.8.9.ebuild b/dev-cpp/pwxlib/pwxlib-0.8.9.ebuild
deleted file mode 100644
index e2efeac..0000000
--- a/dev-cpp/pwxlib/pwxlib-0.8.9.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic meson
-
-DESCRIPTION="The PrydeWorX library of C++ workers, tools and utilities"
-HOMEPAGE="https://pwxlib.prydeworx.com"
-SRC_URI="https://github.com/Yamakuzure/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="annotations debug debug-thread doc profile +spinlocks test torture +yielding"
-
-REQUIRED_USE="
- ?? ( annotations debug-thread )
- annotations? ( !spinlocks !yielding )
- profile? ( !debug !debug-thread )
- yielding? ( spinlocks )
-"
-COMMON_DEPEND="
- debug-thread? ( dev-util/valgrind )
-"
-DEPEND="${COMMON_DEPEND}
- doc? ( app-doc/doxygen )
- >=sys-devel/gcc-8.2.0
- virtual/pkgconfig
-"
-RDEPEND="${COMMON_DEPEND}"
-
-src_configure() {
- # Duplicating C[XX]FLAGS in LDFLAGS is deprecated and will become
- # a hard error in future meson versions:
- filter-ldflags $CFLAGS $CXXFLAGS
-
- local emesonargs=(
- -Ddocdir="${EPREFIX}/usr/share/doc/${PF}"
- --buildtype $(usex debug debug release)
- --libdir="${EPREFIX}"/usr/$(get_libdir)
- -Dannotations=$(usex annotations true false)
- -Ddebug-extra=$(usex debug true false)
- -Ddebug-thread=$(usex debug-thread true false)
- -Dhtml=$(usex doc true false)
- -Dinstall-tests=$(usex test true false)
- -Dprofile=$(usex profile true false)
- -Dspinlocks=$(usex spinlocks true false)
- -Dtests=$(usex test true false)
- -Dtorture=$(usex torture true false)
- -Dyielding=$(usex yielding true false)
- )
-
- meson_src_configure
-}
-
-src_install() {
- DOCS=(
- AUTHORS
- ChangeLog
- code_of_conduct.md
- CONTRIBUTING.md
- INSTALL.md
- LICENSE
- NEWS.md
- README.md
- TODO.md
- )
-
- meson_src_install
-}
-
-pkg_postinst() {
- if use debug-thread; then
- ewarn "You have enabled USE=\"debug-thread\""
- ewarn "This flag enables an excessive amount of debug"
- ewarn "messages, which are only useful if you work on"
- ewarn "the multi-threading code of pwxlib itself."
- fi
-}
diff --git a/dev-cpp/pwxlib/pwxlib-9999.ebuild b/dev-cpp/pwxlib/pwxlib-9999.ebuild
deleted file mode 100644
index 336849e..0000000
--- a/dev-cpp/pwxlib/pwxlib-9999.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic git-r3 meson
-
-DESCRIPTION="The PrydeWorX library of C++ workers, tools and utilities"
-HOMEPAGE="https://pwxlib.prydeworx.com"
-EGIT_REPO_URI="https://github.com/Yamakuzure/pwxlib.git"
-EGIT_BRANCH="master"
-EGIT_SUBMODULES=()
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS=""
-IUSE="annotations asan debug debug-thread doc lsan profile +spinlocks test
-torture tsan +yielding"
-
-REQUIRED_USE="
- ?? ( annotations debug-thread )
- ?? ( asan lsan tsan )
- annotations? ( !spinlocks !yielding )
- asan? ( debug )
- lsan? ( debug )
- profile? ( !debug !debug-thread )
- tsan? ( debug )
- yielding? ( spinlocks )
-"
-COMMON_DEPEND="
- debug-thread? ( dev-util/valgrind )
-"
-DEPEND="${COMMON_DEPEND}
- doc? ( app-doc/doxygen )
- >=sys-devel/gcc-8.2.0
- virtual/pkgconfig
-"
-RDEPEND="${COMMON_DEPEND}"
-
-src_configure() {
- local b_san
-
- # Duplicating C[XX]FLAGS in LDFLAGS is deprecated and will become
- # a hard error in future meson versions:
- filter-ldflags $CFLAGS $CXXFLAGS
-
- # See what kind of sanitization is wanted
- if use asan; then
- export ASAN_OPTIONS=detect_leaks=0
- b_san="-Db_sanitize=address"
- elif use lsan; then
- export ASAN_OPTIONS=detect_leaks=1
- b_san="-Db_sanitize=address"
- elif use tsan; then
- b_san="-Db_sanitize=thread"
- fi
-
- local emesonargs=(
- -Ddocdir="${EPREFIX}/usr/share/doc/${PF}"
- --buildtype $(usex debug debug release)
- --libdir="${EPREFIX}"/usr/$(get_libdir)
- -Dannotations=$(usex annotations true false)
- -Ddebug-extra=$(usex debug true false)
- -Ddebug-thread=$(usex debug-thread true false)
- -Dhtml=$(usex doc true false)
- -Dinstall-tests=$(usex test true false)
- -Dprofile=$(usex profile true false)
- -Dspinlocks=$(usex spinlocks true false)
- -Dtests=$(usex test true false)
- -Dtorture=$(usex torture true false)
- -Dyielding=$(usex yielding true false)
- $b_san
- )
-
- meson_src_configure
-}
-
-src_install() {
- DOCS=(
- AUTHORS
- ChangeLog
- code_of_conduct.md
- CONTRIBUTING.md
- INSTALL.md
- LICENSE
- NEWS.md
- README.md
- TODO.md
- )
-
- meson_src_install
-}
-
-pkg_postinst() {
- if use debug-thread; then
- ewarn "You have enabled USE=\"debug-thread\""
- ewarn "This flag enables an excessive amount of debug"
- ewarn "messages, which are only useful if you work on"
- ewarn "the multi-threading code of pwxlib itself."
- fi
-}