summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/shotcut')
-rw-r--r--media-video/shotcut/Manifest3
-rw-r--r--media-video/shotcut/metadata.xml15
-rw-r--r--media-video/shotcut/shotcut-24.04.28.ebuild52
3 files changed, 70 insertions, 0 deletions
diff --git a/media-video/shotcut/Manifest b/media-video/shotcut/Manifest
new file mode 100644
index 0000000..5598e37
--- /dev/null
+++ b/media-video/shotcut/Manifest
@@ -0,0 +1,3 @@
+DIST shotcut-24.04.28.tar.gz 12116059 BLAKE2B 6f0e31d06056fa6f0868125776b9a3b0976eb68b87707d443e6f0bb7cffa44707792e24689e408a230dcf1123fd7e59310a0200bcb9ae17c3948cc089c1decc2 SHA512 023a144df33cdf57b8a40477d1e7cca9b5a3b38a7e514fc5127b971baa4fc9e83c157413e8e343a4d7d8ba355817a7b54b0d701c8146869135ee4509c9df2a11
+EBUILD shotcut-24.04.28.ebuild 1238 BLAKE2B cbb4578047b11477a34a0a2efa21a9a4c149d09838f63456c5e26b4bfe294eda559ca47c6a3ccf5d600541d5eaf4b32384d1eb9b3819c8cda2f875596f3d12c3 SHA512 2949874f05fc8448243e10fdf4705ba8259189ac972522b4ecd78ceb0d089863f28f9117a63dc8dd2c302961efb33aea270b744cd51842a8739621e99a2f1c69
+MISC metadata.xml 481 BLAKE2B 183f296894a3deb21038399eec0a637f2080d029fb8ea539a5a165206868704e472ed554bec67325fb54a4d8aeea54c01857635e32abdd229c91f3ba7855d095 SHA512 95af90837128290393f798b1561ebcbad057da1b5dafb583f9f9ba56878ff1d48245438ea3605601fad608e749235619d2195290c04c5c31eb8bbe627b58f4a7
diff --git a/media-video/shotcut/metadata.xml b/media-video/shotcut/metadata.xml
new file mode 100644
index 0000000..c199e92
--- /dev/null
+++ b/media-video/shotcut/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>xdch47@posteo.de</email>
+ <name>Felix Neumärker</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mltframework/shotcut</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-video/shotcut/shotcut-24.04.28.ebuild b/media-video/shotcut/shotcut-24.04.28.ebuild
new file mode 100644
index 0000000..bdf56cb
--- /dev/null
+++ b/media-video/shotcut/shotcut-24.04.28.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic xdg
+
+DESCRIPTION="A free, open source, cross-platform video editor"
+HOMEPAGE="https://www.shotcut.org/ https://github.com/mltframework/shotcut/"
+if [[ ${PV} != 9999* ]] ; then
+ SRC_URI="https://github.com/mltframework/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mltframework/shotcut/"
+fi
+
+IUSE="debug"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/qttools:6[linguist]
+"
+DEPEND="
+ dev-qt/qtbase:6[concurrent,gui,network,opengl,sql,widgets,xml]
+ dev-qt/qtdeclarative:6[widgets]
+ dev-qt/qtmultimedia:6
+ dev-qt/qtcharts:6
+ >=media-libs/mlt-7.24.0[ffmpeg,frei0r,fftw(+),jack,opengl,qt6,sdl,xml]
+ media-video/ffmpeg
+"
+
+RDEPEND="${DEPEND}
+ virtual/jack
+"
+
+src_configure() {
+ CMAKE_BUILD_TYPE=$(usex debug Debug Release)
+ if [[ ${PV} != 9999* ]] ; then
+ SHOTCUT_VERSION="${PV}"
+ else
+ SHOTCUT_VERSION="$(git log --date=format:'%y.%m.%d' -1 --format='%ad')"
+ fi
+ local mycmakeargs=(
+ -DSHOTCUT_VERSION="${SHOTCUT_VERSION}"
+ )
+ use debug || append-cxxflags "-DNDEBUG"
+ append-cxxflags "-DSHOTCUT_NOUPGRADE"
+ cmake_src_configure
+}