summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/teamviewer')
-rw-r--r--net-misc/teamviewer/Manifest1
-rw-r--r--net-misc/teamviewer/files/teamviewer-7.0.9377-POSIX.patch183
-rw-r--r--net-misc/teamviewer/files/teamviewer-8.0.17147-POSIX.patch399
-rw-r--r--net-misc/teamviewer/files/teamviewer-8.0.17147-gentoo.patch135
-rw-r--r--net-misc/teamviewer/files/teamviewer.service9
-rw-r--r--net-misc/teamviewer/files/teamviewerd.init26
-rw-r--r--net-misc/teamviewer/metadata.xml16
-rw-r--r--net-misc/teamviewer/teamviewer-8.0.20931-r3.ebuild160
8 files changed, 0 insertions, 929 deletions
diff --git a/net-misc/teamviewer/Manifest b/net-misc/teamviewer/Manifest
deleted file mode 100644
index 0d42c86..0000000
--- a/net-misc/teamviewer/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST teamviewer-8.0.20931.deb 19567090 SHA256 6ad27b106a125c51075597c526b7b84fa9637af1aef6ee0514faa49694bf70dd SHA512 991fb4e572b312289097062577c9dfd9189d8405902e6965b224b1ad7e883de2dca99aa18b4ae2e333ce1cab65eade0f86eddccc32ed045140a34037c1a129d0 WHIRLPOOL e7ec1544e13b6cdc161783e36589b1cf07bbe60dd32f811d29e8c7b266477840550a08382c3b4683fbf00a6433305c135714bb30fb260c202a1bb828f0da8d45
diff --git a/net-misc/teamviewer/files/teamviewer-7.0.9377-POSIX.patch b/net-misc/teamviewer/files/teamviewer-7.0.9377-POSIX.patch
deleted file mode 100644
index ebbe5cd..0000000
--- a/net-misc/teamviewer/files/teamviewer-7.0.9377-POSIX.patch
+++ /dev/null
@@ -1,183 +0,0 @@
-From: Julian Ospald <hasufell@gentoo.org>
-Date: Tue Feb 19 21:24:39 UTC 2013
-Subject: make scripts POSIX compliant
-
---- teamviewer7/.tvscript/.regedit
-+++ teamviewer7/.tvscript/.regedit
-@@ -1,4 +1,4 @@
--#!/bin/bash
-+#!/bin/sh
-
- TV_script_dir="$(dirname "$(readlink -f "$0")")"
- "$TV_script_dir/wrapper" wine regedit "$@"
---- teamviewer7/.tvscript/.winecfg
-+++ teamviewer7/.tvscript/.winecfg
-@@ -1,4 +1,4 @@
--#!/bin/bash
-+#!/bin/sh
-
- TV_script_dir="$(dirname "$(readlink -f "$0")")"
- "$TV_script_dir/wrapper" wine winecfg "$@"
---- teamviewer7/.tvscript/killteamviewer
-+++ teamviewer7/.tvscript/killteamviewer
-@@ -1,4 +1,4 @@
--#!/bin/bash
-+#!/bin/sh
- # execute wineserver -k for all users running a TeamViewer
- # (if not called by root, only successful for the current user)
-
---- teamviewer7/.tvscript/teamviewer
-+++ teamviewer7/.tvscript/teamviewer
-@@ -1,4 +1,4 @@
--#!/bin/bash
-+#!/bin/sh
-
- TV_script_dir="$(dirname "$(readlink -f "$0")")"
- "$TV_script_dir/wrapper" wine "c:\Program Files\TeamViewer\Version7\TeamViewer.exe" "$@"
---- teamviewer7/.tvscript/wrapper
-+++ teamviewer7/.tvscript/wrapper
-@@ -1,4 +1,4 @@
--#!/bin/bash
-+#!/bin/sh
-
- TV_script_dir="$(dirname "$(readlink -f "$0")")"
- TV_base_dir="$(dirname "$TV_script_dir")"
-@@ -23,7 +23,7 @@
- export WINESERVER="$TV_Wine_bin/wineserver"
-
-
--function tv_Prepare()
-+tv_Prepare()
- {
- exec 2>&1 # redirect stderr
-
-@@ -33,7 +33,7 @@
- setup_env
- }
-
--function tv_Run()
-+tv_Run()
- {
- exec 2>&1 # redirect stderr
-
-@@ -43,7 +43,7 @@
- "$TV_Wine_bin/$binary" "$@"
- }
-
--function tv_LogInfo()
-+tv_LogInfo()
- {
- exec 2>&1 # redirect stderr
-
-@@ -71,7 +71,7 @@
- echo " "
- }
-
--function setup_wine()
-+setup_wine()
- {
- # setup dosdevices and symlinks
- local c_sym="$WINEPREFIX/dosdevices/c:"
-@@ -88,14 +88,14 @@
- }
-
- # ensure path exists
--function make_path()
-+make_path()
- {
- local path="$1"
- [ -d "$path" ] || mkdir -p "$path" || die "Could not create $path"
- }
-
- # setup/validate drive symlinks
--function setup_drive_symlink()
-+setup_drive_symlink()
- {
- local sym="$1"
- local dst="$2"
-@@ -107,7 +107,7 @@
- }
-
- # setup logfile symlinks
--function setup_log_symlink
-+setup_log_symlink()
- {
- local cuser=$(id -un)
- local basepath="$WINEPREFIX/drive_c/users/$cuser"
-@@ -129,7 +129,7 @@
- }
-
- # setup/validate win symlinks
--function setup_win_symlink()
-+setup_win_symlink()
- {
- local sym="$WINEPREFIX/$1"
- local dst="$TV_Wine_dir/$1"
-@@ -141,7 +141,7 @@
- [ -d $(readlink -f "$sym") ] || ln -s "$dst" "$sym" || die "Could not create $sym (link to $dst)"
- }
-
--function setup_prog_dir()
-+setup_prog_dir()
- {
- local progdir="$WINEPREFIX/drive_c/Program Files/TeamViewer/Version7"
- local progsrc="$TV_Wine_dir/drive_c/Program Files/TeamViewer/Version7"
-@@ -158,7 +158,7 @@
- done
- }
-
--function setup_wine_tweaks()
-+setup_wine_tweaks()
- {
- # Enable Subpixel Hinting
- if ! [ -e "$WINEPREFIX/.set_fontsmooth" ] ; then
-@@ -191,7 +191,7 @@
- fi
- }
-
--function setup_tar_env()
-+setup_tar_env()
- {
- local dsrc="$TV_script_dir/teamviewer.desktop.template"
- local ddst="$TV_script_dir/teamviewer.desktop"
-@@ -210,7 +210,7 @@
- fi
- }
-
--function setup_env()
-+setup_env()
- {
- local tvwine="$TV_Wine_dir/drive_c/Program Files/TeamViewer/Version7/tvwine.dll.so"
-
-@@ -227,7 +227,7 @@
- (cd /etc; ls -m *-release *-version *_version > "$TV_profile/drive_c/distrelease" 2> /dev/null)
- }
-
--function validate_user()
-+validate_user()
- {
- local userid=$(id -un)
-
-@@ -236,7 +236,7 @@
- fi
- }
-
--function validate_binary()
-+validate_binary()
- {
- local binary="$1"
-
-@@ -245,9 +245,11 @@
- fi
- }
-
--function die()
-+die()
- {
-- echo -e "\nError: $@\n"
-+ echo
-+ echo "Error: $@"
-+ echo
- exit 1
- }
-
diff --git a/net-misc/teamviewer/files/teamviewer-8.0.17147-POSIX.patch b/net-misc/teamviewer/files/teamviewer-8.0.17147-POSIX.patch
deleted file mode 100644
index b8c1413..0000000
--- a/net-misc/teamviewer/files/teamviewer-8.0.17147-POSIX.patch
+++ /dev/null
@@ -1,399 +0,0 @@
-From: Julian Ospald <hasufell@gentoo.org>
-Date: Tue Feb 19 22:58:46 UTC 2013
-Subject: make scripts POSIX compliant
-
---- teamviewer8/tv_bin/script/teamviewer
-+++ teamviewer8/tv_bin/script/teamviewer
-@@ -1,6 +1,6 @@
--#!/bin/bash
-+#!/bin/sh
-
- TV_SCRIPT_DIR="$(dirname "$(readlink -e "$0")")"
--source "$TV_SCRIPT_DIR/tvw_main"
-+. "$TV_SCRIPT_DIR/tvw_main"
-
- Main "$@"
---- teamviewer8/tv_bin/script/teamviewer_desktop
-+++ teamviewer8/tv_bin/script/teamviewer_desktop
-@@ -1,6 +1,6 @@
--#!/bin/bash
-+#!/bin/sh
-
- TV_SCRIPT_DIR="$(dirname "$(readlink -e "$0")")"
--source "$TV_SCRIPT_DIR/tvw_main"
-+. "$TV_SCRIPT_DIR/tvw_main"
-
- Run_TeamViewer_Desktop "$@"
---- teamviewer8/tv_bin/script/tvw_aux
-+++ teamviewer8/tv_bin/script/tvw_aux
-@@ -1,30 +1,34 @@
--#!/bin/bash
-+#!/bin/sh
-
-
- # die with message
--function die()
-+die()
- {
-- echo -e "\nError: $@\n"
-+ echo
-+ echo "Error: $@"
-+ echo
- exit 1
- }
-
--function ABecho()
-+ABecho()
- {
- printf "\E[1m %-30s \E[0m %s \n" "$1" "$2"
- }
-
--function fail()
-+fail()
- {
-- echo -e "\nError: $@\n"
-+ echo
-+ echo "Error: $@"
-+ echo
- false
- }
-
--function cmdExists()
-+cmdExists()
- {
- command -v "$1" >/dev/null 2>&1
- }
-
--function getInitCmd()
-+getInitCmd()
- {
- #exec 2> /dev/null
- readlink /proc/1/exe 2> /dev/null
-@@ -32,7 +36,7 @@
- }
-
- # ensure path exists
--function make_path()
-+make_path()
- {
- local path="$1"
- [ -d "$path" ] || mkdir -p "$path" || fail "Could not create $path"
-@@ -40,34 +44,37 @@
-
- # real and effective user id should be the same - or the wine-profile could become useless
- # TODO: gracefully solve the issue by using su to run wine
--function validateUser()
-+validateUser()
- {
- local userid=$(id -un)
-
- if [ "$userid" != "$USER" ] ; then
-- echo -e "\n\n *** TeamViewer can not be executed with sudo! ***\n Either use your normal user account without sudo\n or use a the real root account to log in to your desktop (not recommended!)."
--
-+ echo
-+ echo "*** TeamViewer can not be executed with sudo! ***"
-+ echo "Either use your normal user account without sudo"
-+ echo "or use a the real root account to log in to your desktop (not recommended!)."
-+
- return 1
- fi
- }
-
--function isSuperUser # root or sudo
-+isSuperUser() # root or sudo
- {
- local userid=$(id -u)
-- [ "$userid" == 0 ]
-+ [ "$userid" = 0 ]
- }
-
--function rootSuggest()
-+rootSuggest()
- {
-- isSuperUser || echo -e "\nTry with root / sudo ?"
-+ isSuperUser || { echo ; echo "Try with root / sudo ?" ;}
- false
- }
-
--function updateMenuEntries()
-+updateMenuEntries()
- {
- local action="$1" # install / uninstall
- xdg-desktop-menu $action --mode system "$TV_DESKTOP_FILE" # prefer installed xdg script (tvw_config)
-
- cmdExists update-menus && update-menus
- cmdExists update-icon-caches && update-icon-caches /usr/share/icons/hicolor
--}
-\ No newline at end of file
-+}
---- teamviewer8/tv_bin/script/tvw_config
-+++ teamviewer8/tv_bin/script/tvw_config
-@@ -1,4 +1,4 @@
--#!/bin/bash
-+#!/bin/sh
-
- TV_VERSION="8.0.17147"
- TV_PKGTYPE="DEB"
---- teamviewer8/tv_bin/script/tvw_main
-+++ teamviewer8/tv_bin/script/tvw_main
-@@ -1,11 +1,11 @@
--#!/bin/bash
-+#!/bin/sh
-
--source "$TV_SCRIPT_DIR/tvw_config"
--source "$TV_SCRIPT_DIR/tvw_aux"
--source "$TV_SCRIPT_DIR/tvw_daemon"
--source "$TV_SCRIPT_DIR/tvw_profile"
-+. "$TV_SCRIPT_DIR/tvw_config"
-+. "$TV_SCRIPT_DIR/tvw_aux"
-+. "$TV_SCRIPT_DIR/tvw_daemon"
-+. "$TV_SCRIPT_DIR/tvw_profile"
-
--function Init()
-+Init()
- {
- local startLog="$TV_LOG_DIR/startup.log"
-
-@@ -17,7 +17,7 @@
- InitProfile >> "$startLog" || die "InitProfile failed. Please check '$startLog'"
- }
-
--function LogStartupInfo()
-+LogStartupInfo()
- {
- exec 2>&1 # redirect stderr
-
-@@ -45,7 +45,7 @@
- }
-
-
--function Main()
-+Main()
- {
- local param="$1"
- local opt="$2"
-@@ -72,7 +72,7 @@
- echo
- }
-
--function Run_TeamViewer
-+Run_TeamViewer()
- {
- Init
- echo "Launching TeamViewer..."
-@@ -82,7 +82,7 @@
- exec wine "c:\TeamViewer\TeamViewer.exe" "$@"
- }
-
--function Run_TeamViewer_Desktop
-+Run_TeamViewer_Desktop()
- {
- [ "$1" = "--desktop" ] && shift
-
-@@ -94,7 +94,7 @@
- exec wine "c:\TeamViewer\TeamViewer_Desktop.exe" "$@"
- }
-
--function Run_KillTeamViewer
-+Run_KillTeamViewer()
- {
- local this="$0" # ps: allow user names with more than 8 characters...
- local userlist=$(ps -e -o "user:25,command" | grep -v "^root" | grep TeamViewer | cut --delimiter=' ' -f 1)
-@@ -111,19 +111,19 @@
- fi
- }
-
--function Run_WineCfg
-+Run_WineCfg()
- {
- Init
- wine winecfg "$@"
- }
-
--function Run_RegEdit
-+Run_RegEdit()
- {
- Init
- wine regedit "$@"
- }
-
--function Run_Daemon()
-+Run_Daemon()
- {
- local opt="$1"
-
-@@ -136,7 +136,7 @@
- esac
- }
-
--function SetPasswd()
-+SetPasswd()
- {
- local pwd="$1"
- [ -n "$pwd" ] || die 'no password specified'
-@@ -156,7 +156,7 @@
- echo
- }
-
--function ExportLicense()
-+ExportLicense()
- {
- local license="$1"
- local path='/tmp/tv_global.conf'
-@@ -176,7 +176,7 @@
- echo
- }
-
--function CreateZipLog()
-+CreateZipLog()
- {
- local cfg_dir="config"
- local log_dir="logfiles"
-@@ -202,7 +202,7 @@
- echo 'done'
- }
-
--function PrintHelp()
-+PrintHelp()
- {
- PrintVersion
- echo
-@@ -222,7 +222,7 @@
- ABecho "teamviewer --daemon enable" "enable TeamViewer daemon - start daemon on system startup (default)"
- }
-
--function PrintInfo()
-+PrintInfo()
- {
- PrintVersion
- echo
-@@ -231,12 +231,12 @@
- PrintTeamViewerID
- }
-
--function PrintVersion()
-+PrintVersion()
- {
- ABecho "TeamViewer" "$TV_VERSION"
- }
-
--function PrintDaemonStatus()
-+PrintDaemonStatus()
- {
- local cmd="$(daemonCtl 'status')"
- local txt="$(eval "$cmd")"
-@@ -245,7 +245,7 @@
- ABecho "teamviewerd status" "$txt"
- }
-
--function PrintTeamViewerID
-+PrintTeamViewerID()
- {
- local config="$TV_BASE_DIR/config/global.conf"
- local tvid
-@@ -258,4 +258,4 @@
- echo "TeamViewer ID: not found"
- echo "Try restarting the TeamViewer daemon (e.g. teamviewer --daemon restart)"
- fi
--}
-\ No newline at end of file
-+}
---- teamviewer8/tv_bin/script/tvw_profile
-+++ teamviewer8/tv_bin/script/tvw_profile
-@@ -1,6 +1,6 @@
--#!/bin/bash
-+#!/bin/sh
-
--function InitProfile()
-+InitProfile()
- {
- exec 2>&1 # redirect stderr
-
-@@ -12,7 +12,7 @@
- echo "ok"
- }
-
--function SetupWine()
-+SetupWine()
- {
- # setup dosdevices and symlinks
- local c_sym="$WINEPREFIX/dosdevices/c:"
-@@ -32,7 +32,7 @@
-
-
- # setup/validate drive symlinks
--function setup_drive_symlink()
-+setup_drive_symlink()
- {
- local sym="$1"
- local dst="$2"
-@@ -44,7 +44,7 @@
- }
-
- # setup logfile symlinks
--function setup_log_symlink
-+setup_log_symlink()
- {
- local cuser=$(id -un)
- local basepath="$WINEPREFIX/drive_c/users/$cuser"
-@@ -66,7 +66,7 @@
- }
-
- # TODO simplify by using a different Log dir
--function setup_prog_dir()
-+setup_prog_dir()
- {
- local progdir="$WINEPREFIX/drive_c/TeamViewer"
- local progsrc="$TV_WINE_DIR/drive_c/TeamViewer"
-@@ -83,7 +83,7 @@
- done
- }
-
--function setup_winemenubuilder()
-+setup_winemenubuilder()
- {
- local sysdir="$WINEPREFIX/drive_c/windows/system32"
- local syssrc="$TV_WINE_DIR/drive_c/windows/system32"
-@@ -93,7 +93,7 @@
- [ -e "$sysdir/winemenubuilder.exe" ] || die "Could not copy winemenubuilder"
- }
-
--function SetupWineTweaks()
-+SetupWineTweaks()
- {
- [ "$USE_LOCAL_WINE" = "yes" ] && return
- [ -d "$WINEPREFIX/.tweak" ] || mkdir "$WINEPREFIX/.tweak"
-@@ -105,7 +105,7 @@
- # winetweak setwinver # Set Win2k mode for TeamViewer
- }
-
--function winetweak()
-+winetweak()
- {
- local tweak="$1"
- local tweakmark="$WINEPREFIX/.tweak/$tweak"
-@@ -118,7 +118,7 @@
-
- }
-
--function SetupTarEnv()
-+SetupTarEnv()
- {
- echo " - "
- # TODO for tar - if [ "$TV_PKGTYPE" = "TAR" ] ; then
-@@ -139,7 +139,7 @@
- # fi
- }
-
--function SetupEnv()
-+SetupEnv()
- {
- echo " - "
- # TODO remove
-@@ -159,4 +159,4 @@
- uname -m > "$WINEPREFIX/drive_c/distarch"
- (cd /etc; ls -m *-release *-version *_version > "$WINEPREFIX/drive_c/distrelease" 2> /dev/null)
- true
--}
-\ No newline at end of file
-+}
diff --git a/net-misc/teamviewer/files/teamviewer-8.0.17147-gentoo.patch b/net-misc/teamviewer/files/teamviewer-8.0.17147-gentoo.patch
deleted file mode 100644
index b3fe411..0000000
--- a/net-misc/teamviewer/files/teamviewer-8.0.17147-gentoo.patch
+++ /dev/null
@@ -1,135 +0,0 @@
-From: Julian Ospald <hasufell@gentoo.org>
-Date: Tue Feb 19 23:01:44 UTC 2013
-Subject: remove all daemon/systemd related bits
-
---- teamviewer8/tv_bin/script/tvw_main
-+++ teamviewer8/tv_bin/script/tvw_main
-@@ -2,7 +2,6 @@
-
- . "$TV_SCRIPT_DIR/tvw_config"
- . "$TV_SCRIPT_DIR/tvw_aux"
--. "$TV_SCRIPT_DIR/tvw_daemon"
- . "$TV_SCRIPT_DIR/tvw_profile"
-
- Init()
-@@ -57,7 +56,6 @@
- --help ) PrintHelp ;;
- --version ) PrintVersion ;;
- --info ) PrintInfo ;;
-- --daemon ) Run_Daemon $opt ;;
- --winecfg ) Run_WineCfg "$@" ;;
- --regedit ) Run_RegEdit "$@" ;;
- --kill ) Run_KillTeamViewer ;;
-@@ -123,26 +121,14 @@
- wine regedit "$@"
- }
-
--Run_Daemon()
--{
-- local opt="$1"
--
-- case "$opt" in
-- ( disable ) removeDaemon || rootSuggest ;;
-- ( enable ) installDaemon || rootSuggest ;;
-- ( start | stop | restart ) cmdDaemon $opt || rootSuggest ;;
-- ( status ) cmdDaemon $opt ;;
-- ( * ) echo "unknown option '$opt'" ;;
-- esac
--}
--
- SetPasswd()
- {
-+ echo "Stop your teamviewer daemon first, then press enter."
-+ read
-+
- local pwd="$1"
- [ -n "$pwd" ] || die 'no password specified'
-
-- Run_Daemon 'stop' > /dev/null
--
- $TV_BIN_DIR/teamviewerd --passwd "$pwd"
- case $? in
- 0 ) echo 'ok' ;;
-@@ -151,29 +137,28 @@
- 13 ) echo 'password not accepted - illegal char detected' ;;
- * ) echo 'unknown response' ;;
- esac
--
-- Run_Daemon 'start' || die 'failed to restart the daemon'
-- echo
-+
-+ echo "You may start your teamviewer daemon again."
- }
-
- ExportLicense()
- {
-+ echo "Stop your teamviewer daemon first, then press enter."
-+ read
-+
- local license="$1"
- local path='/tmp/tv_global.conf'
-
- [ -n "$license" ] || die 'no license specified'
-
-- Run_Daemon 'stop' > /dev/null
--
- $TV_BIN_DIR/teamviewerd --export-license "$license" "$path"
- case $? in
- 0 ) echo "ok - license exported to '$path'" ;;
- 11 ) echo "destination '$path' not accessible" ;;
- * ) echo 'unknown response' ;;
- esac
--
-- Run_Daemon 'start' || die 'failed to restart the daemon'
-- echo
-+
-+ echo "You may start your teamviewer daemon again."
- }
-
- CreateZipLog()
-@@ -214,35 +199,18 @@
- ABecho "teamviewer --passwd [PASSWD]" "set a password (useful when installing remote (ssh)"
- ABecho "teamviewer --ziplog" "create a zip containing all teamviewer logs (useful when contacting support)"
- echo
-- ABecho "teamviewer --daemon status" "show current status of the TeamViewer daemon"
-- ABecho "teamviewer --daemon start" "start TeamViewer daemon"
-- ABecho "teamviewer --daemon stop" "stop TeamViewer daemon"
-- ABecho "teamviewer --daemon restart" "stop/start TeamViewer daemon"
-- ABecho "teamviewer --daemon disable" "disable TeamViewer daemon - don't start daemon on system startup"
-- ABecho "teamviewer --daemon enable" "enable TeamViewer daemon - start daemon on system startup (default)"
- }
-
- PrintInfo()
- {
- PrintVersion
- echo
-- PrintDaemonStatus
-- echo
- PrintTeamViewerID
- }
-
- PrintVersion()
- {
- ABecho "TeamViewer" "$TV_VERSION"
--}
--
--PrintDaemonStatus()
--{
-- local cmd="$(daemonCtl 'status')"
-- local txt="$(eval "$cmd")"
-- [ $? = 0 ] || txt='n/a (error)'
--
-- ABecho "teamviewerd status" "$txt"
- }
-
- PrintTeamViewerID
-@@ -256,6 +224,6 @@
- ABecho "TeamViewer ID:" "$tvid"
- else
- echo "TeamViewer ID: not found"
-- echo "Try restarting the TeamViewer daemon (e.g. teamviewer --daemon restart)"
-- fi
--}
-+ echo "Try restarting the TeamViewer daemon."
-+ fi
-+}
diff --git a/net-misc/teamviewer/files/teamviewer.service b/net-misc/teamviewer/files/teamviewer.service
deleted file mode 100644
index 2ec1f1e..0000000
--- a/net-misc/teamviewer/files/teamviewer.service
+++ /dev/null
@@ -1,9 +0,0 @@
-[Unit]
-Description=Daemon for TeamViewer-8
-
-[Service]
-ExecStart=/opt/teamviewer8/teamviewerd -f
-
-[Install]
-WantedBy=multi-user.target
-
diff --git a/net-misc/teamviewer/files/teamviewerd.init b/net-misc/teamviewer/files/teamviewerd.init
deleted file mode 100644
index e45c5c0..0000000
--- a/net-misc/teamviewer/files/teamviewerd.init
+++ /dev/null
@@ -1,26 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/teamviewer/files/teamviewerd.init,v 1.2 2013/04/18 13:08:45 hasufell Exp $
-
-description="daemon for TeamViewer"
-
-PIDFILE="/var/run/teamviewerd.pid"
-
-start() {
- ebegin "Starting Teamviewer Daemon"
-
- start-stop-daemon \
- --start \
- --pidfile "${PIDFILE}" \
- --background \
- --exec /opt/teamviewer@TVV@/teamviewerd -- -d
-}
-
-stop() {
- ebegin "Stopping Teamviewer Daemon"
-
- start-stop-daemon \
- --stop \
- --pidfile "${PIDFILE}"
-}
diff --git a/net-misc/teamviewer/metadata.xml b/net-misc/teamviewer/metadata.xml
deleted file mode 100644
index a824f0d..0000000
--- a/net-misc/teamviewer/metadata.xml
+++ /dev/null
@@ -1,16 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer>
- <email>flameeyes@gentoo.org</email>
- <name>Diego Elio Pettenò</name>
- </maintainer>
- <maintainer>
- <email>hasufell@gentoo.org</email>
- <name>Julian Ospald</name>
- </maintainer>
- <use>
- <flag name="system-wine">Use <pkg>app-emulation/wine</pkg> instead of bundled one.</flag>
- </use>
-</pkgmetadata>
-
diff --git a/net-misc/teamviewer/teamviewer-8.0.20931-r3.ebuild b/net-misc/teamviewer/teamviewer-8.0.20931-r3.ebuild
deleted file mode 100644
index 308a62e..0000000
--- a/net-misc/teamviewer/teamviewer-8.0.20931-r3.ebuild
+++ /dev/null
@@ -1,160 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=6
-
-inherit eutils gnome2-utils systemd unpacker
-
-# Major version
-MV=${PV/\.*}
-MY_PN=${PN}${MV}
-DESCRIPTION="All-In-One Solution for Remote Access and Support over the Internet"
-HOMEPAGE="http://www.teamviewer.com"
-SRC_URI="http://www.teamviewer.com/download/version_${MV}x/teamviewer_linux.deb -> ${P}.deb"
-
-LICENSE="TeamViewer !system-wine? ( LGPL-2.1 )"
-SLOT=${MV}
-KEYWORDS="~amd64 ~x86"
-IUSE="-system-wine"
-
-RESTRICT="mirror"
-
-RDEPEND="
- app-shells/bash
- x11-misc/xdg-utils
- !system-wine? (
- || (
- (
- media-libs/alsa-lib[abi_x86_32(-)]
- media-libs/freetype[abi_x86_32(-)]
- sys-libs/zlib[abi_x86_32(-)]
- x11-libs/libX11[abi_x86_32(-)]
- x11-libs/libXau[abi_x86_32(-)]
- x11-libs/libXdamage[abi_x86_32(-)]
- x11-libs/libXext[abi_x86_32(-)]
- x11-libs/libXfixes[abi_x86_32(-)]
- x11-libs/libXrandr[abi_x86_32(-)]
- x11-libs/libXrender[abi_x86_32(-)]
- x11-libs/libSM[abi_x86_32(-)]
- x11-libs/libXtst[abi_x86_32(-)]
- )
- (
- app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
- app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)]
- app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)]
- )
-
- )
- )
- system-wine? ( virtual/wine )"
-
-QA_PREBUILT="opt/teamviewer${MV}/*"
-
-S=${WORKDIR}/opt/teamviewer${MV}/tv_bin
-
-make_winewrapper() {
- cat << EOF > "${T}/${MY_PN}"
-#!/bin/sh
-export WINEDLLPATH=/opt/${MY_PN}
-exec wine "/opt/${MY_PN}/TeamViewer.exe" "\$@"
-EOF
- chmod go+rx "${T}/${MY_PN}"
- exeinto /opt/bin
- doexe "${T}/${MY_PN}"
-}
-
-src_prepare() {
- #FIXME
- #epatch "${FILESDIR}"/${PN}-8.0.17147-POSIX.patch \
- # "${FILESDIR}"/${PN}-8.0.17147-gentoo.patch
-
- sed \
- -e "s/@TVV@/${MV}/g" \
- "${FILESDIR}"/${PN}d.init > "${T}"/${PN}d${MV} || die
-
- eapply_user
-}
-
-src_install () {
- if use system-wine ; then
- make_winewrapper
- exeinto /opt/${MY_PN}
- doexe wine/drive_c/TeamViewer/*
- else
- # install scripts and .reg
- insinto /opt/${MY_PN}/script
- doins script/*.reg
- exeinto /opt/${MY_PN}/script
- doexe script/teamviewer{,_desktop} script/tvw_{aux,config,main,profile,daemon}
-
- # install internal wine
- insinto /opt/${MY_PN}
- doins -r wine
- dosym /opt/${MY_PN}/script/${PN} /opt/bin/${MY_PN}
-
- # fix permissions
- fperms 755 /opt/${MY_PN}/wine/bin/wine{,-preloader,server}
- fperms 755 /opt/${MY_PN}/wine/drive_c/TeamViewer/TeamViewer{,_Desktop}.exe
- find "${D}"/opt/${MY_PN} -type f -name "*.so*" -execdir chmod 755 '{}' \;
- fi
-
- # necessary symlinks
- dosym ./script/teamviewer /opt/${MY_PN}/TeamViewer
- dosym ./script/teamviewer_desktop /opt/${MY_PN}/TeamViewer_Desktop
-
- # install daemon binary
- exeinto /opt/${MY_PN}
- doexe ${PN}d
-
- # set up logdir
- keepdir /var/log/${MY_PN}
- dosym /var/log/${MY_PN} /opt/${MY_PN}/logfiles
-
- # set up config dir
- keepdir /etc/${MY_PN}
- dosym /etc/${MY_PN} /opt/${MY_PN}/config
-
- doinitd "${T}"/${PN}d${MV}
- systemd_dounit "${FILESDIR}"/${PN}.service
-
- newicon -s 48 desktop/${PN}.png ${MY_PN}.png
-
- #NODOCS...
- #dodoc ../linux_FAQ_{EN,DE}.txt
- make_desktop_entry ${MY_PN} TeamViewer ${MY_PN}
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-
- if use system-wine ; then
- echo
- eerror "IMPORTANT NOTICE!"
- elog "Using ${PN} with system wine is not supported and experimental."
- elog "Do not report gentoo bugs while using this version."
- echo
- fi
-
- eerror "STARTUP NOTICE:"
- elog "You cannot start the daemon via \"teamviewer --daemon start\"."
- elog "Instead use the provided gentoo initscript:"
- elog " /etc/init.d/${PN}d${MV} start"
- elog
- elog "Logs are written to \"/var/log/teamviewer8\""
-
- echo
-
- eerror "UPDATE NOTICE!"
- ewarn "If you update from teamviewer-8.0.17147"
- ewarn "then you might have to remove \"~/.config/teamviewer8\", because"
- ewarn "the install destination changed and the config might be invalid."
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}