summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorvmacs <vma_github@vmacs.us>2014-04-27 12:39:25 -0600
committervmacs <vma_github@vmacs.us>2014-04-27 12:39:25 -0600
commitcf9d70c35a148c8f8d677a91cffd2821f7e78b22 (patch)
tree5899319410727ca77b2b66db5caa1f930705b93e
downloadvmacs-cf9d70c35a148c8f8d677a91cffd2821f7e78b22.tar.gz
vmacs-cf9d70c35a148c8f8d677a91cffd2821f7e78b22.tar.bz2
vmacs-cf9d70c35a148c8f8d677a91cffd2821f7e78b22.zip
phpMyAdmin-4.1.14
-rw-r--r--dev-db/phpmyadmin/Manifest3
-rw-r--r--dev-db/phpmyadmin/files/postinstall-en-3.1.txt36
-rw-r--r--dev-db/phpmyadmin/phpmyadmin-4.1.14.ebuild61
-rw-r--r--metadata/layout.conf1
4 files changed, 101 insertions, 0 deletions
diff --git a/dev-db/phpmyadmin/Manifest b/dev-db/phpmyadmin/Manifest
new file mode 100644
index 0000000..8061ffc
--- /dev/null
+++ b/dev-db/phpmyadmin/Manifest
@@ -0,0 +1,3 @@
+AUX postinstall-en-3.1.txt 1160 SHA256 0fa47a49b9c5604339335d36ce9d1506a1cd07644d219fb7f35e2e4432fa8dbf SHA512 7b50ab9f9e3a828bd9bff600550ea97712c28804467ab5900a52710d4adb0581fe33155a965dd3956fcd36cc153b1a18a1f001d88ac52d70c8288faf695f01ec WHIRLPOOL 5b548fd9d41ca794f74936ce8ceda15c2c410cbc8d383c3376009a8936e47bc4d350c520ece1ff1eb20b0ac899f84fa513a185db5c255db362b7f3ee0b8f69ef
+DIST phpMyAdmin-4.1.14-all-languages.tar.xz 4810240 SHA256 a124fd8cccc059cfe43e2b7b3a1858bb549fc00ef2c6d329418ee596aa9e8d8f SHA512 b27829f10e68f66cdfc3b97f0d3b45f513e35ce36a1b16b99f0672f4b3ab3d5e8dda0426c62f63131a2c7b6011e1939c69799e1bfeea6aa7b9e0c9f8161fbec2 WHIRLPOOL fd9488b34acfda851a11c2a4c465f77c36fbe2804935fdd200b41d8bdb2a6a53c5cbbcf3edf0c3201e0114d458e9c23f6048d4a36fe3bcfe7fd1cce711300596
+EBUILD phpmyadmin-4.1.14.ebuild 1658 SHA256 e85b00a5057ff31a0dd1ecc306421d5151311c4046cb2338d10e7d5770c8d04c SHA512 2926bd51342a4a7a99d6548f048250b0832aa416a4f9e155d79d77643867e0adbccbd91a5eed9ab9df4588f5f2ba84508f577af9a5c13a6a5d29767c52ae12c8 WHIRLPOOL 0ec03a4fa9d9004b3c2371145731c83b7d1b3e5329472e79759c1eb510cd1274e2c662e2ebfe7f5aea76ba3323548ffbd56b2d1d5259f20ebecd7199df31b4bd
diff --git a/dev-db/phpmyadmin/files/postinstall-en-3.1.txt b/dev-db/phpmyadmin/files/postinstall-en-3.1.txt
new file mode 100644
index 0000000..4e72581
--- /dev/null
+++ b/dev-db/phpmyadmin/files/postinstall-en-3.1.txt
@@ -0,0 +1,36 @@
+If this is a new installation:
+
+1. Configure ${PN}:
+
+a) Create config.inc.php. You can use the web-based installer
+ (this requires the 'setup' USE flag to be enabled):
+
+ mkdir ${MY_INSTALLDIR}/config
+ chown ${VHOST_SERVER_UID}:${VHOST_SERVER_UID} ${MY_INSTALLDIR}/config
+
+ then go to http://${VHOST_HOSTNAME}/${VHOST_APPDIR}/setup/
+
+ once you've saved the configuration:
+
+ cp ${MY_INSTALLDIR}/config/config.inc.php ${MY_INSTALLDIR}/config.inc.php
+ rm -rf ${MY_INSTALLDIR}/config
+
+b) Alternatively, use an existing configuration:
+
+ cp <path to existing config.inc.php file> ${MY_INSTALLDIR}/
+
+c) Alternatively, use the sample config file:
+
+ cp ${MY_INSTALLDIR}/config.sample.inc.php ${MY_INSTALLDIR}/config.inc.php
+
+2. Be sure that the libraries/ directory is not visible. You can use the
+ provided .htaccess file.
+
+=================================================================
+
+If you are upgrading from an earlier version:
+
+1. If you are using ${PN}'s features for master/foreign tables, be sure to read
+ http://${VHOST_HOSTNAME}/${VHOST_APPDIR}/Documentation.html#col_com
+
+ You will need to perform the ALTER TABLE step yourself.
diff --git a/dev-db/phpmyadmin/phpmyadmin-4.1.14.ebuild b/dev-db/phpmyadmin/phpmyadmin-4.1.14.ebuild
new file mode 100644
index 0000000..d5f42e0
--- /dev/null
+++ b/dev-db/phpmyadmin/phpmyadmin-4.1.14.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/phpmyadmin-4.1.8.ebuild,v 1.1 2014/02/23 18:01:18 jmbsvicetto Exp $
+
+EAPI="4"
+
+inherit eutils webapp depend.php
+
+MY_PV=${PV/_/-}
+MY_P="phpMyAdmin-${MY_PV}-all-languages"
+
+DESCRIPTION="Web-based administration for MySQL database in PHP"
+HOMEPAGE="http://www.phpmyadmin.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="setup"
+
+RDEPEND="
+ dev-lang/php[crypt,ctype,filter,json,session,unicode]
+ || (
+ dev-lang/php[mysqli]
+ dev-lang/php[mysql]
+ )
+"
+
+need_httpd_cgi
+need_php_httpd
+
+S="${WORKDIR}"/${MY_P}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc README RELEASE-DATE-${MY_PV} ChangeLog || die
+ rm -f LICENSE README* RELEASE-DATE-${MY_PV}
+
+ if ! use setup; then
+ rm -rf setup || die "Cannot remove setup utility"
+ elog "The phpMyAdmin setup utility has been removed."
+ elog "It is a regular target of various exploits. If you need it, set USE=setup."
+ else
+ elog "You should consider disabling the setup USE flag"
+ elog "to exclude the setup utility if you don't use it."
+ elog "It regularly is the target of various exploits."
+ fi
+
+ insinto "${MY_HTDOCSDIR#${EPREFIX}}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR#${EPREFIX}}"/libraries/config.default.php
+ webapp_serverowned "${MY_HTDOCSDIR#${EPREFIX}}"/libraries/config.default.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-3.1.txt
+ webapp_src_install
+}
diff --git a/metadata/layout.conf b/metadata/layout.conf
new file mode 100644
index 0000000..d43e61c
--- /dev/null
+++ b/metadata/layout.conf
@@ -0,0 +1 @@
+masters = gentoo