summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnome-extra/gnome-globalmenu/ChangeLog7
-rw-r--r--gnome-extra/gnome-globalmenu/Manifest4
-rw-r--r--gnome-extra/gnome-globalmenu/gnome-globalmenu-0.7.9.ebuild56
-rw-r--r--gnome-extra/gnome-globalmenu/metadata.xml12
-rw-r--r--gnome-extra/googsystray/ChangeLog7
-rw-r--r--gnome-extra/googsystray/Manifest4
-rw-r--r--gnome-extra/googsystray/googsystray-1.1.4.ebuild23
-rw-r--r--gnome-extra/googsystray/metadata.xml12
8 files changed, 125 insertions, 0 deletions
diff --git a/gnome-extra/gnome-globalmenu/ChangeLog b/gnome-extra/gnome-globalmenu/ChangeLog
new file mode 100644
index 0000000..87c9a36
--- /dev/null
+++ b/gnome-extra/gnome-globalmenu/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for gnome-extra/gnome-globalmenu
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+
+*gnome-globalmenu-0.7.9 (11 Apr 2010)
+ 11 Apr 2010; Iskren Slavov <iskren.s@gmail.com>
+ gnome-globalmenu-0.7.9.ebuild:
+ Initial version.
diff --git a/gnome-extra/gnome-globalmenu/Manifest b/gnome-extra/gnome-globalmenu/Manifest
new file mode 100644
index 0000000..6f5fdfb
--- /dev/null
+++ b/gnome-extra/gnome-globalmenu/Manifest
@@ -0,0 +1,4 @@
+DIST gnome-globalmenu-0.7.9.tar.bz2 598736 RMD160 a1b05817aa164bb94d2f9835b9d90b39086d1a0a SHA1 7a51f2927f0d59c29e131464586734ad29f87903 SHA256 a5ac112169c175ab2ee6f4ba02655f9af3b7f1a9294056506ad92abb05b1159c
+EBUILD gnome-globalmenu-0.7.9.ebuild 1280 RMD160 2c10ca850a9bdb43eb84872397e28b19cb965658 SHA1 4db22165c32fb8368fc4a74f6e12b779417e0965 SHA256 14282facf7e5f0f8ff4a93de52da7d1c7aaf1f535d3cae2ce5817b5685656067
+MISC ChangeLog 256 RMD160 bc1cc17704fa766755da4d9e09f54724c53fe636 SHA1 5dcd1763cd2aebda9b55dfed211e63bc457ea890 SHA256 dade9c41f5639425f3135f2cee75b8574b06fae8ff14a952289e0947043e61dc
+MISC metadata.xml 402 RMD160 2d170af09f1b218c18c47d97282a482c4ca33661 SHA1 d45f1ac42454916e0275d4047deb06318429bd75 SHA256 95245b82d1b9d1f1839435fcfac9f1351de23e09869ce03373ee21ab9f695be7
diff --git a/gnome-extra/gnome-globalmenu/gnome-globalmenu-0.7.9.ebuild b/gnome-extra/gnome-globalmenu/gnome-globalmenu-0.7.9.ebuild
new file mode 100644
index 0000000..97be517
--- /dev/null
+++ b/gnome-extra/gnome-globalmenu/gnome-globalmenu-0.7.9.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="2"
+
+DESCRIPTION="Global Menu is a (Mac OS X like) globally-shared menu bar for GNOME"
+HOMEPAGE="http://code.google.com/p/gnome2-globalmenu/"
+SRC_URI="http://gnome2-globalmenu.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPLv2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="gnome xfce test"
+
+DEPEND=">=x11-libs/gtk+-2.10.0
+ >=dev-libs/glib-2.10.0
+ >=gnome-base/gconf-2
+ >=x11-libs/libwnck-2.16.0
+ >=gnome-base/gnome-menus-2.16.0
+ gnome? (
+ >=gnome-base/gnome-panel-2.16.0
+ >=x11-libs/libnotify-0.4.4 )
+ xfce? (
+ >=xfce-base/xfce4-panel-4.4.3 )
+ >=x11-libs/libX11-1.1.0"
+RDEPEND="${DEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ >=dev-lang/vala-0.7.3"
+
+src_configure() {
+ G2CONF="${G2CONF}
+ --without-git
+ --docdir=/usr/share/doc/${PF}"
+ --without-xfce4-panel
+
+
+ econf \
+ $(use_enable test tests) \
+ $(use_with gnome gnome-panel) \
+ $(use_with xfce xfce4-panel) || die "econf failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog 'If make install failed try FEATURES="-sandbox" emerge gnome-globalmenu'
+}
+
diff --git a/gnome-extra/gnome-globalmenu/metadata.xml b/gnome-extra/gnome-globalmenu/metadata.xml
new file mode 100644
index 0000000..3e5f58c
--- /dev/null
+++ b/gnome-extra/gnome-globalmenu/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome-extra</herd>
+<maintainer>
+ <email>iskren.s@gmail.com</email>
+</maintainer>
+<longdescription>Gnome Global Menu is a Mac OS X like global
+application menu that stays on top of screen. It is quite small
+application written in Vala.
+</longdescription>
+</pkgmetadata>
diff --git a/gnome-extra/googsystray/ChangeLog b/gnome-extra/googsystray/ChangeLog
new file mode 100644
index 0000000..3c05fed
--- /dev/null
+++ b/gnome-extra/googsystray/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for gnome-extra/googsystray
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+
+*googsystray-1.1.4 (11 Apr 2010)
+ 11 Apr 2010; Iskren Slavov <iskren.s@gmail.com>
+ googsystray-1.1.4.ebuild:
+ Initial version.
diff --git a/gnome-extra/googsystray/Manifest b/gnome-extra/googsystray/Manifest
new file mode 100644
index 0000000..97e7338
--- /dev/null
+++ b/gnome-extra/googsystray/Manifest
@@ -0,0 +1,4 @@
+DIST googsystray-1.1.4.tar.gz 777944 RMD160 ac7ecaa412d04a570e12b983d86770aced665ce7 SHA1 5ad7806e599619885d751b02c8b299345e2fd222 SHA256 a455bd68695bad946e810e183e9e1d5e40a66111a2e288183f372e84f7b1873c
+EBUILD googsystray-1.1.4.ebuild 503 RMD160 e69c5df6c56c43a85dca9e7b0753c65f81790a5b SHA1 0cfa48e9f8f0390cda93fe6a8e013675a2873148 SHA256 b5d6d61a7fcf06d7aabb471fd8232b79aba50a8e5a5d43cfb982b28ea3ebedd6
+MISC ChangeLog 251 RMD160 74dadcd1ef90cc0fc155186b98eecb69ac184169 SHA1 5670896424ce42940277d218aa76923f6381ccdd SHA256 2502082747da9e91d2df985af4410f52b8591fabaddfeeb290322109fb5a7a1a
+MISC metadata.xml 426 RMD160 d2c2d98a9be0bc7d6b3b26c95057fa2eccdf1f44 SHA1 ef0bd670d4b59ab34eadd5c8c464c142c87f7728 SHA256 a3155e629b3d733fec67cb1f6f619426e5a6a48b197103a172adf52b4a891014
diff --git a/gnome-extra/googsystray/googsystray-1.1.4.ebuild b/gnome-extra/googsystray/googsystray-1.1.4.ebuild
new file mode 100644
index 0000000..c7b4e82
--- /dev/null
+++ b/gnome-extra/googsystray/googsystray-1.1.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="GNOME Google/Gmail System tray application."
+HOMEPAGE="http://googsystray.sourceforge.net/"
+SRC_URI="mirror://sourceforge/googsystray/${P}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.6.4-r1
+ >=dev-python/pygtk-2.14.1-r1"
+
+src_install() {
+ distutils_src_install
+}
diff --git a/gnome-extra/googsystray/metadata.xml b/gnome-extra/googsystray/metadata.xml
new file mode 100644
index 0000000..b4fa668
--- /dev/null
+++ b/gnome-extra/googsystray/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome-extra</herd>
+<maintainer>
+ <email>iskren.s@gmail.com</email>
+</maintainer>
+<longdescription>GNOME Google/Gmail System tray application.
+Checks your mail and notifies you. It can also be used with
+Google's Calendar, Wave, Reader, Voice. Written i python.
+</longdescription>
+</pkgmetadata>