summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Huber <huber@crans.org>2011-03-09 13:21:15 +0100
committerOlivier Huber <huber@crans.org>2011-03-09 13:21:15 +0100
commit578437fcd3af09dd6606d544ab9cbc42fbe2b95c (patch)
tree6bbcd607314058177911710ef3789878d7d159f9
parent[Joomla] fix path (diff)
downloadxhub-578437fcd3af09dd6606d544ab9cbc42fbe2b95c.tar.gz
xhub-578437fcd3af09dd6606d544ab9cbc42fbe2b95c.tar.bz2
xhub-578437fcd3af09dd6606d544ab9cbc42fbe2b95c.zip
[Joomla] we need json support in php and configuration.php is still needed
-rw-r--r--www-apps/joomla/Manifest2
-rw-r--r--www-apps/joomla/joomla-1.6.1.ebuild20
2 files changed, 12 insertions, 10 deletions
diff --git a/www-apps/joomla/Manifest b/www-apps/joomla/Manifest
index b10ffce..b342756 100644
--- a/www-apps/joomla/Manifest
+++ b/www-apps/joomla/Manifest
@@ -1,5 +1,5 @@
AUX postinstall-en.txt 754 RMD160 ebc0e7808af410d94fb6fa1b7296ecee1ffa15ec SHA1 bc1c99b4edaaee5d97826543f47c6efcf134df2d SHA256 36261f2301653a1c715a9edf43d0ad89fd0721e3a6c4e55ad4d4b7f1b5adf28c
DIST Joomla_1.6.1-Stable-Full_Package.zip 7920151 RMD160 06b4883a24792c300596443a3e4940f2ad1afd72 SHA1 deb9f7b2e194fe75086a4610f52d7788f653491e SHA256 a8b823c948bbc6035d0d4c3a515a5045eea5da54f912e97178753c6c2e220722
-EBUILD joomla-1.6.1.ebuild 1484 RMD160 5a130dcc62a32da530540f53faded804d1b7ac3a SHA1 f60a2d848202729f679c6de4a0944e1f5691e89a SHA256 5ac7d70c14a3016f3848d32dc21954539f769088f7bfa81cd957c7d258aa90f5
+EBUILD joomla-1.6.1.ebuild 1526 RMD160 302b60873ef538592c99fb8fa0cac808dc9b4e3a SHA1 0ea3ade0a3ca4d5c707588f9bc222c1cb23d2512 SHA256 36ae35b1a0ae9a8ee8605280a54fa5b056dae1b43b8a195742a854c48674a4c8
MISC ChangeLog 7188 RMD160 16f3e228ae4adc09c6661d4a8588dc65dff81813 SHA1 ddd3926d38f0617226accf0b49620ac7e8774c3c SHA256 09e8f534122c928ec60422fd8986674c82c7bc56ef5e697a15670c441d911107
MISC metadata.xml 370 RMD160 813b0609248db59832046ee34292a97a852d7fad SHA1 e5d144968f32af8cfd40e634b2b2c46cc15d9201 SHA256 59f1025ef78a8d3ff7d8fff822b627650ae9c3bab801d3e12703e4240ff064cd
diff --git a/www-apps/joomla/joomla-1.6.1.ebuild b/www-apps/joomla/joomla-1.6.1.ebuild
index 482811f..80eb82f 100644
--- a/www-apps/joomla/joomla-1.6.1.ebuild
+++ b/www-apps/joomla/joomla-1.6.1.ebuild
@@ -21,29 +21,31 @@ S="${WORKDIR}"
DEPEND="${DEPEND}
app-arch/unzip"
-RDEPEND="dev-lang/php[mysql,zlib,xml]"
+RDEPEND="dev-lang/php[json,mysql,zlib,xml]"
src_install () {
webapp_src_preinst
dodoc installation/CHANGELOG installation/INSTALL README.txt
-# touch configuration.php
+ touch configuration.php
insinto "${MY_HTDOCSDIR}"
doins -r .
- local files=" administrator/cache administrator/components administrator/language
- administrator/language/en-GB administrator/manifests administrator/modules
- administrator/templates cache components images images/banners language language/en-GB
- media modules plugins plugins/authentication plugins/content plugins/editors
- plugins/editors-xtd plugins/search plugins/system plugins/user plugins tmp templates"
+ local files=" administrator/cache administrator/components
+ administrator/language administrator/language/en-GB administrator/manifests
+ administrator/modules administrator/templates cache components images
+ images/banners installation/models/configuration.php language
+ language/en-GB media modules plugins plugins/authentication plugins/content
+ plugins/editors plugins/editors-xtd plugins/search plugins/system
+ plugins/user plugins tmp templates"
for file in ${files}; do
webapp_serverowned "${MY_HTDOCSDIR}"/${file}
done
-# webapp_configfile "${MY_HTDOCSDIR}"/configuration.php
-# webapp_serverowned "${MY_HTDOCSDIR}"/configuration.php
+ webapp_configfile "${MY_HTDOCSDIR}"/configuration.php
+ webapp_serverowned "${MY_HTDOCSDIR}"/configuration.php
webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
webapp_src_install