summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Huber <huber@crans.org>2010-12-29 12:58:35 +0100
committerOlivier Huber <huber@crans.org>2010-12-29 12:58:35 +0100
commitf88d0453ebf85da0378290b9592d8d82336cb7b8 (patch)
treeef059ac3d4283eb5b46240fcc978727c1a960dd2
parent[ocaml-text] initial import (diff)
downloadxhub-f88d0453ebf85da0378290b9592d8d82336cb7b8.tar.gz
xhub-f88d0453ebf85da0378290b9592d8d82336cb7b8.tar.bz2
xhub-f88d0453ebf85da0378290b9592d8d82336cb7b8.zip
[dev-ml/xmlm] initial import
-rw-r--r--dev-ml/xmlm/Manifest2
-rw-r--r--dev-ml/xmlm/xmlm-1.0.2.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-ml/xmlm/Manifest b/dev-ml/xmlm/Manifest
new file mode 100644
index 0000000..828a4ac
--- /dev/null
+++ b/dev-ml/xmlm/Manifest
@@ -0,0 +1,2 @@
+DIST xmlm-1.0.2.tbz 36177 RMD160 e1feec0805e43e2e15ac7386b0e5d2375d44fe81 SHA1 051ec8bbffbf2d720e5bc5a845cbf300f3f5f61f SHA256 d9963126b906b19003f272b63d6ea8ec5b270ed52342538c9eb4185b7235acb8
+EBUILD xmlm-1.0.2.ebuild 753 RMD160 bbca20926a90133ff67b2e95ddfa9064452c66ab SHA1 33a4a6308a28f72662425ce114809052fc25f579 SHA256 78f7bad73f2dec42f4f0d96a141db114c42005f1f775acffc11729bf713f7f20
diff --git a/dev-ml/xmlm/xmlm-1.0.2.ebuild b/dev-ml/xmlm/xmlm-1.0.2.ebuild
new file mode 100644
index 0000000..662aa79
--- /dev/null
+++ b/dev-ml/xmlm/xmlm-1.0.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+inherit findlib
+
+DESCRIPTION="Xmlm is an OCaml module providing streaming XML input/output"
+HOMEPAGE="http://erratique.ch/software/xmlm"
+SRC_URI="http://erratique.ch/software/xmlm/releases/${P}.tbz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc ocamlopt"
+
+DEPEND="${DEPEND}
+>=dev-lang/ocaml-3.10[ocamlopt?]"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ ./build module-byte
+
+ if use ocamlopt; then
+ ./build module-native
+ fi
+
+ if use doc; then
+ ./build doc
+ fi
+}
+
+src_install() {
+ export INSTALLDIR=${D}/`ocamlc -where`/xmlm
+
+ ./build install-byte
+ if use ocamlopt; then
+ ./build install
+ else
+ ./build install-byte
+ fi
+}