summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2012-03-26 11:34:37 +0530
committerNirbheek Chauhan <nirbheek@gentoo.org>2012-03-26 13:49:38 +0530
commit7253114dddf4d7ed0af9a4d97aa41821026103c4 (patch)
tree6228489f626cccce89bd09c344b57f9335812a3c
parentAdd net-wireless/gnome-bluetooth-3.3.92 (diff)
downloadgnome-7253114dddf4d7ed0af9a4d97aa41821026103c4.tar.gz
gnome-7253114dddf4d7ed0af9a4d97aa41821026103c4.tar.bz2
gnome-7253114dddf4d7ed0af9a4d97aa41821026103c4.zip
Add gnome-extra/gnome-contacts-3.3.92
-rw-r--r--gnome-extra/gnome-contacts/Manifest4
-rw-r--r--gnome-extra/gnome-contacts/gnome-contacts-3.3.92.ebuild51
-rw-r--r--gnome-extra/gnome-contacts/gnome-contacts-9999.ebuild31
3 files changed, 67 insertions, 19 deletions
diff --git a/gnome-extra/gnome-contacts/Manifest b/gnome-extra/gnome-contacts/Manifest
index 5534af03..552258f9 100644
--- a/gnome-extra/gnome-contacts/Manifest
+++ b/gnome-extra/gnome-contacts/Manifest
@@ -1 +1,3 @@
-EBUILD gnome-contacts-9999.ebuild 1243 RMD160 416faaff6cf319db19005b62d3d582c5a2ddbb9c SHA1 bcba1a26848c8ac0f47732880f547ce5613e0e23 SHA256 9f718a63e45d18e296e3246dfe06ae0b3991f67bfc213dbccbfee9fb6dbe68e8
+DIST gnome-contacts-3.3.92.tar.xz 589608 RMD160 6c00b95d98c977ce618c4e962138e57994a55313 SHA1 f063205c30f7f828f38a42459f22a9f19cacc25a SHA256 5cd65ecc9da097453987a8aeff63e0619f53a1c7e436ab9a67e4ef590fbfbe90
+EBUILD gnome-contacts-3.3.92.ebuild 1306 RMD160 a6228a4c6e3e9c5b00140b4a23955b821a2846e7 SHA1 627cc5dfbd4ae07ac01d4516ca5d28dc53bf2897 SHA256 e3ff5dd4f550637e057df4cc4fe2508bc37802cf4f84c47b4043e2c5abe8f477
+EBUILD gnome-contacts-9999.ebuild 1306 RMD160 a6228a4c6e3e9c5b00140b4a23955b821a2846e7 SHA1 627cc5dfbd4ae07ac01d4516ca5d28dc53bf2897 SHA256 e3ff5dd4f550637e057df4cc4fe2508bc37802cf4f84c47b4043e2c5abe8f477
diff --git a/gnome-extra/gnome-contacts/gnome-contacts-3.3.92.ebuild b/gnome-extra/gnome-contacts/gnome-contacts-3.3.92.ebuild
new file mode 100644
index 00000000..cb652d77
--- /dev/null
+++ b/gnome-extra/gnome-contacts/gnome-contacts-3.3.92.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-contacts/gnome-contacts-3.2.2.ebuild,v 1.2 2011/11/06 21:33:10 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+
+inherit gnome2
+if [[ ${PV} = 9999 ]]; then
+ inherit gnome2-live
+fi
+
+DESCRIPTION="GNOME contact management application"
+HOMEPAGE="https://live.gnome.org/Design/Apps/Contacts"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+if [[ ${PV} = 9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~x86"
+fi
+
+RDEPEND=">=dev-libs/folks-0.6.1.1
+ >=dev-libs/glib-2.31.10:2
+ >=x11-libs/gtk+-3.0:3
+ >=gnome-extra/evolution-data-server-3.2[gnome-online-accounts]
+ >=gnome-base/gnome-desktop-3.0:3
+ >=net-libs/telepathy-glib-0.17.5
+
+ dev-libs/libgee:0
+ net-libs/gnome-online-accounts
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/libnotify
+ x11-libs/pango"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.40
+ >=sys-devel/gettext-0.17"
+# Regenerating C from vala sources requires:
+# >=dev-lang/vala-0.14.0:0.14
+# net-libs/telepathy-glib[vala]
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS" # README is empty
+ # We do not need valac when building from pre-generated C sources,
+ # but configure checks for it anyway
+ G2CONF="${G2CONF} VALAC=$(type -P true)"
+}
diff --git a/gnome-extra/gnome-contacts/gnome-contacts-9999.ebuild b/gnome-extra/gnome-contacts/gnome-contacts-9999.ebuild
index 0c28a95c..cb652d77 100644
--- a/gnome-extra/gnome-contacts/gnome-contacts-9999.ebuild
+++ b/gnome-extra/gnome-contacts/gnome-contacts-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-contacts/gnome-contacts-3.2.2.ebuild,v 1.2 2011/11/06 21:33:10 tetromino Exp $
EAPI="4"
GCONF_DEBUG="no"
@@ -23,34 +23,29 @@ else
fi
RDEPEND=">=dev-libs/folks-0.6.1.1
- >=dev-libs/glib-2.29.12:2
- dev-libs/libgee:0
- >=gnome-extra/evolution-data-server-3[gnome-online-accounts]
+ >=dev-libs/glib-2.31.10:2
+ >=x11-libs/gtk+-3.0:3
+ >=gnome-extra/evolution-data-server-3.2[gnome-online-accounts]
>=gnome-base/gnome-desktop-3.0:3
+ >=net-libs/telepathy-glib-0.17.5
+
+ dev-libs/libgee:0
net-libs/gnome-online-accounts
- net-libs/telepathy-glib
x11-libs/cairo
x11-libs/gdk-pixbuf:2
- >=x11-libs/gtk+-3.0:3
x11-libs/libnotify
x11-libs/pango"
DEPEND="${RDEPEND}
dev-util/pkgconfig
>=dev-util/intltool-0.40
>=sys-devel/gettext-0.17"
-
-if [[ ${PV} = 9999 ]]; then
- DEPEND="${DEPEND}
- >=dev-lang/vala-0.14.0:0.14
- net-libs/telepathy-glib[vala]"
-fi
+# Regenerating C from vala sources requires:
+# >=dev-lang/vala-0.14.0:0.14
+# net-libs/telepathy-glib[vala]
pkg_setup() {
DOCS="AUTHORS ChangeLog NEWS" # README is empty
- # configure checks for valac, but will not use it when building from tarball
- if [[ ${PV} = 9999 ]]; then
- G2CONF="${G2CONF} VALAC=$(type -P valac-0.14)"
- else
- G2CONF="${G2CONF} VALAC=$(type -P true)"
- fi
+ # We do not need valac when building from pre-generated C sources,
+ # but configure checks for it anyway
+ G2CONF="${G2CONF} VALAC=$(type -P true)"
}