summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2012-03-25 18:45:02 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2012-03-25 18:45:02 +0200
commitedb3a440a831c6076c0d5dfb0e73ac3e0006a43c (patch)
treeed41bad5096dd8c390917c173cf4d4f8581f0de8
parentx11-wm/metacity: 2.34.1 → 2.34.3 (diff)
downloadgnome-edb3a440a831c6076c0d5dfb0e73ac3e0006a43c.tar.gz
gnome-edb3a440a831c6076c0d5dfb0e73ac3e0006a43c.tar.bz2
gnome-edb3a440a831c6076c0d5dfb0e73ac3e0006a43c.zip
dev-libs/totem-pl-parser: 2.32.6-r1 → 3.2.0
-rw-r--r--dev-libs/totem-pl-parser/Manifest12
-rw-r--r--dev-libs/totem-pl-parser/totem-pl-parser-3.2.0.ebuild70
2 files changed, 82 insertions, 0 deletions
diff --git a/dev-libs/totem-pl-parser/Manifest b/dev-libs/totem-pl-parser/Manifest
new file mode 100644
index 00000000..5ef2e886
--- /dev/null
+++ b/dev-libs/totem-pl-parser/Manifest
@@ -0,0 +1,12 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+DIST totem-pl-parser-3.2.0.tar.xz 1445160 RMD160 910d0062cea88a65ad63decdfb73ff7ea6e3684e SHA1 a0dfdc7acfe7186dfba50bad9629d6e17e9a871c SHA256 0142ec5ee8fcc0553e8c67f4c35e0a25fc610434cde918db70cb8311899f4c7d
+EBUILD totem-pl-parser-3.2.0.ebuild 1961 RMD160 c9c9495af799a320938e491b9b2af681067f593f SHA1 7b457138b23037cea7eb2c51399367eae227327e SHA256 60bcdf2ebd5af55054a1906191276b5115c3ac4742976685398180cf7f164768
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.18 (GNU/Linux)
+
+iEYEAREKAAYFAk9vS44ACgkQ1fmVwcYIWAZ5QQCeKxJ9Wf8LhhRtyNmApwlvvQHq
+vyoAoKTYQEbNIRe9pE/I9OnGUqygwcrN
+=hJ6+
+-----END PGP SIGNATURE-----
diff --git a/dev-libs/totem-pl-parser/totem-pl-parser-3.2.0.ebuild b/dev-libs/totem-pl-parser/totem-pl-parser-3.2.0.ebuild
new file mode 100644
index 00000000..948965e9
--- /dev/null
+++ b/dev-libs/totem-pl-parser/totem-pl-parser-3.2.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/totem-pl-parser/totem-pl-parser-2.32.6-r1.ebuild,v 1.5 2012/01/18 20:25:17 maekke Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2
+
+DESCRIPTION="Playlist parsing library"
+HOMEPAGE="http://projects.gnome.org/totem/ http://developer.gnome.org/totem-pl-parser/stable/"
+
+# eautoreconf needs:
+#SRC_URI="${SRC_URI} mirror://gentoo/introspection-20110205.m4.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~sparc ~x86 ~x86-fbsd"
+IUSE="archive crypt doc +introspection +quvi"
+
+RDEPEND=">=dev-libs/glib-2.31:2
+ dev-libs/gmime:2.4
+ >=net-libs/libsoup-gnome-2.30:2.4
+ archive? ( >=app-arch/libarchive-2.8.4 )
+ crypt? ( dev-libs/libgcrypt )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+ quvi? ( >=media-libs/libquvi-0.2.15 )"
+DEPEND="${RDEPEND}
+ !<media-video/totem-2.21
+ >=sys-devel/gettext-0.17
+ >=dev-util/intltool-0.35
+ doc? ( >=dev-util/gtk-doc-1.14 )"
+# eautoreconf needs:
+# >=dev-util/gtk-doc-am-1.14
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-static
+ --disable-maintainer-mode
+ $(use_enable archive libarchive)
+ $(use_enable crypt libgcrypt)
+ $(use_enable quvi)
+ $(use_enable introspection)"
+ DOCS="AUTHORS ChangeLog NEWS"
+}
+
+# eautoreconf needs:
+#src_unpack() {
+# # If gobject-introspection is installed, we don't need the extra .m4
+# if has_version "dev-libs/gobject-introspection"; then
+# unpack ${P}.tar.bz2
+# else
+# unpack ${A}
+# fi
+#}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Disable tests requiring network access, bug #346127
+ sed -e 's:\(g_test_add_func.*/parser/resolution.*\):/*\1*/:' \
+ -e 's:\(g_test_add_func.*/parser/parsing/itms_link.*\):/*\1*/:' \
+ -i plparse/tests/parser.c || die "sed failed"
+}
+
+src_test() {
+ # This is required as told by upstream in bgo#629542
+ dbus-launch emake check || die "emake check failed"
+}