aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-12-31 20:38:02 +0000
committerMike Frysinger <vapier@gentoo.org>2009-12-31 20:38:02 +0000
commit0b2d0378a577421f4a025fe39760abda652bbcd8 (patch)
tree62498902abdb9d1d9a26191381214b0262a7f560 /Makefile
parentignore generated gettext files (diff)
downloadnet-tools-0b2d0378a577421f4a025fe39760abda652bbcd8.tar.gz
net-tools-0b2d0378a577421f4a025fe39760abda652bbcd8.tar.bz2
net-tools-0b2d0378a577421f4a025fe39760abda652bbcd8.zip
improve dist target: include compiled gettext files, exclude scm files, and always prefix the paths in the tarball with the full versioned name
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 1065945..798509d 100644
--- a/Makefile
+++ b/Makefile
@@ -154,8 +154,12 @@ clobber: clean
dist: clobber
+ @$(MAKE) -C po $@
@echo Creating net-tools-$(RELEASE) in ..
- @tar -cvz -f ../net-tools-$(RELEASE).tar.gz -C .. net-tools
+ @tar -cvz -f ../net-tools-$(RELEASE).tar.gz . \
+ --transform='s,^[.],net-tools-$(RELEASE),' \
+ --exclude=CVS --exclude=.cvsignore \
+ --exclude='.git*'
config.h: config.in Makefile