summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChi-Thanh Christopher Nguyen <chithanh@gentoo.org>2013-07-17 18:41:22 +0200
committerChi-Thanh Christopher Nguyen <chithanh@gentoo.org>2013-07-17 18:41:22 +0200
commit3da9d5d686517074bbcdc9fb79b3a2c217ed16f0 (patch)
tree02a41cf97adebdd5e69a3bec9c2f82fb71946b34 /dev-libs
parentdev-libs/weston: install README.gentoo, weston-gears and examples (diff)
downloadx11-3da9d5d686517074bbcdc9fb79b3a2c217ed16f0.tar.gz
x11-3da9d5d686517074bbcdc9fb79b3a2c217ed16f0.tar.bz2
x11-3da9d5d686517074bbcdc9fb79b3a2c217ed16f0.zip
dev-libs/wayland: sync ebuild with g-x86
Change control operators back to if clauses. Revert eclass changes.
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/wayland/wayland-9999.ebuild50
1 files changed, 29 insertions, 21 deletions
diff --git a/dev-libs/wayland/wayland-9999.ebuild b/dev-libs/wayland/wayland-9999.ebuild
index efce00df..20e4b893 100644
--- a/dev-libs/wayland/wayland-9999.ebuild
+++ b/dev-libs/wayland/wayland-9999.ebuild
@@ -3,41 +3,49 @@
# $Header: $
EAPI=5
-AUTOTOOLS_AUTORECONF=1
-AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
-EGIT_REPO_URI="git://anongit.freedesktop.org/git/${PN}/${PN}"
-inherit autotools-utils toolchain-funcs
-[[ ${PV} == 9999* ]] && inherit git-2
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="git://anongit.freedesktop.org/git/${PN}/${PN}"
+ GIT_ECLASS="git-2"
+ EXPERIMENTAL="true"
+fi
+
+inherit autotools toolchain-funcs $GIT_ECLASS
DESCRIPTION="Wayland protocol libraries"
HOMEPAGE="http://wayland.freedesktop.org/"
-[[ ${PV} == 9999* ]] || \
-SRC_URI="http://wayland.freedesktop.org/releases/${P}.tar.xz"
+
+if [[ $PV = 9999* ]]; then
+ SRC_URI="${SRC_PATCHES}"
+ KEYWORDS=""
+else
+ SRC_URI="http://wayland.freedesktop.org/releases/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+fi
LICENSE="MIT"
SLOT="0"
-[[ ${PV} == 9999* ]] || \
-KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86"
IUSE="doc static-libs"
-RDEPEND="
- dev-libs/expat
- virtual/libffi
-"
+RDEPEND="dev-libs/expat
+ virtual/libffi"
DEPEND="${RDEPEND}
- virtual/pkgconfig
doc? ( app-doc/doxygen )
-"
+ virtual/pkgconfig"
+
+src_prepare() {
+ if [[ ${PV} = 9999* ]]; then
+ eautoreconf
+ fi
+}
src_configure() {
- local myeconfargs=(
- $(use_enable doc documentation)
- )
+ myconf="$(use_enable static-libs static) \
+ $(use_enable doc documentation)"
if tc-is-cross-compiler ; then
- myeconfargs+=( --disable-scanner )
+ myconf+=" --disable-scanner"
fi
- autotools-utils_src_configure
+ econf ${myconf}
}
src_test() {
@@ -45,5 +53,5 @@ src_test() {
mkdir "${XDG_RUNTIME_DIR}" || die
chmod 0700 "${XDG_RUNTIME_DIR}" || die
- autotools-utils_src_test
+ default
}