summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNikoli <nikoli@lavabit.com>2013-07-17 20:54:03 +0400
committerNikoli <nikoli@lavabit.com>2013-07-17 20:54:03 +0400
commit4019fc0232259bb000642df19f85a790d88457e8 (patch)
tree45ba308db4dc590866af8251e130eb3730ee9cd4 /dev-libs
parentdev-libs/wayland: sync ebuild with g-x86 (diff)
downloadx11-4019fc0232259bb000642df19f85a790d88457e8.tar.gz
x11-4019fc0232259bb000642df19f85a790d88457e8.tar.bz2
x11-4019fc0232259bb000642df19f85a790d88457e8.zip
dev-libs/weston: tests need X server
Package-Manager: portage-2.1.12.2 RepoMan-Options: --force
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/weston/weston-1.2.0.ebuild9
-rw-r--r--dev-libs/weston/weston-9999.ebuild9
2 files changed, 12 insertions, 6 deletions
diff --git a/dev-libs/weston/weston-1.2.0.ebuild b/dev-libs/weston/weston-1.2.0.ebuild
index bd366021..55d4016c 100644
--- a/dev-libs/weston/weston-1.2.0.ebuild
+++ b/dev-libs/weston/weston-1.2.0.ebuild
@@ -11,8 +11,9 @@ EAPI=5
AUTOTOOLS_AUTORECONF=1
AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
EGIT_REPO_URI="git://anongit.freedesktop.org/git/wayland/${PN}"
+VIRTUALX_REQUIRED="test"
-inherit autotools-utils linux-info
+inherit autotools-utils linux-info virtualx
[[ ${PV} == 9999* ]] && inherit git-2
DESCRIPTION="Wayland reference compositor"
@@ -24,7 +25,7 @@ LICENSE="MIT CC-BY-SA-3.0"
SLOT="0"
[[ ${PV} == 9999* ]] || \
KEYWORDS="~arm ~amd64 ~x86 ~arm-linux"
-IUSE="colord +drm +egl examples headless fbdev pango pdf rdp +resize-optimization rpi static-libs +suid systemd tablet test unwind wayland-compositor X xwayland"
+IUSE="colord +drm +egl examples headless fbdev pango pdf rdp +resize-optimization rpi static-libs +suid systemd tablet test unwind wayland-compositor +X xwayland"
REQUIRED_USE="
drm? ( egl )
@@ -32,6 +33,7 @@ REQUIRED_USE="
pango? ( examples )
pdf? ( examples )
rpi? ( !drm !egl )
+ test? ( X )
wayland-compositor? ( egl )
"
@@ -147,7 +149,8 @@ src_test() {
mkdir "${XDG_RUNTIME_DIR}" || die
chmod 0700 "${XDG_RUNTIME_DIR}" || die
- autotools-utils_src_test
+ cd "${BUILD_DIR}" || die
+ Xemake check
}
src_install() {
diff --git a/dev-libs/weston/weston-9999.ebuild b/dev-libs/weston/weston-9999.ebuild
index bd366021..55d4016c 100644
--- a/dev-libs/weston/weston-9999.ebuild
+++ b/dev-libs/weston/weston-9999.ebuild
@@ -11,8 +11,9 @@ EAPI=5
AUTOTOOLS_AUTORECONF=1
AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
EGIT_REPO_URI="git://anongit.freedesktop.org/git/wayland/${PN}"
+VIRTUALX_REQUIRED="test"
-inherit autotools-utils linux-info
+inherit autotools-utils linux-info virtualx
[[ ${PV} == 9999* ]] && inherit git-2
DESCRIPTION="Wayland reference compositor"
@@ -24,7 +25,7 @@ LICENSE="MIT CC-BY-SA-3.0"
SLOT="0"
[[ ${PV} == 9999* ]] || \
KEYWORDS="~arm ~amd64 ~x86 ~arm-linux"
-IUSE="colord +drm +egl examples headless fbdev pango pdf rdp +resize-optimization rpi static-libs +suid systemd tablet test unwind wayland-compositor X xwayland"
+IUSE="colord +drm +egl examples headless fbdev pango pdf rdp +resize-optimization rpi static-libs +suid systemd tablet test unwind wayland-compositor +X xwayland"
REQUIRED_USE="
drm? ( egl )
@@ -32,6 +33,7 @@ REQUIRED_USE="
pango? ( examples )
pdf? ( examples )
rpi? ( !drm !egl )
+ test? ( X )
wayland-compositor? ( egl )
"
@@ -147,7 +149,8 @@ src_test() {
mkdir "${XDG_RUNTIME_DIR}" || die
chmod 0700 "${XDG_RUNTIME_DIR}" || die
- autotools-utils_src_test
+ cd "${BUILD_DIR}" || die
+ Xemake check
}
src_install() {