summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor Ulyanov <disinbox@gmail.com>2014-08-02 16:21:02 +0400
committerIgor Ulyanov <disinbox@gmail.com>2014-08-02 16:21:02 +0400
commitff18973d66455eed8bf8213e7f9986648749efa0 (patch)
tree3ec5cd77ff75c1fac8aa4762f0b6337dc7f88e94
parentmanifest (diff)
downloaddisplacer-ff18973d66455eed8bf8213e7f9986648749efa0.tar.gz
displacer-ff18973d66455eed8bf8213e7f9986648749efa0.tar.bz2
displacer-ff18973d66455eed8bf8213e7f9986648749efa0.zip
tox-core-9999 added
-rw-r--r--net-im/tox-core/Manifest1
-rw-r--r--net-im/tox-core/tox-core-9999.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/net-im/tox-core/Manifest b/net-im/tox-core/Manifest
index 947ee20..e81b0f1 100644
--- a/net-im/tox-core/Manifest
+++ b/net-im/tox-core/Manifest
@@ -1 +1,2 @@
EBUILD tox-core-20131029.ebuild 1283 SHA256 40f31fc0508fb617a560fcfb2c72ed9179fe4541ecb7f1c1e355f10a33b83634 SHA512 6ed850cbdfa5eaf62f0d01c9d8c8e8e15ba56ccb3775d7542439c16db6e88d8075fe2673c4b5eaac32337f9236271b030d20114560064280f2fb5fe03331e6d3 WHIRLPOOL 7730857757c1a10f679656fbbcb575be3d817d07cc706177c133e2c5a2e194b0b604dd68680f8c389f3fac82fd66b1bc1f10782b6d06efa949f56b1d9eaf8fcc
+EBUILD tox-core-9999.ebuild 1228 SHA256 82705ff9766a321316cac298e9dacf552eda751c19beb4cc9f65337114fc5137 SHA512 945f481666136a36124e3230f9ab09f8ff2d66d2ac6e507793f31bdcc10316d0c5f52e90db0c6ebe5f969bf85ea2fb003d6322e56b0a63662d89a7621a3f7519 WHIRLPOOL 406568b13136ed197287043d3dd5fff5280a7960f174e3122283eb840f7671295a159ae587e637c3f25b3af09ecdf8c8738367f343e992dbd2283183bfff0752
diff --git a/net-im/tox-core/tox-core-9999.ebuild b/net-im/tox-core/tox-core-9999.ebuild
new file mode 100644
index 0000000..ce55711
--- /dev/null
+++ b/net-im/tox-core/tox-core-9999.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit autotools flag-o-matic git-r3 multilib
+
+DESCRIPTION="Free as in freedom Skype replacement"
+HOMEPAGE="http://tox.im/"
+EGIT_REPO_URI="git://github.com/irungentoo/ProjectTox-Core.git
+ https://github.com/irungentoo/ProjectTox-Core.git"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="-nacl ncurses server +sodium static-libs test"
+REQUIRED_USE="^^ ( nacl sodium )"
+
+RDEPEND="virtual/ffmpeg
+ nacl? ( virtual/nacl )
+ ncurses? ( sys-libs/ncurses )
+ sodium? ( dev-libs/libsodium )"
+DEPEND="${RDEPEND}
+ test? ( dev-libs/check )"
+
+DOCS="README.md"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf \
+ $(use_enable nacl) \
+ $(use_enable server dht-bootstrap-daemon) \
+ $(use_enable test tests) \
+ $(use_enable ncurses ntox) \
+ $(use_enable static-libs static) \
+ --with-nacl-headers=/usr/include/nacl \
+ --with-nacl-libs=/usr/$(get_libdir)/nacl
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
+
+pkg_postinst() {
+ elog "DHT node list is available via https://gist.github.com/Proplex/6124860"
+ elog "or in #tox @ irc.freenode.org"
+}