summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChen, Chih-Chia <pigfoot@gmail.com>2022-03-15 17:54:53 +0800
committerChen, Chih-Chia <pigfoot@gmail.com>2022-03-15 17:54:53 +0800
commitb5487d879c3c1dc9ceaa45e47af668639ae607ea (patch)
tree29d8b5445289ebf6785b81b6f4d345520b6e5f53
parent[net-analyzer/amass] refine (diff)
downloadpigfoot-b5487d879c3c1dc9ceaa45e47af668639ae607ea.tar.gz
pigfoot-b5487d879c3c1dc9ceaa45e47af668639ae607ea.tar.bz2
pigfoot-b5487d879c3c1dc9ceaa45e47af668639ae607ea.zip
[net-misc/curlie] upgrade from upstream
Signed-off-by: Chen, Chih-Chia <pigfoot@gmail.com>
-rw-r--r--net-misc/curlie/curlie-1.6.0-r1.ebuild49
-rw-r--r--net-misc/curlie/curlie-1.6.0.ebuild45
l---------net-misc/curlie/curlie-1.6.7.ebuild1
-rw-r--r--net-misc/curlie/curlie-9999.ebuild59
4 files changed, 60 insertions, 94 deletions
diff --git a/net-misc/curlie/curlie-1.6.0-r1.ebuild b/net-misc/curlie/curlie-1.6.0-r1.ebuild
deleted file mode 100644
index 4633378..0000000
--- a/net-misc/curlie/curlie-1.6.0-r1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 2019-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit go-module
-
-EGO_PN="github.com/rs/${PN}"
-
-EGO_SUM=(
- "github.com/akamensky/argparse v0.0.0-20180518035907-99676ba18cd5/go.mod"
- "github.com/jessevdk/go-flags v1.4.0/go.mod"
- "golang.org/x/crypto v0.0.0-20180524125353-159ae71589f3"
- "golang.org/x/crypto v0.0.0-20180524125353-159ae71589f3/go.mod"
- "golang.org/x/sys v0.0.0-20180525062015-31355384c89b/go.mod"
- "golang.org/x/sys v0.0.0-20191026070338-33540a1f6037"
- "golang.org/x/sys v0.0.0-20191026070338-33540a1f6037/go.mod"
-)
-
-go-module_set_globals
-
-DESCRIPTION="The power of curl, the ease of use of httpie, written in GoLang"
-SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-SRC_URI+="${EGO_SUM_SRC_URI}"
-RESTRICT="mirror"
-
-LICENSE="MIT"
-SLOT="0/${PVR}"
-KEYWORDS="~amd64 ~x86 ~arm"
-IUSE="+pie"
-
-src_compile() {
- # -buildmode=pie forces external linking mode, even CGO_ENABLED=0
- # https://github.com/golang/go/issues/18968
- use pie && local build_pie="-buildmode=pie"
-
- local build_flags="$( echo ${EGO_BUILD_FLAGS} ) $( echo ${build_pie} )"
-
- set -- env \
- GOCACHE="${T}/go-cache" \
- CGO_ENABLED=0 \
- go build -mod=readonly -v -work -x ${build_flags} -o "bin/${PN}" ${EGO_PN}
- echo "$@"
- "$@" || die
-}
-
-src_install() {
- dobin bin/*
-}
diff --git a/net-misc/curlie/curlie-1.6.0.ebuild b/net-misc/curlie/curlie-1.6.0.ebuild
deleted file mode 100644
index 2b714c8..0000000
--- a/net-misc/curlie/curlie-1.6.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-EGO_PN="github.com/rs/${PN}"
-EGO_VENDOR=(
- "github.com/akamensky/argparse 99676ba18cd5"
- "github.com/jessevdk/go-flags v1.4.0"
- "golang.org/x/crypto 159ae71589f3 github.com/golang/crypto"
- "golang.org/x/sys 33540a1f6037 github.com/golang/sys"
-)
-
-inherit golang-build golang-vcs-snapshot
-
-DESCRIPTION="The power of curl, the ease of use of httpie, written in GoLang"
-ARCHIVE_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
- ${EGO_VENDOR_URI}"
-SRC_URI="${ARCHIVE_URI}"
-RESTRICT="mirror"
-
-LICENSE="MIT"
-SLOT="0/${PVR}"
-KEYWORDS="~amd64 ~x86 ~arm"
-IUSE="+pie"
-
-src_compile() {
- # -buildmode=pie forces external linking mode, even CGO_ENABLED=0
- # https://github.com/golang/go/issues/18968
- use pie && local build_pie="-buildmode=pie"
-
- local build_flags="$( echo ${EGO_BUILD_FLAGS} ) $( echo ${build_pie} )"
-
- set -- env GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" \
- GOCACHE="${T}/go-cache" \
- CGO_ENABLED=0 \
- GO111MODULE=off \
- go install -v -work -x ${build_flags} ${EGO_PN}
- echo "$@"
- "$@" || die
-}
-
-src_install() {
- dobin bin/*
-}
diff --git a/net-misc/curlie/curlie-1.6.7.ebuild b/net-misc/curlie/curlie-1.6.7.ebuild
new file mode 120000
index 0000000..de2fa23
--- /dev/null
+++ b/net-misc/curlie/curlie-1.6.7.ebuild
@@ -0,0 +1 @@
+curlie-9999.ebuild \ No newline at end of file
diff --git a/net-misc/curlie/curlie-9999.ebuild b/net-misc/curlie/curlie-9999.ebuild
new file mode 100644
index 0000000..259bc40
--- /dev/null
+++ b/net-misc/curlie/curlie-9999.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+EGO_PN="github.com/rs/${PN}"
+
+inherit go-module
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://${EGO_PN}.git"
+
+ src_unpack() {
+ git-r3_src_unpack
+ go-module_live_vendor
+ }
+else
+ EGO_VER="v${PV}"
+ #SRC_URI="https://${EGO_PN}/archive/${EGO_VER}.tar.gz -> ${P}.tar.gz"
+
+ #SRC_URI+="${EGO_SUM_SRC_URI}"
+ #S="${WORKDIR}/Amass-${PV}"
+ inherit git-r3
+ EGIT_REPO_URI="https://${EGO_PN}.git"
+ EGIT_COMMIT="${EGO_VER}"
+
+ src_unpack() {
+ git-r3_src_unpack
+ go-module_live_vendor
+ }
+
+ KEYWORDS="~amd64 ~x86 ~arm64 ~arm"
+fi
+
+DESCRIPTION="The power of curl, the ease of use of httpie, written in GoLang"
+LICENSE="MIT"
+SLOT="0/${PVR}"
+RESTRICT="mirror"
+IUSE="+pie"
+
+src_compile() {
+ # -buildmode=pie forces external linking mode, even CGO_ENABLED=0
+ # https://github.com/golang/go/issues/18968
+ use pie && local build_pie="-buildmode=pie"
+
+ local build_flags="$( echo ${EGO_BUILD_FLAGS} ) $( echo ${build_pie} )"
+
+ set -- env \
+ CGO_ENABLED=0 \
+ go build -o "bin/${PN}" -mod=vendor -v -work -x ${build_flags} \
+ ${EGO_PN}
+ echo "$@"
+ "$@" || die
+}
+
+src_install() {
+ dobin bin/${PN}
+}