summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Phillips <write2david@gmail.com>2012-10-31 21:54:20 -0500
committerDavid Phillips <write2david@gmail.com>2012-10-31 21:54:20 -0500
commit4d7cfb35d2ed36f6e83fa0c9bde8e055d954cac8 (patch)
tree224226cb7faaabf2a9c886cd7785f356fd226053
parentAdd -r2 for cairo-dock-plugins (diff)
downloadwrite2David-4d7cfb35d2ed36f6e83fa0c9bde8e055d954cac8.tar.gz
write2David-4d7cfb35d2ed36f6e83fa0c9bde8e055d954cac8.tar.bz2
write2David-4d7cfb35d2ed36f6e83fa0c9bde8e055d954cac8.zip
Update method of dealing with cairo-dock's...
...installation into non-standard directories
-rw-r--r--x11-misc/cairo-dock/cairo-dock-9999.ebuild21
-rw-r--r--x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999-r2.ebuild9
2 files changed, 21 insertions, 9 deletions
diff --git a/x11-misc/cairo-dock/cairo-dock-9999.ebuild b/x11-misc/cairo-dock/cairo-dock-9999.ebuild
index aa7de05..1e9896a 100644
--- a/x11-misc/cairo-dock/cairo-dock-9999.ebuild
+++ b/x11-misc/cairo-dock/cairo-dock-9999.ebuild
@@ -61,10 +61,23 @@ pkg_setup()
ewarn ""
ewarn "THIS IS A LIVE EBUILD, NOT AN OFFICIAL RELEASE."
ewarn " Thus, it may FAIL to build properly."
- ewarn " Please do NOT report bugs to Gentoo's bugzilla."
+ ewarn ""
+ ewarn "This ebuild is not supported by an Gentoo developer."
+ ewarn " So please do NOT report bugs to Gentoo's bugzilla."
ewarn " Instead, report all bugs to write2david@gmail.com"
ewarn ""
ewarn ""
+
+ # Dealing with the weird behavior of cairo-dock installing
+ # stuff under "/usr/usr/lib" for 32-bit systems.
+ # Also, the weird reported behavior of cairo-dock installing
+ # stuff under "/usr/usr/lib6464" for 64-bit system.
+
+ # We are doing this so that files are actually placed into the normal directory
+
+ ln -s /usr/lib /usr/usr/lib
+ ln -s /usr/lib64 /usr/usr/lib6464/
+
}
@@ -74,10 +87,12 @@ src_prepare() {
}
-# Not sure what the next line does. Can't find any documenation about it.
-# Maybe it does nothing? Help?!
+# Not sure what the next line does. Can't find any documentation about it.
+# Maybe it does nothing? It came from someone else's old ebuild for
+# cairo-dock. Help?!
#MAKE_IN_SOURCE_BUILD=true
+
src_configure() {
# Next line added because of the same issues/solutions reported on...
diff --git a/x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999-r2.ebuild b/x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999-r2.ebuild
index 37b98d5..628aaeb 100644
--- a/x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999-r2.ebuild
+++ b/x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999-r2.ebuild
@@ -113,13 +113,10 @@ pkg_postinst() {
ewarn ""
ewarn "THIS IS A LIVE EBUILD, NOT AN OFFICIAL RELEASE."
ewarn " Thus, it may FAIL to run properly."
- ewarn " Please do NOT report bugs to Gentoo's bugzilla."
+ ewarn ""
+ ewarn "This ebuild is not supported by an Gentoo developer."
+ ewarn " So please do NOT report bugs to Gentoo's bugzilla."
ewarn " Instead, report all bugs to write2david@gmail.com"
ewarn ""
ewarn ""
- # Dealing with the weird issue of cairo-dock installing under /usr/usr
- # Without this next line, cairo-dock won't start
- # Also, a report of weird behavior of installing under "lib6464"
- ln -s /usr/usr/lib/libgldi.so.3 /usr/lib/libgldi.so.3
- ln -s /usr/usr/lib6464/libgldi.so.3 /usr/lib64/libgldi.so.3
}