summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDane Smith <c1pher@gentoo.org>2013-05-13 13:19:34 -0400
committerDane Smith <c1pher@gentoo.org>2013-05-13 13:19:34 -0400
commite3b7c425ea3b4bc5130944b78e17d9c53e350fe7 (patch)
tree0b8f02bf21e0a1ea32de9ff4bc278f7ee309af9d /sys-auth/libpam-google-authenticator/libpam-google-authenticator-1.0.ebuild
parentgo version bump for my testing. (diff)
downloadc1pher-e3b7c425ea3b4bc5130944b78e17d9c53e350fe7.tar.gz
c1pher-e3b7c425ea3b4bc5130944b78e17d9c53e350fe7.tar.bz2
c1pher-e3b7c425ea3b4bc5130944b78e17d9c53e350fe7.zip
Allow time configuration.
Diffstat (limited to 'sys-auth/libpam-google-authenticator/libpam-google-authenticator-1.0.ebuild')
-rw-r--r--sys-auth/libpam-google-authenticator/libpam-google-authenticator-1.0.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/sys-auth/libpam-google-authenticator/libpam-google-authenticator-1.0.ebuild b/sys-auth/libpam-google-authenticator/libpam-google-authenticator-1.0.ebuild
index e716524..6a6a31a 100644
--- a/sys-auth/libpam-google-authenticator/libpam-google-authenticator-1.0.ebuild
+++ b/sys-auth/libpam-google-authenticator/libpam-google-authenticator-1.0.ebuild
@@ -3,7 +3,7 @@
# $Header: $
EAPI=4
-inherit pam
+inherit eutils pam toolchain-funcs
DESCRIPTION="Google Authentiator PAM plugin"
HOMEPAGE="http://code.google.com/p/google-authenticator/"
@@ -17,7 +17,15 @@ IUSE=""
DEPEND="sys-libs/pam"
RDEPEND="${DEPEND}"
-src_install(){
+src_prepare() {
+ epatch "${FILESDIR}/allow_time_config.patch"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
insinto $(getpam_mod_dir)
doins pam_google_authenticator.so
dobin google-authenticator
@@ -25,6 +33,6 @@ src_install(){
dodoc README
}
-pkg_postinst(){
+pkg_postinst() {
elog "For setup information check the installed README"
}