summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/libpam-google-authenticator/libpam-google-authenticator-1.0.ebuild')
-rw-r--r--sys-auth/libpam-google-authenticator/libpam-google-authenticator-1.0.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/sys-auth/libpam-google-authenticator/libpam-google-authenticator-1.0.ebuild b/sys-auth/libpam-google-authenticator/libpam-google-authenticator-1.0.ebuild
index e716524..6a6a31a 100644
--- a/sys-auth/libpam-google-authenticator/libpam-google-authenticator-1.0.ebuild
+++ b/sys-auth/libpam-google-authenticator/libpam-google-authenticator-1.0.ebuild
@@ -3,7 +3,7 @@
# $Header: $
EAPI=4
-inherit pam
+inherit eutils pam toolchain-funcs
DESCRIPTION="Google Authentiator PAM plugin"
HOMEPAGE="http://code.google.com/p/google-authenticator/"
@@ -17,7 +17,15 @@ IUSE=""
DEPEND="sys-libs/pam"
RDEPEND="${DEPEND}"
-src_install(){
+src_prepare() {
+ epatch "${FILESDIR}/allow_time_config.patch"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
insinto $(getpam_mod_dir)
doins pam_google_authenticator.so
dobin google-authenticator
@@ -25,6 +33,6 @@ src_install(){
dodoc README
}
-pkg_postinst(){
+pkg_postinst() {
elog "For setup information check the installed README"
}