summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <hans@degraaff.org>2020-11-06 07:49:58 +0100
committerHans de Graaff <hans@degraaff.org>2020-11-06 07:49:58 +0100
commit04f531c8d8d2be31cf01b7a003a96527333d76a1 (patch)
tree6749325f504a100c40aab89ab20c21cf396cefc9
parentdev-ruby/rubocop: cleanup (diff)
downloadgraaff-04f531c8d8d2be31cf01b7a003a96527333d76a1.tar.gz
graaff-04f531c8d8d2be31cf01b7a003a96527333d76a1.tar.bz2
graaff-04f531c8d8d2be31cf01b7a003a96527333d76a1.zip
dev-ruby/rotp: add 6.2.0
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Hans de Graaff <hans@degraaff.org>
-rw-r--r--dev-ruby/rotp/Manifest1
-rw-r--r--dev-ruby/rotp/rotp-6.2.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/rotp/Manifest b/dev-ruby/rotp/Manifest
index bf018e77..186391f0 100644
--- a/dev-ruby/rotp/Manifest
+++ b/dev-ruby/rotp/Manifest
@@ -3,3 +3,4 @@ DIST rotp-5.0.0.gem 62464 BLAKE2B 0df6334007eaa54f18d04adc02a0cdce3478dd6f0af6a7
DIST rotp-5.1.0.gem 62464 BLAKE2B 813e625e1e980421595654af440d091c938532c5188a1073b00adf98f51d4f55e9aff704448e3d19119622eb9d6b747110d7d1587aad0da96c8da3745ba9bfa1 SHA512 889e6ab24e3fac089ad9278ba82de9401e7bcc7cb1afee66324d56f2d0380f3dc8525a8c02d3ec22cd0097c3cbaa722887912025dd29762dcada05f44f723f54
DIST rotp-6.0.0.gem 62464 BLAKE2B fdd6ea402a2cd084b514ee84041448771230d29253415369b1bd59cd709f85ca6d857995ccd9ed8955b8ca4f5e220949c9a2520eba850d6adfd8a9d0d173e9a4 SHA512 579420f0c7f320884322eadbb4a3071ec1374ea6e4657ba0a2612f53f6b9c730afa78c355fd2b07dafa93e8214a6e1d17753dacb7cb65d3fb67b3f6e71378de2
DIST rotp-6.1.0.gem 63488 BLAKE2B 9e8fc5b5dd594acc6bec1cde49018ebd2bf77b3c802c5e0434601a28b4a3b184294a376397648b0522496cbfc0496651901007dca05e2f85bc3787bbe2c2b727 SHA512 e62e7784e81a2f7f2a75831eff09eea588a1de9b9f1156645f7a358cb87cc61f93c5e7f6a793723a0b6b3a48ddf120f1634609aa9920f6cc0e81a6c83ad7c4fd
+DIST rotp-6.2.0.gem 63488 BLAKE2B 1ae290b6fb0714f06f44fa9bad15c3619dc897d68aac9ec44a6c47417b01ac55e5066df5ae731f4a7c75984226369e498e2f705ce6c7e0197671c527e3394751 SHA512 db874073a636a09e855b3e69663405920fc20ec9bf8e3bf3eea6a9db2bc69200763a61699760addb8c6f8fdd70aa5d2dcc2fbce347ab1e953865765811c80822
diff --git a/dev-ruby/rotp/rotp-6.2.0.ebuild b/dev-ruby/rotp/rotp-6.2.0.ebuild
new file mode 100644
index 00000000..663f2444
--- /dev/null
+++ b/dev-ruby/rotp/rotp-6.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Works for both HOTP and TOTP, and includes QR Code provisioning"
+HOMEPAGE="https://github.com/mdp/rotp"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "
+ test? ( dev-ruby/timecop )
+"
+
+all_ruby_prepare() {
+ # Remove pregenerated documentation so we can update it.
+ rm -rf doc || die
+
+ sed -e '/simplecov/,/^end/ s:^:#:' \
+ -e '1irequire "uri"' \
+ -i spec/spec_helper.rb || die
+}