summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <hans@degraaff.org>2018-04-20 07:23:45 +0200
committerHans de Graaff <hans@degraaff.org>2018-04-20 07:23:45 +0200
commit386856acd648bd849d2570b900e5fbe594bc39e7 (patch)
tree7b4d1292253ecd7149aa4881e30961e439f61ba7
parentapp-forensics/brakeman: cleanup (diff)
downloadgraaff-386856acd648bd849d2570b900e5fbe594bc39e7.tar.gz
graaff-386856acd648bd849d2570b900e5fbe594bc39e7.tar.bz2
graaff-386856acd648bd849d2570b900e5fbe594bc39e7.zip
dev-python/django-pipeline: add 1.6.14
Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--dev-python/django-pipeline/Manifest1
-rw-r--r--dev-python/django-pipeline/django-pipeline-1.6.14.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/django-pipeline/Manifest b/dev-python/django-pipeline/Manifest
index 03d6eaed..b9b6c96c 100644
--- a/dev-python/django-pipeline/Manifest
+++ b/dev-python/django-pipeline/Manifest
@@ -1 +1,2 @@
DIST django-pipeline-1.3.26.tar.gz 41054 BLAKE2B 0082186d742b0fd965546e7aba8275b2381c34239a164f73c8507cafaa68ba9f242c281dba27896bc080f43f28c731fb36dbbb83449e2976acaa593981f1b08e SHA512 106c89e6a5509305548f6169f9b38d3a288bdf260c4b933ac1372c8471e897b8f6109cdecf70a4f77dff670e2b97abe4ed990903abfc188a59600189d0473284
+DIST django-pipeline-1.6.14.tar.gz 57645 BLAKE2B 7ca380a8fa8a6f30cec3af004f12d677f08cfec646003cd8e3a8cce60bd571f720e5179c01954dd2270459a1bed57b8d1571e76ee120d4d168e69fd9d83d8ddb SHA512 5bffd0bbc8fed1ca5a3654a6a08cbb2836756586dc47cc749de800d4704339bfdd1aefbfab08b7125fac02d1d2b13a13a9c9a4a19c4ed642a94561e92a725cb4
diff --git a/dev-python/django-pipeline/django-pipeline-1.6.14.ebuild b/dev-python/django-pipeline/django-pipeline-1.6.14.ebuild
new file mode 100644
index 00000000..153a665a
--- /dev/null
+++ b/dev-python/django-pipeline/django-pipeline-1.6.14.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="An asset packaging library for Django"
+HOMEPAGE="https://pypi.python.org/pypi/django-pipeline/ https://github.com/cyberdelia/django-pipeline"
+
+# PyPi releases lack docs/ subdir:
+# https://github.com/cyberdelia/django-pipeline/pull/254
+SRC_URI="https://github.com/cyberdelia/django-pipeline/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/django-1.6[${PYTHON_USEDEP}]
+ dev-python/jsmin[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}] )"
+
+# As usual for test phase
+DISTUTILS_IN_SOURCE_BUILD=1
+
+# Requires npm modules
+RESTRICT="test"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ # https://github.com/cyberdelia/django-pipeline/issues/381
+ PYTHONPATH=. django-admin.py test --settings=tests.settings tests \
+ || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
+
+python_install() {
+ export PIPELINE_JS_COMPRESSOR = 'pipeline.compressors.jsmin.JSMinCompressor'
+ distutils-r1_python_install
+}