summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <hans@degraaff.org>2019-02-08 07:27:00 +0100
committerHans de Graaff <hans@degraaff.org>2019-02-08 07:27:00 +0100
commit4bc3a8a94738d0f9dd87ae4280df503b4fbc761f (patch)
tree040c051fc2941c2abff90276e6ed7450989eb5f8
parentdev-ruby/authlogic: cleanup (diff)
downloadgraaff-4bc3a8a94738d0f9dd87ae4280df503b4fbc761f.tar.gz
graaff-4bc3a8a94738d0f9dd87ae4280df503b4fbc761f.tar.bz2
graaff-4bc3a8a94738d0f9dd87ae4280df503b4fbc761f.zip
dev-ruby/authlogic: add 5.0.0
Signed-off-by: Hans de Graaff <hans@degraaff.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--dev-ruby/authlogic/Manifest1
-rw-r--r--dev-ruby/authlogic/authlogic-5.0.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-ruby/authlogic/Manifest b/dev-ruby/authlogic/Manifest
index c0c20d47..5f5ed021 100644
--- a/dev-ruby/authlogic/Manifest
+++ b/dev-ruby/authlogic/Manifest
@@ -1,2 +1,3 @@
DIST authlogic-3.8.0.gem 77312 BLAKE2B c55848e80e9f358063226e3127ce5e800f00ab56bf5b3b2156defbd75739e53d586e3bdcae13bf5f86a65615c8ea006fc539c44a535173655a298cea349badcc SHA512 65d3619f8fbdf9a861b5a7b9b98a76abca51b66afbfeacc549cad212d82fd6db82edceac61ed42fa5b83b2bd1ace15978bf16637d7ccd944e35e5ef3b7a17a61
DIST authlogic-4.4.2.gem 89088 BLAKE2B 6af884fff44c865468936e7679659bb6e46e084589ee850dd15d7dbab24e28769155af5d219e9f56c299e83c5600a3fef96e6d7e27c8ec7c9d1170542f586877 SHA512 413e83f0063d476e81f831c7840ad5d08e4de66bcc0937e1f671c20f0b1a275b6907ad92dc8eddcc1ce95861dfd32c667fd1b8173e6535570b3d2fdc1adb011a
+DIST authlogic-5.0.0.tar.gz 73862 BLAKE2B 6b329e34d968d8b3e54b73d4eb81a8cd80e48cb8b921b28f0508883357f4fd8b0364bf205a6f2cfd8ca617eeb016667d368933b1f7c5262a11029c9fc81c8a12 SHA512 c61f43c55eb0e719fa8a068571ec2c2459d29d25ecba1ad7cadd1ee753d1efdfe627d48b81cd788ab4888a47c06af6c379d860219afa795e48dfdd3ba03e1240
diff --git a/dev-ruby/authlogic/authlogic-5.0.0.ebuild b/dev-ruby/authlogic/authlogic-5.0.0.ebuild
new file mode 100644
index 00000000..d70fb37d
--- /dev/null
+++ b/dev-ruby/authlogic/authlogic-5.0.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A clean, simple, and unobtrusive ruby authentication solution."
+HOMEPAGE="https://github.com/binarylogic/authlogic"
+SRC_URI="https://github.com/binarylogic/authlogic/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Ruby"
+
+KEYWORDS="~amd64"
+SLOT="5"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/activerecord-5.2:* <dev-ruby/activerecord-6.1:*
+ >=dev-ruby/activesupport-5.2:* <dev-ruby/activesupport-6.1:*
+ >=dev-ruby/request_store-1.0.5:*
+ >=dev-ruby/bcrypt-ruby-3.1.5"
+ruby_add_bdepend "test? ( >=dev-ruby/bcrypt-ruby-3.1.5 dev-ruby/sqlite3 )"
+
+all_ruby_prepare() {
+ sed -i -e '/\(bundler\|rubocop\)/I s:^:#:' Rakefile || die
+ sed -i -e '/byebug/ s:^:#: ; /reporters/I s:^:#:' test/test_helper.rb || die
+
+ sed -i -e '/:crypto_provider/ s/SCrypt/BCrypt/' lib/authlogic/acts_as_authentic/password.rb || die
+ sed -i -e 's/SCrypt/BCrypt/' test/fixtures/{admins,users}.yml || die
+ sed -i -e '/SCrypt/ s:^:#:' test/test_helper.rb || die
+
+ sed -i -e '/scrypt/d' \
+ -e '/bcrypt/ s/development_//' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid tests for now that fail due to our BCrypt hack
+ rm -f test/session_test/{http_auth,persistence,password,magic_columns}_test.rb || die
+ rm -f test/acts_as_authentic_test/{password,persistence_token}_test.rb || die
+ rm -f test/crypto_provider_test/scrypt_test.rb || die
+}