summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <hans@degraaff.org>2021-12-25 08:39:36 +0100
committerHans de Graaff <hans@degraaff.org>2021-12-25 08:39:36 +0100
commit58a524e730fd5a7c7e25e2123ec4b55faa3e021c (patch)
tree55f6fbaecf6dc538e4858bba5ce9aa8c1790c007
parentdev-ruby/rubocop: add 1.24.0 (diff)
downloadgraaff-58a524e730fd5a7c7e25e2123ec4b55faa3e021c.tar.gz
graaff-58a524e730fd5a7c7e25e2123ec4b55faa3e021c.tar.bz2
graaff-58a524e730fd5a7c7e25e2123ec4b55faa3e021c.zip
dev-ruby/rotp: add ruby30
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <hans@degraaff.org>
-rw-r--r--dev-ruby/rotp/rotp-6.2.0-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/rotp/rotp-6.2.0-r1.ebuild b/dev-ruby/rotp/rotp-6.2.0-r1.ebuild
new file mode 100644
index 00000000..40eee60a
--- /dev/null
+++ b/dev-ruby/rotp/rotp-6.2.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Works for both HOTP and TOTP, and includes QR Code provisioning"
+HOMEPAGE="https://github.com/mdp/rotp"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "!<dev-ruby/rotp-5.0.0-r1:5"
+
+ruby_add_bdepend "
+ test? ( dev-ruby/timecop )
+"
+
+all_ruby_prepare() {
+ # Remove pregenerated documentation so we can update it.
+ rm -rf doc || die
+
+ sed -e '/simplecov/,/^end/ s:^:#:' \
+ -e '1irequire "uri"' \
+ -i spec/spec_helper.rb || die
+}