summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <hans@degraaff.org>2020-12-16 06:49:16 +0100
committerHans de Graaff <hans@degraaff.org>2020-12-16 06:49:16 +0100
commitfec2ad9dc66c15080350c7eadeaf6b962d51fbe7 (patch)
treecdeb9af2ba6ecca564312ed67a1a023649fe4d37
parentnet-analyzer/ssh-audit: use distutils (diff)
downloadgraaff-fec2ad9dc66c15080350c7eadeaf6b962d51fbe7.tar.gz
graaff-fec2ad9dc66c15080350c7eadeaf6b962d51fbe7.tar.bz2
graaff-fec2ad9dc66c15080350c7eadeaf6b962d51fbe7.zip
dev-ruby/rotp: add ruby27
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Hans de Graaff <hans@degraaff.org>
-rw-r--r--dev-ruby/rotp/rotp-5.0.0-r1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-ruby/rotp/rotp-5.0.0-r1.ebuild b/dev-ruby/rotp/rotp-5.0.0-r1.ebuild
index 1556bd69..b0da2ecb 100644
--- a/dev-ruby/rotp/rotp-5.0.0-r1.ebuild
+++ b/dev-ruby/rotp/rotp-5.0.0-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-USE_RUBY="ruby24 ruby25 ruby26"
+USE_RUBY="ruby25 ruby26 ruby27"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
@@ -33,5 +33,5 @@ all_ruby_prepare() {
# Remove pregenerated documentation so we can update it.
rm -rf doc || die
- sed -i -e '/simplecov/,/^end/ s:^:#:' spec/spec_helper.rb || die
+ sed -i -e '/simplecov/,/^end/ s:^:#:' -e '1irequire "uri"' spec/spec_helper.rb || die
}