summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2015-02-25 18:44:56 +0200
committerMart Raudsepp <leio@gentoo.org>2015-02-25 18:45:13 +0200
commit7bb3e5da6637f6ba2b36b86dc672cb69f625106f (patch)
tree9de85853cfb9ac7c5a297940cecc03e8dfda5f89
parentgtk+:3 - bump and sync with main tree (diff)
downloadleio-7bb3e5da6637f6ba2b36b86dc672cb69f625106f.tar.gz
leio-7bb3e5da6637f6ba2b36b86dc672cb69f625106f.tar.bz2
leio-7bb3e5da6637f6ba2b36b86dc672cb69f625106f.zip
webkit-gtk: Fix rpi egl/gles2 flag appending logic
It checks for egl libraries with USE=egl too in configure, not just when USE=webgl is given. As they are force coupled with rpi, append the flags when either egl or gles2 USE flags are given (though REQUIRED_USE mostly takes care of it too, iirc).
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.4.8.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.4.8.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.4.8.ebuild
index 3a549dc..34fdf6e 100644
--- a/net-libs/webkit-gtk/webkit-gtk-2.4.8.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-2.4.8.ebuild
@@ -216,9 +216,9 @@ src_configure() {
# Arches without JIT support also need this to really disable it in all places
use jit || append-cppflags -DENABLE_JIT=0 -DENABLE_YARR_JIT=0 -DENABLE_ASSEMBLER=0
- if use webgl; then
- use rpi && append-cppflags $(pkg-config --cflags egl glesv2)
- use rpi && append-ldflags $(pkg-config --libs egl glesv2)
+ if use rpi; then
+ (use egl || use gles2) && append-cppflags $(pkg-config --cflags egl glesv2)
+ (use egl || use gles2) && append-ldflags $(pkg-config --libs egl glesv2)
fi
# It doesn't compile on alpha without this in LDFLAGS, bug #???