summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/jsonbot/jsonbot-0.84.4.ebuild')
-rw-r--r--net-im/jsonbot/jsonbot-0.84.4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-im/jsonbot/jsonbot-0.84.4.ebuild b/net-im/jsonbot/jsonbot-0.84.4.ebuild
new file mode 100644
index 0000000..a6f11d7
--- /dev/null
+++ b/net-im/jsonbot/jsonbot-0.84.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+PYTHON_DEPEND="2"
+MY_P="jsb-${PV}"
+
+inherit distutils
+
+DESCRIPTION="Python based extensible and multi-protocol bot framework"
+HOMEPAGE="http://code.google.com/p/jsonbot/"
+SRC_URI="http://jsonbot.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Missing deps (will be bundled) : hapi, sleekxmpp
+RDEPEND="dev-python/beautifulsoup
+ dev-python/dnspython
+ dev-python/feedparser
+ dev-python/oauth
+ dev-python/pysqlite
+ dev-python/requests
+ dev-python/simplejson
+ >=www-servers/tornado-2.2"
+DEPEND="${RDEPEND}
+ dev-lang/python[sqlite]
+ dev-python/setuptools"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ distutils_src_install
+ rm -rf "${D}"/usr/jsb/
+}