summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZaheer Abbas Merali <zaheerm@gentoo.org>2006-07-14 17:05:14 +0000
committerZaheer Abbas Merali <zaheerm@gentoo.org>2006-07-14 17:05:14 +0000
commit78ab7b62ff9c26c731eb5ff3db8248ed11f7f470 (patch)
tree6ac931e703d189ebe1e4d8aa04e605dfaff59798
parentIstanbul 0.2.0 (diff)
downloadzaheerm-78ab7b62ff9c26c731eb5ff3db8248ed11f7f470.tar.gz
zaheerm-78ab7b62ff9c26c731eb5ff3db8248ed11f7f470.tar.bz2
zaheerm-78ab7b62ff9c26c731eb5ff3db8248ed11f7f470.zip
actually add the ebuild
svn path=/; revision=7
-rw-r--r--media-video/istanbul/istanbul-0.2.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-video/istanbul/istanbul-0.2.0.ebuild b/media-video/istanbul/istanbul-0.2.0.ebuild
new file mode 100644
index 0000000..4516bfb
--- /dev/null
+++ b/media-video/istanbul/istanbul-0.2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-libmms/gst-plugins-libmms-0.10.0.ebuild,v 1.2 2006/04/04 15:04:40 mr_bones_ Exp $
+
+inherit eutils gnome2
+
+KEYWORDS="~x86 ~amd64"
+
+RDEPEND=">=media-libs/gst-plugins-base-0.10.8
+ dev-lang/python
+ >=dev-python/pygtk-2.6
+ >=dev-python/gnome-python-extras-2.11.3
+ gnome-base/gconf
+ >=dev-python/gst-python-0.10.0
+ media-plugins/gst-plugins-ogg
+ media-plugins/gst-plugins-theora
+ >=media-libs/libtheora-1.0_alpha6"
+
+DEPEND="${RDEPEND}"
+SRC_URI="http://live.gnome.org/Istanbul/${P}.tar.bz2"
+
+src_compile() {
+ mkdir -p "${T}/home"
+ export HOME="${T}/home"
+ export GST_REGISTRY=${T}/home/registry.cache.xml
+ addpredict /root/.gconfd
+ addpredict /root/.gconf
+ econf
+ emake
+}