aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-03-28 17:47:55 -0700
committerMatt Turner <mattst88@gentoo.org>2020-03-28 18:35:14 -0700
commitbc493a6bfe5ee0446a28f6b5b23e9d0a11feb0d0 (patch)
treeca985d5bc441a92b6cedfdee6bb70978f25afbd3
parentcatalyst: Delete Gentoo Reference Platform target (diff)
downloadcatalyst-bc493a6b.tar.gz
catalyst-bc493a6b.tar.bz2
catalyst-bc493a6b.zip
catalyst: Delete tinderbox target
Unused, and other successful tinderbox systems exist and are in active use. Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--README1
-rw-r--r--catalyst/defaults.py2
-rw-r--r--catalyst/targets/tinderbox.py47
-rw-r--r--doc/catalyst-spec.5.txt4
-rw-r--r--doc/catalyst.1.txt4
-rw-r--r--examples/tinderbox_template.spec93
-rwxr-xr-xtargets/support/chroot-functions.sh2
-rwxr-xr-xtargets/tinderbox/chroot.sh33
-rwxr-xr-xtargets/tinderbox/controller.sh21
-rwxr-xr-xtargets/tinderbox/preclean-chroot.sh5
10 files changed, 5 insertions, 207 deletions
diff --git a/README b/README
index b398fe30..eb75ba67 100644
--- a/README
+++ b/README
@@ -34,7 +34,6 @@ Catalyst is capable of:
- Building installation stages
- Building bootable LiveCDs
-- Setting up a Tinderbox target for test building
- Building netboot images
Configuring catalyst
diff --git a/catalyst/defaults.py b/catalyst/defaults.py
index 568d8566..7d1de119 100644
--- a/catalyst/defaults.py
+++ b/catalyst/defaults.py
@@ -18,7 +18,7 @@ required_build_targets = ["targetbase", "generic_stage_target"]
# new build types should be added here
valid_build_targets = ["stage1_target", "stage2_target", "stage3_target",
"stage4_target", "livecd_stage1_target", "livecd_stage2_target",
- "embedded_target", "tinderbox_target", "snapshot_target", "netboot_target",
+ "embedded_target", "snapshot_target", "netboot_target",
"netboot2_target"
]
diff --git a/catalyst/targets/tinderbox.py b/catalyst/targets/tinderbox.py
deleted file mode 100644
index 6908793a..00000000
--- a/catalyst/targets/tinderbox.py
+++ /dev/null
@@ -1,47 +0,0 @@
-"""
-Tinderbox target
-"""
-# NOTE: That^^ docstring has influence catalyst-spec(5) man page generation.
-
-import os
-
-from catalyst.support import cmd, CatalystError
-from catalyst.base.stagebase import StageBase
-
-
-class tinderbox(StageBase):
- """
- Builder class for the tinderbox target
- """
- def __init__(self,spec,addlargs):
- self.required_values=["tinderbox/packages"]
- self.valid_values=self.required_values[:]
- self.valid_values.extend(["tinderbox/use"])
- StageBase.__init__(self,spec,addlargs)
-
- def run_local(self):
- # tinderbox
- # example call: "grp.sh run xmms vim sys-apps/gleep"
- try:
- if os.path.exists(self.settings["controller_file"]):
- cmd([self.settings['controller_file'], 'run'] +
- self.settings['tinderbox/packages'], env=self.env)
-
- except CatalystError:
- self.unbind()
- raise CatalystError("Tinderbox aborting due to error.",
- print_traceback=True)
-
- def set_cleanables(self):
- self.settings['cleanables'] = [
- '/etc/resolv.conf',
- '/var/tmp/*',
- self.settings['portdir'],
- ]
-
- def set_action_sequence(self):
- #Default action sequence for run method
- self.settings["action_sequence"]=["unpack","unpack_snapshot",\
- "config_profile_link","setup_confdir","bind","chroot_setup",\
- "setup_environment","run_local","preclean","unbind","clean",\
- "clear_autoresume"]
diff --git a/doc/catalyst-spec.5.txt b/doc/catalyst-spec.5.txt
index 7383afe8..4c0be357 100644
--- a/doc/catalyst-spec.5.txt
+++ b/doc/catalyst-spec.5.txt
@@ -344,7 +344,7 @@ quite a few problems with these, so be careful with whatever `USE`
flags you add here. This is generally used for adding some
functionality that we do not want on by default for all Gentoo users,
but that we want on by default in our binaries. This setting is
-supported by the `stage4`, `netboot2`, and `tinderbox` targets.
+supported by the `stage4` and `netboot2` targets.
*<target>/packages*::
This is the set of packages that we will merge into the stage4 tarball
@@ -353,7 +353,7 @@ fxload irssi wpa_supplicant`). They will be built with the `USE`
flags configured above. These packages must not depend on a
configured kernel. If the package requires a configured kernel, then
it will be defined elsewhere. This setting is supported by the
-`stage4`, `netboot2`, and `tinderbox` targets.
+`stage4`, and `netboot2` targets.
*netboot/packages*::
These package names are also labels used later when determining what
diff --git a/doc/catalyst.1.txt b/doc/catalyst.1.txt
index 9c52878c..46e21e63 100644
--- a/doc/catalyst.1.txt
+++ b/doc/catalyst.1.txt
@@ -18,9 +18,7 @@ DESCRIPTION
-----------
*catalyst* is the tool that the Gentoo Release Engineering team
utilizes to build all Gentoo Linux releases. It is capable of building
-installation stages, bootable LiveCDs, and netboot images. *catalyst*
-is also capable of providing a simple tinderbox environment for package
-testing.
+installation stages, bootable LiveCDs, and netboot images.
For more information, please visit the *catalyst* project page
on the web at 'https://wiki.gentoo.org/wiki/Catalyst'.
diff --git a/examples/tinderbox_template.spec b/examples/tinderbox_template.spec
deleted file mode 100644
index d5575b4a..00000000
--- a/examples/tinderbox_template.spec
+++ /dev/null
@@ -1,93 +0,0 @@
-# generic tinderbox specfile
-
-# The subarch can be any of the supported catalyst subarches (like athlon-xp).
-# Refer to "man catalyst" or <https://wiki.gentoo.org/wiki/Catalyst>
-# for supported subarches
-# example:
-# subarch: athlon-xp
-subarch:
-
-# The version stamp is an identifier for the build. It can be anything you wish
-# it to be, but it is usually a date.
-# example:
-# version_stamp: 2006.1
-version_stamp:
-
-# The target specifies what target we want catalyst to do.
-# example:
-# target: tinderbox
-target: tinderbox
-
-# The rel_type defines what kind of build we are doing. This is merely another
-# identifier, but it useful for allowing multiple concurrent builds. Usually,
-# default will suffice.
-# example:
-# rel_type: default
-rel_type:
-
-# This is the system profile to be used by catalyst to build this target. It is
-# specified as a relative path from /var/db/repos/gentoo/profiles.
-# example:
-# profile: default-linux/x86/2006.1
-profile:
-
-# This specifies which snapshot to use for building this target.
-# example:
-# snapshot: 2006.1
-snapshot:
-
-# This specifies where the seed stage comes from for this target, The path is
-# relative to $clst_sharedir/builds. The rel_type is also used as a path prefix
-# for the seed.
-# example:
-# default/stage3-x86-2006.1
-source_subpath:
-
-# These are the hosts used as distcc slaves when distcc is enabled in your
-# catalyst.conf. It follows the same syntax as distcc-config --set-hosts and
-# is entirely optional.
-# example:
-# distcc_hosts: 127.0.0.1 192.168.0.1
-distcc_hosts:
-
-# This is an optional directory containing portage configuration files. It
-# follows the same syntax as /etc/portage and should be consistent across all
-# targets to minimize problems.
-# example:
-# portage_confdir: /etc/portage
-portage_confdir:
-
-# This option specifies the location to a portage overlay that you would like to
-# have used when building this target.
-# example:
-# portage_overlay: /usr/local/portage
-portage_overlay:
-
-# This allows the optional directory containing the output packages for
-# catalyst. Mainly used as a way for different spec files to access the same
-# cache directory. Default behavior is for this location to be autogenerated
-# by catalyst based on the spec file.
-# example:
-# pkgcache_path: /tmp/packages
-pkgcache_path:
-
-# The tinderbox target can build packages with any USE settings. However, it
-# should be noted that these settings are additive to the settings in the
-# chosen profile. This is extremely useful when testing possible changed to a
-# profile or package.
-# example:
-# tinderbox/use: gtk2 gnome kde qt bonobo cdr esd gtkhtml mozilla mysql perl ruby tcltk cups ldap ssl tcpd -svga
-tinderbox/use:
-
-# This is the list of packages that will be built by the tinderbox target.
-# Each of these is considered a separate target to test, and catalyst will use
-# rsync to reset the build area to the default from the source_subpath before
-# each package. This allows for testing USE changes on individual packages as
-# well as for dependency issues.
-# exampleL
-# tinderbox/packages: dante tsocks sys-apps/eject minicom links acpid apmd parted whois tcpdump cvs zip unzip netcat partimage app-admin/sudo app-cdr/cdrtools gnome emacs dev-lang/ruby enlightenment kde mozilla-firefox mozilla-thunderbird xfce4 openbox fluxbox sylpheed openoffice-bin gimp xemacs xmms abiword gaim xchat pan tetex xcdroast k3b samba nmap gradm ettercap ethereal mplayer
-tinderbox/packages:
-
-# Setting the option overrides the location of the kerncache
-kerncache_path:
-
diff --git a/targets/support/chroot-functions.sh b/targets/support/chroot-functions.sh
index 8996119c..82164f64 100755
--- a/targets/support/chroot-functions.sh
+++ b/targets/support/chroot-functions.sh
@@ -260,7 +260,7 @@ cleanup_stages() {
${clst_sed} -i "/USE=\"\${USE} bindist\"/d" "${clst_make_conf}"
${clst_sed} -i "/USE=\"bindist\"/d" "${clst_make_conf}"
- [ "${clst_target}" != "tinderbox" ] && rm -f /var/log/emerge.log /var/log/portage/elog/*
+ rm -f /var/log/emerge.log /var/log/portage/elog/*
}
update_env_settings(){
diff --git a/targets/tinderbox/chroot.sh b/targets/tinderbox/chroot.sh
deleted file mode 100755
index 431912e4..00000000
--- a/targets/tinderbox/chroot.sh
+++ /dev/null
@@ -1,33 +0,0 @@
-#!/bin/bash
-
-source /tmp/chroot-functions.sh
-
-# START THE BUILD
-setup_pkgmgr
-
-# Backup pristine system
-
-rsync -avx --exclude "/root/" --exclude "/tmp/" --exclude "${clst_repo_basedir}/${clst_repo_name}/" / \
- /tmp/rsync-bak/
-
-for x in ${clst_tinderbox_packages}
-do
- if [[ "${clst_VERBOSE}" == "true" ]]
- then
- run_merge --usepkg --buildpkg --newuse -vp $x
- fi
-
- mkdir -p /tmp/packages/$x
- export PORT_LOGDIR="/tmp/packages/$x"
- run_merge $x
-
- if [ "$?" != "0" ]
- then
- echo "! $x" >> /tmp/tinderbox.log
- else
- echo "$x" >> /tmp/tinderbox.log
- fi
- echo "Syncing from original pristine tinderbox snapshot..."
- rsync -avx --delete --exclude "/root/*" --exclude "/tmp/" --exclude \
- "${clst_repo_basedir}/${clst_repo_name}/" /tmp/rsync-bak/ /
-done
diff --git a/targets/tinderbox/controller.sh b/targets/tinderbox/controller.sh
deleted file mode 100755
index 3dbc76f1..00000000
--- a/targets/tinderbox/controller.sh
+++ /dev/null
@@ -1,21 +0,0 @@
-#!/bin/bash
-
-source ${clst_shdir}/support/functions.sh
-
-case $1 in
- run)
- shift
- exec_in_chroot ${clst_shdir}/tinderbox/tinderbox-chroot.sh
- ;;
- preclean)
- #exec_in_chroot ${clst_shdir}/tinderbox/tinderbox-preclean-chroot.sh
- delete_from_chroot /tmp/chroot-functions.sh
- ;;
- clean)
- exit 0
- ;;
- *)
- exit 1
- ;;
-esac
-exit $?
diff --git a/targets/tinderbox/preclean-chroot.sh b/targets/tinderbox/preclean-chroot.sh
deleted file mode 100755
index 5353f67d..00000000
--- a/targets/tinderbox/preclean-chroot.sh
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/bash
-
-source /tmp/chroot-functions.sh
-
-cleanup_stages