aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sebastian@pipping.org>2012-07-09 16:36:18 +0200
committerSebastian Pipping <sebastian@pipping.org>2012-07-09 16:37:55 +0200
commitdd2efce0306dc0f3a98c8151107038544e1d1296 (patch)
tree10fd08e49ca8959f38dbc0174e0aa499d8a86df7 /Makefile
parentIntroduce catalyst-spec(5) man page (diff)
downloadcatalyst-dd2efce0306dc0f3a98c8151107038544e1d1296.tar.gz
catalyst-dd2efce0306dc0f3a98c8151107038544e1d1296.tar.bz2
catalyst-dd2efce0306dc0f3a98c8151107038544e1d1296.zip
Makefile: Add $(MAN_PAGE_SOURCES) to resolve explicit listing of man pages
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index ef4e78ed..9b03903e 100644
--- a/Makefile
+++ b/Makefile
@@ -2,9 +2,10 @@
# Licensed under GPL v2 or later
PACKAGE_VERSION = `fgrep '__version__=' catalyst | sed 's|^__version__="\(.*\)"$$|\1|'`
-MAN_PAGES = catalyst.1 catalyst-spec.5
+MAN_PAGE_SOURCES = $(wildcard doc/*.?.txt)
+MAN_PAGES = $(patsubst doc/%.txt,files/%,$(MAN_PAGE_SOURCES))
MAN_PAGE_INCLUDES = doc/subarches.generated.txt doc/targets.generated.txt
-EXTRA_DIST = $(MAN_PAGES:%=files/%)
+EXTRA_DIST = $(MAN_PAGES)
CLEAN_FILES = $(EXTRA_DIST) $(MAN_PAGE_INCLUDES)
distdir = catalyst-$(PACKAGE_VERSION)
@@ -12,7 +13,7 @@ distdir = catalyst-$(PACKAGE_VERSION)
all: $(EXTRA_DIST)
-$(MAN_PAGES:%=files/%): files/%: doc/%.txt $(MAN_PAGE_INCLUDES) doc/asciidoc.conf Makefile catalyst
+$(MAN_PAGES): files/%: doc/%.txt $(MAN_PAGE_INCLUDES) doc/asciidoc.conf Makefile catalyst
a2x --conf-file=doc/asciidoc.conf --attribute="catalystversion=$(PACKAGE_VERSION)" \
--format=manpage -D files "$<"