summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-01-21 18:53:18 -0500
committerMichael Orlitzky <mjo@gentoo.org>2016-01-21 18:53:18 -0500
commit79787fcc061362905f0b47a67c922884a27616fc (patch)
tree6f4e0f5ec6436739bacb3f1bbd08adadec163830
parentFix cleanup up libphp[57].so symlinks. (diff)
downloadeselect-php-79787fcc.tar.gz
eselect-php-79787fcc.tar.bz2
eselect-php-79787fcc.zip
Add another layer of indirection to get @bindir@ and friends in the output.
When we create php.eselect from php.eselect.in using autoconf, we don't have a way to get the full, expanded value of @bindir@, @libdir@, and the other paths that we need. The autoconf documentation suggests a workaround for this: add another layer of indirection, and use the Makefile to substitute those values into the output files. This commit sets the stage by renaming php.eselect.in to php.eselect.in.in. The first round of processing by autoconf takes php.eselect.in.in to php.eselect.in. The Makefile will then generate php.eselect from php.eselect.in after substituting @bindir@, @libdir@, and @localstatedir@.
-rw-r--r--Makefile.am19
-rw-r--r--configure.ac2
-rw-r--r--src/php.eselect.in.in (renamed from src/php.eselect.in)0
3 files changed, 19 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 330f491..073abf9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,2 +1,19 @@
eselectdir = $(datadir)/eselect/modules
-nodist_eselect_DATA = src/php.eselect
+nodist_eselect_DATA = $(srcdir)/src/php.eselect
+
+# The next few rules allow us to replace bindir, libdir, and
+# localstatedir within our script and conf file. The example is taken
+# from the autoconf documentation and can be found in the
+# "Installation Directory Variables" section.
+edit = sed -e 's|@bindir[@]|$(bindir)|g' \
+ -e 's|@libdir[@]|$(libdir)|g' \
+ -e 's|@localstatedir[@]|$(localstatedir)|g'
+
+$(nodist_eselect_DATA): Makefile
+ rm -f $@ $@.tmp
+ srcdir=''; \
+ test -f ./$@.in || srcdir=$(srcdir)/; \
+ $(edit) $${srcdir}$@.in > $@.tmp
+ mv $@.tmp $@
+
+$(srcdir)/src/php.eselect: $(srcdir)/src/php.eselect.in
diff --git a/configure.ac b/configure.ac
index 2f1f609..c118e0e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8,6 +8,6 @@ AC_PATH_PROG(SORT,sort)
AC_PATH_PROG(UNIQ,uniq)
# List of output files.
-AC_CONFIG_FILES([Makefile src/php.eselect])
+AC_CONFIG_FILES([Makefile src/php.eselect.in])
AC_OUTPUT
diff --git a/src/php.eselect.in b/src/php.eselect.in.in
index b2a0dd5..b2a0dd5 100644
--- a/src/php.eselect.in
+++ b/src/php.eselect.in.in