summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am19
-rw-r--r--configure.ac2
-rw-r--r--src/php.eselect.in.in (renamed from src/php.eselect.in)0
3 files changed, 19 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 330f491..073abf9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,2 +1,19 @@
eselectdir = $(datadir)/eselect/modules
-nodist_eselect_DATA = src/php.eselect
+nodist_eselect_DATA = $(srcdir)/src/php.eselect
+
+# The next few rules allow us to replace bindir, libdir, and
+# localstatedir within our script and conf file. The example is taken
+# from the autoconf documentation and can be found in the
+# "Installation Directory Variables" section.
+edit = sed -e 's|@bindir[@]|$(bindir)|g' \
+ -e 's|@libdir[@]|$(libdir)|g' \
+ -e 's|@localstatedir[@]|$(localstatedir)|g'
+
+$(nodist_eselect_DATA): Makefile
+ rm -f $@ $@.tmp
+ srcdir=''; \
+ test -f ./$@.in || srcdir=$(srcdir)/; \
+ $(edit) $${srcdir}$@.in > $@.tmp
+ mv $@.tmp $@
+
+$(srcdir)/src/php.eselect: $(srcdir)/src/php.eselect.in
diff --git a/configure.ac b/configure.ac
index 2f1f609..c118e0e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8,6 +8,6 @@ AC_PATH_PROG(SORT,sort)
AC_PATH_PROG(UNIQ,uniq)
# List of output files.
-AC_CONFIG_FILES([Makefile src/php.eselect])
+AC_CONFIG_FILES([Makefile src/php.eselect.in])
AC_OUTPUT
diff --git a/src/php.eselect.in b/src/php.eselect.in.in
index b2a0dd5..b2a0dd5 100644
--- a/src/php.eselect.in
+++ b/src/php.eselect.in.in