summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/box2d/Manifest4
-rw-r--r--dev-libs/box2d/box2d-2.0.1.ebuild56
-rw-r--r--dev-libs/box2d/files/box2d-2.0.1-gcc4.patch25
-rw-r--r--dev-libs/box2d/metadata.xml9
-rw-r--r--games-arcade/jamp/Manifest4
-rw-r--r--games-arcade/jamp/files/jamp-1.0.2-ownbox2d.patch35
-rw-r--r--games-arcade/jamp/jamp-1.0.2.ebuild43
-rw-r--r--games-arcade/jamp/metadata.xml9
8 files changed, 185 insertions, 0 deletions
diff --git a/dev-libs/box2d/Manifest b/dev-libs/box2d/Manifest
new file mode 100644
index 0000000..b3eaf8f
--- /dev/null
+++ b/dev-libs/box2d/Manifest
@@ -0,0 +1,4 @@
+AUX box2d-2.0.1-gcc4.patch 809 RMD160 2af0a29c3a8b9a09901939bcfbb27fe185c26fc1 SHA1 57115719f6de29b8601e2faddbe482c2a9a1dc29 SHA256 5aa81532c9039b9fdfa44dab6dac9cae4815731227e6a46d3a5fe12cb1acce0e
+DIST Box2D_v2.0.1.zip 866019 RMD160 4a1e4b62c814b9a562d1ca6b580bfec83a7ad8a9 SHA1 27a1a0bd08c81bbf661fa008645ee5c538bb2767 SHA256 62857048aa089b558561074154430883cee491eedd71247f75f488cba859e21f
+EBUILD box2d-2.0.1.ebuild 1207 RMD160 a023e169ab6e492e6b7390ef255e91ad61f0b4cb SHA1 d0eb14003361d748bdd8f9a0da44bae6818acb73 SHA256 0edb253964f1efbac2982b526ef6e553975adbd80f5f59bbdf17df8cb5a429af
+MISC metadata.xml 249 RMD160 220cde0fc1a8d7d355705f0f6772bd8d77cdc17a SHA1 34b33eb8d24cd8bfef2ddfb8e80334fd77cc9488 SHA256 3875fd5008d7f5bfe7f3cf7bf330c209a5034f5988d37c1699fb3be35a7be906
diff --git a/dev-libs/box2d/box2d-2.0.1.ebuild b/dev-libs/box2d/box2d-2.0.1.ebuild
new file mode 100644
index 0000000..767815d
--- /dev/null
+++ b/dev-libs/box2d/box2d-2.0.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+MY_PN=Box2D
+
+inherit eutils
+
+IUSE=""
+
+DESCRIPTION="Box2D is an open source physics engine written primarily for games."
+HOMEPAGE="http://www.box2d.org"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}_v${PV}.zip"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="media-libs/freeglut
+ app-arch/unzip"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${MY_PN}_v${PV}/${MY_PN}/Source
+
+src_prepare(){
+ epatch "${FILESDIR}"/${P}-gcc4.patch
+ sed -i -e "s:../Source/::g" -i ../Include/Box2D.h || die sed failed
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ dodoc ../Readme.txt
+
+ dolib.a Gen/float/lib${PN}.a
+
+ insinto /usr/include/${MY_PN}/
+ doins ../Include/${MY_PN}.h
+ insinto /usr/include/${MY_PN}/Collision/
+ doins Collision/*.h
+ insinto /usr/include/${MY_PN}/Collision/Shapes/
+ doins Collision/Shapes/*.h
+ insinto /usr/include/${MY_PN}/Common/
+ doins Common/*.h
+ insinto /usr/include/${MY_PN}/Dynamics/
+ doins Dynamics/*.h
+ insinto /usr/include/${MY_PN}/Dynamics/Contacts/
+ doins Dynamics/Contacts/*.h
+ insinto /usr/include/${MY_PN}/Dynamics/Joints/
+ doins Dynamics/Joints/*.h
+}
diff --git a/dev-libs/box2d/files/box2d-2.0.1-gcc4.patch b/dev-libs/box2d/files/box2d-2.0.1-gcc4.patch
new file mode 100644
index 0000000..16da07c
--- /dev/null
+++ b/dev-libs/box2d/files/box2d-2.0.1-gcc4.patch
@@ -0,0 +1,25 @@
+diff -Naur Box2D/Source/Common/b2BlockAllocator.cpp Box2D/Source/Common/b2BlockAllocator.cpp
+--- Box2D/Source/Common/b2BlockAllocator.cpp 2007-11-24 11:25:02.000000000 +0100
++++ Box2D/Source/Common/b2BlockAllocator.cpp 2009-10-12 15:56:39.000000000 +0200
+@@ -20,6 +20,7 @@
+ #include <cstdlib>
+ #include <memory>
+ #include <climits>
++#include <cstring>
+
+ int32 b2BlockAllocator::s_blockSizes[b2_blockSizes] =
+ {
+diff -Naur Box2D/Source/Common/b2Math.h Box2D/Source/Common/b2Math.h
+--- Box2D/Source/Common/b2Math.h 2008-04-07 23:35:04.000000000 +0200
++++ Box2D/Source/Common/b2Math.h 2009-10-12 15:55:44.000000000 +0200
+@@ -23,8 +23,8 @@
+ #include <cmath>
+ #include <cfloat>
+ #include <cstdlib>
+-
+-#include <stdio.h>
++#include <cstring>
++#include <cstdio>
+
+ #ifdef TARGET_FLOAT32_IS_FIXED
+
diff --git a/dev-libs/box2d/metadata.xml b/dev-libs/box2d/metadata.xml
new file mode 100644
index 0000000..4e4714e
--- /dev/null
+++ b/dev-libs/box2d/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>frostworks@gmx.de</email>
+ <name>Marcel Unbehaun</name>
+</maintainer>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-arcade/jamp/Manifest b/games-arcade/jamp/Manifest
new file mode 100644
index 0000000..7e5902d
--- /dev/null
+++ b/games-arcade/jamp/Manifest
@@ -0,0 +1,4 @@
+AUX jamp-1.0.2-ownbox2d.patch 1005 RMD160 42b7f5132b6868a2c7cb655674d2ee7585c7332b SHA1 4d2926c066b95bd1d3dcb2456aeb9440096d117a SHA256 69617e445313ac2168834d9cb6a70c760e4f26b79db0e4279ddc74c0161081a7
+DIST jamp-1.0.2.tar.gz 4436414 RMD160 64f6c50e5b04044223bb95f77f041e21dbb54bdd SHA1 da622561e0d12d8e5028e6e7d98c08bd1de2e515 SHA256 6756cdb881e31fad2a18a072dbe1dfa4393bd56995527f37a3950fd3fd7b928d
+EBUILD jamp-1.0.2.ebuild 895 RMD160 0885ab39decd515c966371251728bbc267234dfe SHA1 4c432954779750727f192101b3169bed947de55f SHA256 120f6d30df0ad661f108a2a1b2058061ae4441e4183dd80ad57a2b810034bdef
+MISC metadata.xml 249 RMD160 220cde0fc1a8d7d355705f0f6772bd8d77cdc17a SHA1 34b33eb8d24cd8bfef2ddfb8e80334fd77cc9488 SHA256 3875fd5008d7f5bfe7f3cf7bf330c209a5034f5988d37c1699fb3be35a7be906
diff --git a/games-arcade/jamp/files/jamp-1.0.2-ownbox2d.patch b/games-arcade/jamp/files/jamp-1.0.2-ownbox2d.patch
new file mode 100644
index 0000000..5c689b1
--- /dev/null
+++ b/games-arcade/jamp/files/jamp-1.0.2-ownbox2d.patch
@@ -0,0 +1,35 @@
+diff -Naur jamp-1.0.2/cLevel.cpp jamp-1.0.2-p/cLevel.cpp
+--- jamp-1.0.2/cLevel.cpp 2009-01-15 23:36:24.000000000 +0100
++++ jamp-1.0.2-p/cLevel.cpp 2009-10-12 17:01:02.000000000 +0200
+@@ -496,7 +496,7 @@
+ m_world->SetContinuousPhysics(true);
+ m_pointCount = 0;
+
+- m_world->Step(timeStep, 10, 8);
++ m_world->Step(timeStep, (10, 8));
+ Singleton<cActorManager>::Ptr()->UpdateAllFromPhysics();
+ if (!m_debugPressed)
+ {
+diff -Naur jamp-1.0.2/Makefile jamp-1.0.2-p/Makefile
+--- jamp-1.0.2/Makefile 2009-10-12 16:50:07.000000000 +0200
++++ jamp-1.0.2-p/Makefile 2009-10-12 17:01:35.000000000 +0200
+@@ -2,8 +2,8 @@
+ SHAREDIR = /usr/share
+ DATADIR = /usr/share/games
+
+-PROJECT= ./box2d
+-CXXFLAGS= -g -O2 -I$(PROJECT)/Include
++PROJECT= Box2D
++CXXFLAGS= -g -O2 -I/usr/include/$(PROJECT)
+ SOURCES=\
+ cActorManager.cpp \
+ cCamera.cpp \
+@@ -21,7 +21,7 @@
+ cTextureManager.cpp \
+ Level1.cpp
+ all:
+- (cd box2d/Source; $(MAKE))
++# (cd box2d/Source; $(MAKE))
+ ($(MAKE) jamp)
+
+ clean:
diff --git a/games-arcade/jamp/jamp-1.0.2.ebuild b/games-arcade/jamp/jamp-1.0.2.ebuild
new file mode 100644
index 0000000..8deda7f
--- /dev/null
+++ b/games-arcade/jamp/jamp-1.0.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="Squirrel Physics (codename JAMP)"
+HOMEPAGE="http://perre.noud.ch/jamp/"
+SRC_URI="http://perre.noud.ch/jamp/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl
+ media-libs/mesa
+ media-libs/sdl-image
+ dev-libs/box2d
+ media-libs/sdl-mixer"
+DEPEND="${RDEPEND}"
+
+src_prepare(){
+ epatch ${FILESDIR}/"${P}-ownbox2d.patch"
+ sed -e "s:/usr/games:${GAMES_BINDIR}:g" -i Makefile || die "sed failed"
+}
+
+src_install() {
+ dogamesbin ${PN}
+ local datadir="${GAMES_DATADIR}"/"${PN}"
+ dodir ${datadir}
+ insinto "${GAMES_DATADIR}"/"${PN}"
+ doins -r images shapes sounds || die
+ newicon images/"${PN}.png" "${PN}.png"
+ make_desktop_entry "${PN}" "${PN}"
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+}
diff --git a/games-arcade/jamp/metadata.xml b/games-arcade/jamp/metadata.xml
new file mode 100644
index 0000000..4e4714e
--- /dev/null
+++ b/games-arcade/jamp/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>frostworks@gmx.de</email>
+ <name>Marcel Unbehaun</name>
+</maintainer>
+<herd>games</herd>
+</pkgmetadata>